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1 Installing Weintek Built-in CODESYS 

Installing Weintek Built-in CODESYS allows users to easily create a cMT+CODESYS 

project in CODESYS software. Please find the Package file we prepared and follow 

these steps for quick installation. 

1. First, get a copy of CODESYS Package file. 

 
2. On your PC, right-click the mouse button and select [Open with CODESYS 

Package Manager]. 

 

3. Select Complete Setup or Typical Setup (you may select any of these setup 

types since the components used by Weintek Built-in CODESYS exist in both 

types.) 

 
4. Click [Next] when seeing the following message. 
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5. The installed component will be shown in the installation summary. 
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2 Connecting cMT CODESYS 

2.1 Connecting Through Network 

1. Connect cMT model’s LAN 1 port with a router or PC. 

2. Tap Start button to open HMI system settings window. 

 

3. Open CODESYS page and find the IP address. By default, DHCP is used and 

it will automatically obtain an IP address. 

 

2.2 Creating CODESYS Project 

1. Launch CODESYS V3.5 and click [File] » [New Project], and then select 

[Standard project]. Enter the project name in Name filed, browse for the 

location, and then click [OK] to leave. 
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2. Select Weintek Built-in CODESYS. CODESYS software provides 6 languages 

that can be selected in [PLC_PRG in:] drop-down list as shown below. 

Structure Text (ST) is used as an example in this manual. 

 

3. Double-click on Device (Weintek Built-in CODESYS) to open the settings 

window. 
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4. Open Scan Network tab, CODESYS software will start searching for the 

CODESYS devices on the same network. Select the desired device and then 

click [OK] to leave. The last two IP address parts (between dots) are 

converted into HEX digits and shown in this window. For example, if the IP 

address of the CODESYS device is 192.168.2.118, please select HMI 

Name[0276]. 

 

5. The project will connect the selected device. 
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Note 

 IP address of the device can be entered in the field shown below. 
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3 Creating EasyBuilder Project 

*Please use EasyBuilder Pro v6.00.02 build 20180410 or later versions. 

3.1 Creating Tags 

1. Create several tags in PLC_PRG tab and make tag “test” accumulate 

automatically. 

 

3.2 Exporting Tag 

1. Right-click on Application in Devices tree and then select [Add Object] » 

[Symbol Configuration], use defaults. 

 

2. Find PLC_PRG, select the variables to be exported, and then click [Build]. 

 
3. Select [Build] » [General code], the *.xml file can be found in the directory 

of the project. 
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3.3 Configuring EasyBuilder 

1. Create a project and select Weintek Built-in CODESYS in the device list. 

 

2. Open Tag Manager and click , and then click [Import Tag] to import 

the *.xml file built in preceding steps. 

 

3. The CODESYS tags can now be found in Tag Manager. 
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4. Create a Numeric object and use “Application.PLC_PRG.test” for address. 

After downloading the project to HMI, “test” tag data can be found. 
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4 Connecting cMT CODESYS to iR-COP 

1. Right-click on Device (Weintek Built-in CODESYS) and then select [Add 

Device]. 

2. Select [CANbus] » [CANbus], and then select [Add Device]. 

 

3. CANbus (CANbus) can be found in Devices tree. 

 

4. Double-click on CANbus (CANbus) with the current window opened in 

Devices tree, or right-click on CANbus (CANbus) and then select [Add 

Device]. 

5. Click [Fieldbusses] » [CANopen] » [CANopen Manager] » [CANopen 

Manager], and then select [Add Device]. 

 



 

cMT+CODESYS and Remote I/O Quick Start Guide 
 

 

11 
 

6. Double-click on CANopen_Manager with the current window opened in 

Devices tree or right-click on CANopen_Manager and then click [Add 

Device]. 

7. Click [Fieldbusses] » [CANopen] » [Remote Device], find iR-COP and then 

select [Add Device]. 

 

8. Under [iR-COP] select [Miscellaneous], add I/O module and then select 

[Add Device]. 

 

9. Double click on CANbus (CANbus) in Devices tree to open the settings 

window. Please select the correct baud rate for iR-COP in General tab. 
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10. Create CANopen variables in PLC_PRG, for example: 

 

11. Double click on iR_Cop in Devices tree to open the settings window. Select 

related variables in CANopen I/O Mapping tab. 

 

12. When finished, click [Online] » [Login] to download the project to 

CODESYS. 
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5 Connecting cMT CODESYS to iR-ETN 

1. Right-click on Device (Weintek Built-in CODESYS/cMT-CTRL) and then select 

[Add Device]. 

2. Select [Ethernet Adapter] » [Ethernet] and then click [Add Device]. 

 

3. Ethernet (Ethernet) can be found in Devices tree. 

 

4. Double-click on Ethernet with the current window opened in Devices tree 

or right-click on Ethernet and then select [Add Device]. 

5. Click [Fieldbusses] » [Modbus] » [Modbus TCP Master] » [Modbus TCP 

Master], and then select [Add Device]. 

 

6. Double-click on Modbus TCP Master with the current window opened in 

Devices tree or right-click on Modbus TCP Master and then click [Add 
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Device]. 

7. Click [Fieldbusses] » [Modbus] » [Modbus TCP Slave] » [Modbus TCP Slave], 

and then select [Add Device]. 

 

8. Double click on Ethernet in the Devices tree, enter CODESYS’s IP address in 

General tab, and then select [Change Operating System Settings]. 

 

9. When CODESYS is already connected, go to General tab and click the […] 

button near Interface field and select eth0. 

 
10. Select Modbus_TCP_Slave in the Devices tree and then go to General tab 

to set up IR-ETN’s IP address and Unit ID. 
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11. Open [Modbus Slave Channel] tab and create Modbus Variable. 

 

 

12. Open PLC_PRG in Devices tree, create tag and set Bool as data type. Write 
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a command as shown below. 

 

13. Open Modbus_TCP_Slave in Devices tree and then go to 

[Modbus_TCPSlave I/O Mapping] tab to set variable mapping. 

 

14. When finished, click [Online] » [Login] to download the project to 

CODESYS. 
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6 Connecting cMT CODESYS to iR-ECAT 

1. Right-click on Device (Weintek Built-in CODESYS/cMT-CTRL) and then select 

[Add Device]. 

2. Select [EtherCAT] » [Master] » [EtherCAT Master] and then click [Add 

Device]. 

 

3. EtherCAT_Master can be found in Devices tree. 

 

4. Double-click on EtherCAT_Master with the current window opened or in 

Devices tree right-click on EtherCAT_Master and then select [Add Device]. 

5. Click [Fieldbusses] » [EtherCAT] » [Slave] » [iR-ECAT], and then select [Add 

Device]. 
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6. Double-click on iR-ECAT in Devices tree with the current window opened or 

right-click on iR-ECAT and then click [Add Device]. 

7. Click [Fieldbusses] » [EtherCAT] » [Module], and then select [Add Device]. 

 

8. Double click on EtherCAT in the Devices tree, click Browse in General tab, 

and then select [eth0]. 

 

9. Open PLC_PRG in Devices tree, create tag and set Bool as data type. Write 

a command as shown below. 
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10. In Devices tree open iR-ECAT » [EtherCAT I/O Mapping] and configure the 

settings. 

 

 

11. When finished, click [Online] » [Login] to download the project to 

CODESYS. 
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7 cMT-CTRL01 Quick Start 

1. Right-click on iBus and select [Add Device]. 

2. Select [Miscellaneous], add the iR modules connected to cMT-CTRL01, and 

click [Add Device]. 

 

3. Open PLC_PRG in Devices tree, create tag and set Bool as data type. Write 

a command as shown below. 

 

4. In Devices tree open iR module list » [Module I/O Mapping] tab and 

configure the settings. 

 

 

5. When finished, click [Online] » [Login] to download the project to 

CODESYS. 
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8 CODESYS Ethernet/IP Scanner Quick Start 

CODESYS limitation: Currently, only the Ethernet/IP Scanner in CODESYS version 

3.5.15 is supported. Using other versions may result in compilation failures. 

 

1. Right-click on Device (Weintek Built-in CODESYS/cMT-CTRL) and then select 

[Add Device]. 

2. Select [Ethernet Adapter] » [Ethernet] and then click [Add Device]. 

 

3. Ethernet (Ethernet) can be found in Devices tree. 

 

4. With the current window opened, double-click on [Ethernet] in Devices 

tree or right-click on [Ethernet] in Devices tree and then select [Add 

Device]. 

5. Click [Fieldbuses] » [Ethernet/IP] » [Ethernet/IP Scanner] » [Ethernet/IP 

Scanner], and then select [Add Device]. 
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6. With the current window opened, double-click on [EtherNet/IP Scanner] in 

Devices tree or right-click on [EtherNet/IP Scanner] in Devices tree and 

then select [Add Device]. 

7. Click [Fieldbuses] » [EtherNet/IP] » [EtherNet/IP Remote Adapter] » 

[iR-ETN], and then select [Add Device]. 

For more information about how to generate and add iR-ETN.eds file, 

please see chapters 1 and 2 in iR-ETN EtherNet/IP Connection Guide. 

 

8. When CODESYS is already connected, go to General tab and click the 

[Browse…] button near Interface field and select eth0. 

 
9. Select iR-ETN in Devices tree and then go to General tab to set up IR-ETN’s 

https://dl.weintek.com/public/Document/UM0/UM020006E_iR-ETN_EtherNetIP_Connection_Guide_eng.pdf
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IP address. 

 

10. Open PLC_PRG in Devices tree, create tag and set Bool as data type. Write 

a command as shown below. 

 

11. In Devices tree open iR_ETN » [Ethernet/IP I/O Mapping] tab and configure 

the settings. 

 

 

12. When finished, click [Online] » [Login] to download the project to 

CODESYS. 
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9 Starting iR Analog Modules 

9.1 Analog Module Wiring 

Please see UM018013E_iR-Axxx-VI_UserManual_eng.pdf for information on wiring 

when using iR-AI04-VI,iR-AM06-VI,iR-AQ04-VI modules. 

Please see UM018014E_iR-Axxx-TR_UserManual_eng.pdf for information on wiring 

when using iR-AI04-TR module. 

9.2 Setting Analog Channels 

9.2.1 Using EasyRemoteIO to Set Channels (iR-ETN) 

1. Search for iR-ETN on the network. 

 

2. Open the parameter tab of the module to be set. 

 
3. Enter the parameters as shown below. 

 
4. Download the project to finish setting parameters. 

https://dl.weintek.com/public/iR/eng/UserManual/UM018013E_iR-Axxx-VI_UserManual_eng.pdf
https://dl.weintek.com/public/iR/eng/UserManual/UM018014E_iR-Axxx-TR_UserManual_eng.pdf
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9.2.2 Using CODESYS to Set Channels (iR-ETN) 

1. Add iR-ETN in CODESYS according to the wiring diagram. 

2. [Modbus_TCP_Slave] » [Modbus Slave Init] » [New] 

 

 

 

Find iR-ETN Modbus Address Mapping table in these user manuals: 

For analog modules see UM018013E_iR-Axxx-VI_UserManual_eng.pdf 

For temperature module see UM018014E_iR-Axxx-TR_UserManual_eng.pdf 

 

3. When finished, click [Online] » [Login] to download the project to 

https://dl.weintek.com/public/iR/eng/UserManual/UM018013E_iR-Axxx-VI_UserManual_eng.pdf
https://dl.weintek.com/public/iR/eng/UserManual/UM018014E_iR-Axxx-TR_UserManual_eng.pdf
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CODESYS. 

Exporting PLCopenXML from EasyRemoteIO: 

1. Open EasyRemoteIO » [File] » [Export PLCopen XML]. 

2. Select Modbus_TCP_Master device, open Project tab » [Import 

PLCopenXML File]. 

 
Parameter settings in EasyRemoteIO will be imported to CODESYS, and the 

parameters are written to the module after login. 

 

9.2.3 Using CODESYS to Set Channels (iR-COP) 

1. Add iR-COP following the steps explained in Chapter 4 in this manual. 

2. [iR_COP] » [SDOs] » [Add SDO] 
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Find iR-COP Address Mapping table in these user manuals: 

For analog modules see UM018013E_iR-Axxx-VI_UserManual_eng.pdf 

For temperature modules see UM018014E_iR-Axxx-TR_UserManual_eng.pdf 

 

3. When finished, click [Online] » [Login] to download the project to 

CODESYS. 

 

9.2.4 Using CODESYS to Set Channels (iR-ECAT) 

1. Add iR-ECAT following the steps explained in Chapter 6 in this manual. 

2. [iR_ECAT] » [Startup Parameters] » [Add] 

 

https://dl.weintek.com/public/iR/eng/UserManual/UM018013E_iR-Axxx-VI_UserManual_eng.pdf
https://dl.weintek.com/public/iR/eng/UserManual/UM018014E_iR-Axxx-TR_UserManual_eng.pdf
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3. When finished, click [Online] » [Login] to download the project to 

CODESYS. 

9.3 Analog Channel IO Mapping 

9.3.1 Reading / Writing iR-ETN Channels 

1. [Modbus_TCP_Slave] » [Modbus Slave Channel] » [Add Channel] 
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Channel Input Function Code 3 & 4, Modbus address start from 0x0000. 

Channel Output Function Code 6 & 16, Modbus address start from 0x0100. 

See UM018002E_iR-ETN_UserManual_eng.pdf for information on: 

Analog Input Mapping to Modbus (also applicable for temperature module). 

Analog Output Mapping to Modbus. 

2. Open PLC_PRG in Devices tree, create tag and set INT as data type. Write a 

command as shown below. 

 

3. In Devices tree open Modbus_TCP_Slave » [ModbusTCPSlave I/O Mapping] 

tab and configure the settings. 

 

 

4. When finished, click [Online] » [Login] to download the project to 

CODESYS. 

 

 

9.3.2 Reading / Writing iR-COP Channels 

1. Add Analog module. 

https://dl.weintek.com/public/iR/eng/UserManual/UM018002E_iR-ETN_UserManual_eng.pdf
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2. Open PLC_PRG in Devices tree, create tag and set INT as data type. Write a 

command as shown below. 

 

3. In Devices tree open the list of Analog Module » [CANopen-Module I/O 

Mapping] tab and configure the settings. 

 

 

4. When finished, click [Online] » [Login] to download the project to 

CODESYS. 

 

9.3.3 Reading / Writing iR-ECAT Channels 

1. Add Analog module. 
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2. Open PLC_PRG in Devices tree, create tag and set INT as data type. Write a 

command as shown below. 

 

3. In Devices tree open the list of iR-ECAT » [EtherCAT I/O Mapping] tab and 

configure the settings. 

 

4. When finished, click [Online] » [Login] to download the project to 

CODESYS. 

 

9.3.4 Reading / Writing cMT-CTRL01 Channels 

1. Add Analog module. 
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2. Open PLC_PRG in Devices tree, create tag and set INT as data type. Write a 

command as shown below. 

 

3. In Devices tree open the [iR_AM06_VI] » [Module I/O Mapping] tab and 

configure the settings. 

 

4. When finished, click [Online] » [Login] to download the project to 

CODESYS. 

 

9.4 Accessing Analog Module Registers Using Function Blocks 

Before proceeding, make sure that the cMT+CODESYS Package has been downloaded 

and installed. 

 

9.4.1 iR-ETN 

1. Add the [Ethernet], [Modbus_TCP_Master], and [Modbus_TCP_Slave] 

devices, and configure their communication parameters. For detailed 

instructions, refer to Chapter 5 of this manual: 

[Device] » [Add device] » [Ethernet]. 

[Ethernet] » [Add device] » [Modbus_TCP_Master]. 

[Modbus_TCP_Master] » [Add device] » [Modbus_TCP_Slave]. 

 

2. Declare the ModbusRequest function block and its associated function 

block parameters. Log in to CODESYS to proceed. 
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3. After assigning address parameters in CODESYS, trigger “xExecute” to read 

the data, which will be displayed in “Data”. 

 
※ ModbusCommand's function code 3 (ReadHoldingRegister) is used to 

read word addresses. 

※ For Modbus address mapping, refer to “Analog Module Manual 

Chapter 8” for detailed information. 

 

9.4.2 iR-COP 

1. Add the [CANbus], [CANopen_Manager], [iR_COP], [iR_Module] devices, 

and configure their communication parameters. For detailed instructions, 

refer to Chapter 4 of this manual: 

[Device] » [Add device] » [CANbus]. 

[CANopen_Manager] » [Add device] » [iR_COP]. 

[iR_COP] » [Add device] » [iR_AM06_VI]. 

 

2. Declare the CIA405.SDO_READ function block and its associated function 

block parameters. Log in to CODESYS to proceed. 

https://dl.weintek.com/public/iR/eng/UserManual/UM018013E_iR-Axxx-VI_UserManual_eng.pdf
https://dl.weintek.com/public/iR/eng/UserManual/UM018013E_iR-Axxx-VI_UserManual_eng.pdf
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3. After assigning required parameters in CODESYS, trigger “ENABLE” to read 

the data, which will be displayed in “DATA”. 

 
※ The iR_COP Coupler Node_ID corresponds to the DEVICE. Refer to 

[iR_COP] » [General] » [Node ID] for more information.  

※ For INDEX and SUBINDEX address mapping, refer to “Analog Module 

Manual Chapter 9” for detailed information. 

 

9.4.3 iR-ECAT 

1. Add the [EtherCAT_Master], [iR_ECAT], [iR_Module] devices, and configure 

their communication parameters. For detailed instructions, refer to 

Chapter 6 of this manual: 

[Device] » [Add device] » [EtherCAT_Master]. 

[EtherCAT_Master] » [Add device] » [iR_ECAT]. 

[iR_ECAT] » [Add device] » [iR_AM06_VI]. 

 

2. Declare the ETC_CO_Read function block and its associated function block 

parameters. Log in to CODESYS to proceed. 

https://dl.weintek.com/public/iR/eng/UserManual/UM018013E_iR-Axxx-VI_UserManual_eng.pdf
https://dl.weintek.com/public/iR/eng/UserManual/UM018013E_iR-Axxx-VI_UserManual_eng.pdf
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3. After assigning required parameters in CODESYS, trigger “xExecute” to read 

the data, which will be displayed in “Data”. 

 
※The EtherCAT Coupler's address corresponds to uiDevice. Please refer to 

[iR_ECAT] » [General] » [EtherCAT address] for more information.  

※For module sequence addressing, use wIndex, where the Index address 

of the first analog module is 16#8000.  

※The address mapping for analog module's registers is done using 

bySubIndex. 

 

9.4.4 cMT-CTRL01 

1. Under [iBus] » [Add device], add the analog module. 

 

2. Under [Library Manager] » [Add Library], add Weintek iBus Library. 

 

3. Declare the iBus.iBus_Reg_Read function block and log in to CODESYS. 
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4. Input the desired parameter into the function block for reading, then 

trigger "Execute" to display the current value in "Data". 

※ For input parameter configuration, refer to "Weintek Library User 

Manual Chapter 10 - Weintek iBus Library". 

 

 

10 Starting iR Motion Control Module 

10.1  Motion Control Module Wiring 

Please see UM019004E_iR-PU01-P_UserManual_eng.pdf for information on wiring 

when using iR-PU01-P module. 

 

10.2  Setting Motion Control Module Parameters 

10.2.1 Writing Motion Control Parameters from iR-ETN 

1. Add iR-ETN following the steps explained in Chapter 5 in this manual. 

2. Go to [Library Manager] » [Add library] and add Weintek_CODESYS_Library 

V1.0.0.3. 

3. The Function Blocks for writing parameters to iR-PU01P are placed in the 

ETN_PU folder. 

https://dl.weintek.com/public/iR/eng/UserManual/UM018017E_CODESYS_Weintek_Library_UserManual_eng.pdf
https://dl.weintek.com/public/iR/eng/UserManual/UM018017E_CODESYS_Weintek_Library_UserManual_eng.pdf
https://dl.weintek.com/public/iR/eng/UserManual/UM019004E_iR-PU01-P_UserManual_eng.pdf
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4. Write iR-PU01-P parameters in the program. 

 

5. When finished, click [Online] » [Login] and download the project to 

CODESYS. Trigger Execute to write parameters into iR-PU01-P. 

 

10.2.2 Writing Motion Control Parameters from iR-COP 

1. Add iR-COP following the steps explained in Chapter 4 in this manual. 

2. [iR_COP] » [SDOs] » [Add SDO] 
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See UM019004E_iR-PU01-P_UserManual_eng.pdf for information on motion 

control parameter configuration and object dictionary when using analog 

modules. 

 

3. When finished, click [Online] » [Login] and download the project to 

CODESYS. 

 

10.2.3 Writing Motion Control Parameters from iR-ECAT 

1. Add iR-ECAT following the steps explained in Chapter 6 in this manual. 

2. [iR_ECAT] » [Startup Parameters] » [Add] 

 

https://dl.weintek.com/public/iR/eng/UserManual/UM019004E_iR-PU01-P_UserManual_eng.pdf
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See UM019004E_iR-PU01-P_UserManual_eng.pdf for information on motion 

control parameter configuration and object dictionary when using analog 

modules. 

 

3. When finished, click [Online] » [Login] and download the project to 

CODESYS. 

 

10.3  Motion Control Module I/O Mapping 

10.3.1 Reading / Writing iR-ETN Channels 

1. Add Weintek_CODESYS_Library and follow the steps in Chapter 5 in this 

manual to add Modbus TCP device. 

 
2. Add motion control channels and NMT network management channels. 

https://dl.weintek.com/public/iR/eng/UserManual/UM019004E_iR-PU01-P_UserManual_eng.pdf
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3. Open PLC_PRG in Devices tree, create tag and set AXIS_REF_Lite as data 

type. Edit motion control function blocks as shown below. 

 
4. In Devices tree open [iR-COP] » [CANopen I/O Mapping] tab to configure 

the settings. 

 

5. When finished, click [Online] » [Login] and download the project to 

CODESYS. After triggering xExecute_0, iR-PU01-P enters standstill state. 

 

10.3.2 Reading / Writing iR-COP Channels 

1. Add Weintek_CODESYS_Library. 
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2. Add motion control modules. 

 

3. Open PLC_PRG in Devices tree, create tag and set AXIS_REF_Lite as data 

type. Edit motion control function blocks as shown below. 
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4. In Devices tree open [iR_COP] » [CANopen I/O Mapping] tab and configure 

the settings. 

 
 

5. When finished, click [Online] » [Login] to download the project to CODESYS. 

After triggering xExecute_0, iR-PU01-P enters standstill state. 

 

10.3.3 Reading / Writing iR-ECAT Channels 

1. Add Weintek_CODESYS_Library. 
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2. Add motion control modules. 

 

3. Open PLC_PRG in Devices tree, create tag and set AXIS_REF_Lite as data 

type. Edit motion control function blocks as shown below. 
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4. In Devices tree open [iR_ECAT] » [EtherCAT I/O Mapping] tab and configure 

the settings. 

 
 

5. When finished, click [Online] » [Login] to download the project to CODESYS. 

After triggering xExecute_0, iR-PU01-P enters standstill state. 

 

10.3.4 Reading / Writing cMT-CTRL01 Channels 

1. Add Weintek_CODESYS_Library. 
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2. Add the motion control module. 

 
3. Open PLC_PRG in Devices tree, create tag and set AXIS_REF_Lite as data 

type. Edit motion control function blocks as shown below. 
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4. In Devices tree open [iR_ECAT] » [EtherCAT I/O Mapping] tab and configure 

the settings. 

 

 

5. When finished, click [Online] » [Login] to download the project to CODESYS. 

After triggering xExecute_0, iR-PU01-P enters standstill state. 

 

10.4  Accessing Motion Control Module Registers Using Function Blocks 

10.4.1 iR-ETN 

1. Add the [Ethernet], [Modbus_TCP_Master], and [Modbus_TCP_Slave] 

devices, and configure their communication parameters. For detailed 

instructions, refer to Chapter 5 of this manual: 

[Device] » [Add device] » [Ethernet]. 

[Ethernet] » [Add device] » [Modbus_TCP_Master]. 

[Modbus_TCP_Master] » [Add device] » [Modbus_TCP_Slave].  

 

2. Under [Library Manager] » [Add Library], add Weintek_CODESYS_Library. 
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3. Declare the weintek.ETN_PU_SDO function block and its associated 

function block parameters. Log in to CODESYS to proceed. 

 

4. After assigning address parameters in CODESYS, trigger “Read” to read the 

data, which will be displayed in “Data”. 

 

※ For Index and Sub_Index address mapping, refer to “iR-PU01-P User 

Manual” for detailed information. 

 

10.4.2 iR-COP 

1. Add the [CANbus], [CANopen_Manager], [iR_COP], [iR_Module] devices, 

and configure their communication parameters. For detailed instructions, 

refer to Chapter 4 of this manual: 

[Device] » [Add device] » [CANbus]. 

[CANopen_Manager] » [Add device] » [iR_COP]. 

[iR_COP] » [Add device] » [iR_PU01_P].  

 

2. Declare the CIA405.SDO_READ function block and its associated function 

block parameters. Log in to CODESYS to proceed. 

https://dl.weintek.com/public/iR/eng/UserManual/UM019004E_iR-PU01-P_UserManual_eng.pdf
https://dl.weintek.com/public/iR/eng/UserManual/UM019004E_iR-PU01-P_UserManual_eng.pdf
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3. After assigning required parameters in CODESYS, trigger “ENABLE” to read 

the data, which will be displayed in “DATA”. 

 
※ The iR_COP Coupler Node_ID corresponds to the DEVICE. Refer to 

[iR_COP] » [General] » [Node ID] for more information. 

※ For INDEX and SUBINDEX address mapping, refer to “iR-PU01-P User 

Manual” for detailed information. 

 

10.4.3 iR-ECAT 

1. Add the [EtherCAT_Master], [iR_ECAT], [iR_Module] devices, and configure 

their communication parameters. For detailed instructions, refer to 

Chapter 6 of this manual: 

[Device] » [Add device] » [EtherCAT_Master]. 

[EtherCAT_Master] » [Add device] » [iR_ECAT]. 

[iR_ECAT] » [Add device] » [iR_PU01_Axis_0]. 

 

2. Declare the ETC_CO_Read function block and its associated function block 

parameters. Log in to CODESYS to proceed. 

https://dl.weintek.com/public/iR/eng/UserManual/UM019004E_iR-PU01-P_UserManual_eng.pdf
https://dl.weintek.com/public/iR/eng/UserManual/UM019004E_iR-PU01-P_UserManual_eng.pdf
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3. After assigning required parameters in CODESYS, trigger “xExecute” to read 

the data, which will be displayed in “Data”. 

 
※The EtherCAT Coupler's address corresponds to uiDevice. Please refer to 

[iR_ECAT] » [General] » [EtherCAT address] for more information. 

※For address mapping using wIndex and bySubIndex, refer to “iR-PU01-P 

User Manual” for detailed information. 

 

10.4.4 cMT-CTRL01 

1. Download and install the cMT+CODESYS Package. 

 

2. Under [iBus] » [Add device], add the motion control module. 

 

3. Under [Library Manager] » [Add Library], add Weintek iBus Library. 

 

https://dl.weintek.com/public/iR/eng/UserManual/UM019004E_iR-PU01-P_UserManual_eng.pdf
https://dl.weintek.com/public/iR/eng/UserManual/UM019004E_iR-PU01-P_UserManual_eng.pdf
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4. Declare the iBus.iBus_PU_Read function block and log in to CODESYS. 

 

5. Input the desired parameter into the function block for reading, then 

trigger "Execute" to display the current value in "Data". 

※ For input parameter configuration, refer to "Weintek Library User 

Manual Chapter 10 - Weintek iBus Library". 

 
 

11 Starting Driver 

11.1 CANopen Driver 

1. Add Weintek_CODESYS_Library. 

 

2. Add CANbus, CANopen_Manager, CANopen drivers. 

https://dl.weintek.com/public/iR/eng/UserManual/UM018017E_CODESYS_Weintek_Library_UserManual_eng.pdf
https://dl.weintek.com/public/iR/eng/UserManual/UM018017E_CODESYS_Weintek_Library_UserManual_eng.pdf
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3. CANbus -> Baudrate settings: 

 

CODESYS baudrate must be identical to the driver’s baudrate. 

4. CANopen driver settings: 

(1) Node ID 

 

Node ID settings must be identical to that of the driver. 

(2) PDO settings: 

 

See Axis Variable Instance Mapping_Q to add variables for output 
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channels. 

  

See Axis Variable Instance Mapping_I to add variables for input channels. 

(3) SDO settings: 

 

Follow the settings in the screenshot above to set initial values for checking 

motor rotation. 

(4) CANopen I/O Mapping: 

 

Mapping_I and Mapping_Q should be mapped to CANopen I/O Mapping. 

5. Programming: 
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Function blocks MC_Power & MC_MoveRelative are needed for testing motor 

rotation. 

Trigger “xEnable” and then trigger “xINC_Exe” to give command to the motor to 

perform positioning. When MC_Power.Status = FALSE, use MC_Reset function 

block to reset the motor and then trigger “xINC_Exe”. 

※ Function blocks that can give command to the motor can be found in 

Weintek_MC_LITE folder in Weintek Library.  

For more information, please see the following user manual. 

UM018017E_CODESYS_Weintek_Library_UserManual_eng 

11.2 EtherCAT Driver 

1. Add Weintek_CODESYS_Library. 

https://dl.weintek.com/public/Document/UM0/UM018017E_CODESYS_Weintek_Library_UserManual_eng.pdf
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2. Add EtherCAT_Master, EtherCAT drivers. 

 

3. EtherCAT_Master -> Source Address(MAC): 

 

4. EtherCAT driver settings: 
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(1) Process Data 

 

Select an RxPDO Mapping and a TxPDO mapping. 

(2) Expert Process Data 

 

See Axis Variable Instance Mapping_Q to add variables for output 

channels. 

  
See Axis Variable Instance Mapping_I to add variables for input channels. 

(3) Startup Parameters: 



 

cMT+CODESYS and Remote I/O Quick Start Guide 
 

 

56 
 

 

Follow the settings in the screenshot above to set initial values for checking 

motor rotation. 

(4) EtherCAT I/O Mapping: 

 

Mapping_I and Mapping_Q should be mapped to EtherCAT I/O Mapping. 

5. Programming: 
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Function blocks MC_Power & MC_MoveRelative are needed for testing motor 

rotation. 

Trigger “xEnable” and then trigger “xINC_Exe” to give command to the motor to 

perform positioning. When MC_Power.Status = FALSE, use MC_Reset function 

block to reset the motor and then trigger “xINC_Exe”. 

※ Function blocks that can give command to the motor can be found in 

Weintek_MC_LITE folder in Weintek Library.  

For more information, please see the following user manual. 

UM018017E_CODESYS_Weintek_Library_UserManual_eng 

  

https://dl.weintek.com/public/Document/UM0/UM018017E_CODESYS_Weintek_Library_UserManual_eng.pdf
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12 Removing Weintek Built-in CODESYS 

1. Click [Tools] » [Packages Manager]. 

2. Find Weintek Built-in CODESYS and then click [Uninstall]. 

 

3. Click [Next] when seeing the window below. 

 
4. Removing the program. 
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5. Click [Finish]. 
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13 Frequently Asked Questions 

13.1 Questions Related to IP Address 

Q1. How to use static IP address for cMT CODESYS? 

A: Please follow these steps. 

1. Right-click on “Device (Weintek Built-in CODESYS)” and select [Add Device]. 

2. Select [Ethernet Adapter] » [Ethernet] and then select [Add Device]. 

 

3. In Device tree find Ethernet and double click it. 

 

4. The following window opens, click […] button. 

 

5. Select “eth0”. Please see “2.2 Creating CODESYS Project” to finish CODESYS 

project settings before doing this step. 
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6. Select [Change Operating System Settings]. 

 

7. Download the project to cMT CODESYS. 

 

Q2. Why my CODESYS Gateway shows 0.0.0.0? 

A: When using static IP for cMT CODESYS, its IP address will be displayed as 

0.0.0.0. 

 

Q3. Can I use the same domain for cMT HMI’s LAN 1 and LAN 2? 

A: This is acceptable only when cMT HMI has CODESYS activated. 

 

13.2 Questions Related to CODESYS 

Q1. When the indicator of CODESYS Gateway lights up in red, how can I 

connect to the device? 

A: When CODESYS Gateway is not properly started or installed, its indicator will 

light up in red. Please try the following 3 methods to solve this situation. 

1. Click the icon of “CODESYS Gateway SysTray” in system settings and then 

click [Start Gateway]. 

2. Add new gateway and enter HMI IP. 
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3. Re-install CODESYS Gateway. 

 

Q2. Why a triangle icon shows near Modbus_TCP_Slave device when I log in 

HMI in CODESYS software? 

 
A: This means that HMI cannot connect Modbus TCP/IP device via CODESYS. 

Please check the IP settings and make sure the cable is properly connected. 

 

13.3 Questions Related to Downloading cMT CODESYS File 

Q1. How to update CODESYS firmware? 

A:  

There are 2 ways to update CODESYS firmware. 

1. Launch Utility Manager and select cMT Series » Maintenance » CODESYS 

Firmware Update. Browse for the firmware file and click [Update]. 
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2. Enter cMT HMI’s IP address in the website browser and find [CODESYS] » 

[CODESYS update] tab. Select the file and click [Update]. 

 

 

Q2. How to download CODESYS project using website? 

A: 

1. In CODESYS software select [Online] » [Create boot application]. An *.app 

file and a *.crc file will be generated. 
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2. Enter cMT HMI’s IP address in the website browser and find [CODESYS] » 

[Project update] tab. Select the files generated in the last step and click 

[Update]. 
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