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EasyBuilder Pro Quick Start Guide

Creating a simple project file in EasyBuilder Pro involves just a few steps:

Set PLC Device Parameters — Create Objects — Perform Offline or Online

Simulation — Configure HMI IP Address — Download Project File to HMI

Ensure that EasyBuilder Pro is installed on your computer before starting. This guide
uses a cMT2078X HMI and a PLC device with the MODBUS TCP/IP protocol as an

example.

1. Set PLC Device Parameters

Step 1. Open EasyBuilder Pro and create a new file.

Step 2. Select the model, check [Use template], and click [OK]. The template file

includes several preset windows, such as built-in keypads on windows 50 to

68 and 83 to 90, user password setup pages on windows 70 to 74,

EasyAccess 2.0 setup pages on windows 76 to 77, and the screensaver page

on window 80.

[© mew  New Project

Open  Model: [~ @ cMTX Series - Standard

cMT2058XH

fcMT2078X

> cMT2108X/ cMT2108X2/ cMT2108X2 (V2)
cMT2128X
> cMT2158X/ cMT2158X (V2)

cMT2166X

cMT3161X
v B cMTX Series - Advanced
cMT3072X/ cMT3072:2
cMT3072XH / cMT3072XH2 / cMT3072XHT
cMT3072XP
cMT3092X/ cMT3092X (v2)
cMT3102X/ cMT3102X (V2)
cMT3108XH
cMT3108XP
cMT3152X/ cMT3152X (V2)
cMT3162X/ cMT3162X (V2)
cMT-FHDX-220
cMT-FHDX-820
cMT-SVRX-820/822
~ B lloT Gateway Series

MT-G01

@ use template (template_800x480.cmtp)

Uncompress Project| | 3, Demo Project

-

CMT2078X

Orientation

O Landscape
O Portrait

Resolution : 800 x 480
COM 1:RS-232

COM 2 : RS-485 2W/4W
COM 3 : RS-232, RS-485 2V
COM port pin : link
Ethernet : LAN 1, LAN 2
WIFi: NA

CAN Bus : NA

SD Card Slot : NA

USB Host : Yes

oK Cancel

Windows Tree

Fas

Step 3. On the [Device] tab, click [New Device/Server] to configure the PLC device to

be connected.

Step 4. This step uses a PLC device with the MODBUS TCP/IP protocol as an example.

a9
[ 50:Keypad 1 - Integer
=[] 51:Keypad 2 - Integer
= 52:Keypad 3 - Integer
I~ 53:Keypad 4 - Integer
[ 54:Keypad 5 - Integer
=[] 55:Keypad 6 - Integer
= 56:Keypad 7 - HEX
~ ] 57:Keypad 8 - Floating
[ 58:Keypad @ - Numeric
1~ 59:Keypad 10 - Integer{translucent)
= 60: ASCIl Middle
= 61:AsClI Small
= 62: ASCll Upper M
[ 63: ASCll Lower M
I~ 64:ASCll Upper S
= 65: ASCll Lower §
- 66:ASCIl Middletranslucen)
I~ 67 : ASCll Upper M(translucent)
1~ 88: ASCIl Lower Mitranslucent)
- 69
= 70: Login & Logout

[ 71: Add accoun t
= 72: Delete account
i~ 73: Set privilege
= 74: Set passward

75

I~ 76: EasyAccess 2.0 Setting
i~ 77 : EasyAccess 2.0 Proxy Setting
- 7

79
=3 80:Screen Saver

[ 82: Wechat Cade

1~ ] 83 : System Standard ASCII

I~ 84: System Standard ASCIl Lower
I~ 85 : System Standard ASCIl Upper
[ 86: System Standard NumPad
=[] 87 : System Flat ASCII

I~ 88: System Flat ASCII Lower
I~ 89: System Flat ASCIl Upper
[ 90: System Flat NumPad

L
&

101

Windows Tree  \Windows Preview

Correctly set parameters such as IP address and port.
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Device Settings

Mame : MODEBUS TCR/IP

o Device

Location @ | gcal Settings...

* Select Local for a device connected to this HMI, or Remote for a device connected through another HMI.

Device type : MCODEUS TCRIP | »

Pevice ID : 58, ¥.3.30, MODBUS_TCFIP.C33
IfF: Ethernet w Crpen Device Connection Croide. .

* Support offdine simulation on HMI {use LB-12358).

P |192.168.1. 111, Port=502 | Settings... |

| [T Use UDP (User Datagram Protocol )

Device default station no. : 1
[ Use broadcast command
[ Default station na. use station no. variable

Hovw to desiznate the station no. in object’s address?..

Interval of block pack (words) : 32 o Address Range Limit. ..
Max. read-command size (words) : 120 e Data Conversion...
Max. write-command size {words) : 120 -
oK Cancel

X |

Step 5. After clicking [OK], a new device will be added to the [Device list].

System Parameter Settings

Cellular Data Network Time Sync,/DST e-Mail FTP
Device Model General System Remote Security Extended Memary
Device list: What's my IP?
Mame Location Device Type Interface
v Local HMI Local HMI Local cMT2078X (800 x 480) -
ilocal Device 4 : MODBUS TCP/IP Local  MODBUS TCP/IP Ethernet (P=192.168.1.111, Port=502)
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2. Create Objects

The following describes how to create three representative objects and their

functions.
File H & « » - Home Project [elZad Data/History |loT/Energy View Tool Weincloud
o ¢ (O [alPicture @ BitLamp £ SetBit [08 Multi-State Switch = Slider 2
@ [ ¥% 35 A [IShape B Wordlamp (2 SetWord 3 [E) Option List 5 AsClI
HH Table 1 @%Combo Button

Draw Lamp Button/Switch Input

Step 1. Create a [Toggle Switch] Object:

If there is a switch for a light on the PLC device and the goal is to control its switch on
the HMI, create this object. It is commonly used for operating bit addresses. Click
[Object] » [Toggle Switch], and under Read/Write, set the corresponding MODBUS
addresses for the light. Refer to the PLC Connection Guide for address mapping.

Mew Toggle Switch/Bit Lamp >

General Security Shape Label

Comment:
(O Bit Lamp O Toggle Switch
[ Read,/Write use different addresses
Read/Write
Device: MODBUS TCR/IP v (g 3
Address : | 0x v |1
[ Invert signal
[C'wirite when buttan is released
Attribute
Switchstyle:  Toggle w

Set the switch style to Toggle, meaning that if the initial state is 0 (OFF), clicking it
once will set it to 1 (ON). Besides the default images included in the system, it is also

possible to add or modify images for each state in the Shape tab.

I New Toggle Switch/Bit Lamp x| [ New Toggle Switch/Bit Lamp x
| General Security Shape Label | General Security Shape Label
— State: 0 ~ | p— State: |1 ~
| Picture - [Lamp - Ribbon | Picture - [Lamp - Ribbon
| ISYSTEM | ISYSTEM
68x69 68x69
o 1 o 1
Picture Picture
@ Use picture Picture Library... 18 Use picture Picture Library...


https://dl.weintek.com/public/PLC_Connect_Guide/MODBUS_TCP_IP.pdf
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Step 2. Create a [Numeric] Object:

Various data such as temperature and humidity from sensors often exist in PLC
devices. This object can display the data or set parameters. Click [Object] » [Numeric]
and configure, including the read/write addresses.

Mumeric's Properties x

General Data Entry Format Trigger Action Setting Security Shape Font  Profile

Comment :

B Allow input (i ]

[CJ Read,/Write use different addresses

Read/\Vrite
Device: MODBUS TCP/IP ™ &

£

Address: 4x -1

Step 3. Create a [Function Key] Object:
To create an intuitive project interface, it is often necessary to display popup
windows or switch between full-screen windows. Use [Function Key] to create these

functional buttons. Click [Object] » [Function Key] and configure the functions as
needed.

Function Key's Properties X

General Security Shape Label Profile

Comment :
Attribute
Type: Window -
[ Activate after button is released
Window
] ] ]
.FK_U . Function: | Display popup window -
= u = Window no.: 70.Login & Lagout ~
Title bar/Position...
Animation : Settings... [Mone, None]
B Close this popup window when parent window is closed
B show close button
Motification
] Enable
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Step 4. Properly place the objects in the editing window to complete a simple
project file.

EasyBuilder Pro V6.09.02.469 : EBProject1 - [10 - WINDOW_010 |
fle B &« + - QREUE Project  Object DatafHistory  lloT/Energy  View Tool  Weincloud

Roselect- (5 @ b 4 & E o E)- - _ o
paste BBy | b |00 BE/ s OGOwN

E 2 gl =8 t AA 7 A-U =.4- . A
Parameters i AMOH® Al &)s ; - b= =
Clipboard Editing Object Arrange Font

Windows Tree X 4 10 - WINDOW_010 x

Enter keyword to filter windows
= 10: WINDOW_010
I TS0 (0x-1) (Back) |
- NE_O (4x-1)
—FK0
11
12

o

T3 g1l

v B P PR PP

rrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrTrTT
n
5

EasyBuilder Pro offers a variety of objects with different functions. When designing
project files, select objects according to needs. For details on available objects, refer
to the EasyBuilder Pro User Manual.



https://dl.weintek.com/public/EBPro/UserManual/eng/UserManual_separate_chapter/Chapter_13_Objects.pdf
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3. Simulate the Project File

EasyBuilder Pro offers two types of simulation:

Offline Simulation: Operates without a connection to the PLC device and is used to
verify whether the project file functions as designed.

Online Simulation: Communicates with the PLC device to reflect actual HMI-PLC
behaviors.

Fle H & « # : Home YGEw@l Object Data/History lloT/Energy View  Toaol

S ® %[5 B e B =

System Language Compile Online Offline Download Build Download Reboot
Message & Font Simulation  Simulation| (PC->HMI) Files HMI
Setting Build

Offline Simulation

Step 1. Save the project file.

Step 2. Click [Project] » [Compile].

Step 3. Click [Compile], and after completion, click [Close].

| Compile * I

Project name : r::\J..lsers\Deskhop\ddTZU?BX_Quid(_Start.cmtp

CXOE file name : r::\J..lsers\Desktop\ddTZO?BX_Quid(_Smrt.cxob [

8 Decompilation is prohibited () Disable HMI upload function

Select the languages used on the HMI

Startup language after redownloading the project :  |anguage 1 I
ﬂ Language 1
Treat the use of unsupported tags as @ Error I
Output Error List
Total size : 3668719 bytes (3.50 MB)
Free space © 63440145 bytes (60.50 MB)

Project Checksum : Secd5a23a05a2¢1159ee68f598b55che
0 error(s), 0 warning(s)

succeeded

Double-dick a message to modify the attributes of the object in question

Quick Compile Font Management. .. @ Guild font files

Step 4. Click [Offline Simulation] to verify the relative position and basic operation

of objects.
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Step 5. The [Toggle Switch] and [Numeric] objects display offline without
attempting communication with the PLC device. Check if the [Function Key]

object operates the popup window correctly.

. cMT Viewer ( Simulation ) _ o x

Login by Index

Index ' admin

Password

Online Simulation
Step 1. Ensure computer communication with the PLC device, and after clicking
[Online Simulation], verify communication with the device.

Step 2. The software will reflect the actual values in the PLC device.

2, cMT Viewer ( Simulation ) B O %

10
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4. Configure HMI IP Address

Automatic I[P Configuration

Step 1. Power on the HMI and connect to LAN. Ensure there is a DHCP server on the
LAN.

Step 2. Tap theicon © inthe top left corner of the HMI.

Step 3. Tap [Network] from the left menu, then [Configure] on the right, and try to
modify settings.

Setting o EXITE Network
. Ethernet LAN2
. System Properties
Model {HMLName /02 Configure Automatic >
CODESYS AT
68.2.19
Activate CODESYS /v IP Address 192.168.2.191
Subnet Mask 255.255.252.0
Project
Clear History / Restart ... Gateway 192.168.1.254
@ Network N DNS 168.95.1.1
Ethernet / Configure /1.5
Enable CODESYS Login [ @)

9 Security
Admin / Update Projec...

e EasyAccess 2.0
Version / Activation Sta...

Step 4. To modify settings, log into the system settings. Enter the default password
111111 and press enter.

Step 5. Select [Automatic] and click [Save]. Once successful, the HMI will obtain a
LAN IP address.

Setting @» Hore < Network Configure Save

Admin, o
Automatic v

. System Properties

Model / HMI Name / O... Manual

CODESYS
Activate CODESYS / Re...

Project
Clear History / Restart ...

® Network
Ethernet / Configure / I... k

e Security
Admin / Update Projec...
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Manual IP Configuration
Step 1. If the LAN has no DHCP server, open the command prompt by typing ‘cmd’
in the computer's search interface. Then, use the command ‘ipconfig’ to

check the computer’s network settings.

B Command Prompt - m} X

Step 2. Choose [Manual] in Network settings, input the same subnet as the

computer, and click [Save]. Once successful, the HMI will obtain a LAN IP

address.
Setting €» Hore < Network Configure Save
in. o )
Automatic
System Properties
E)
= Model / HMI Name / O... Manual v
CODESYS
% [t IP Address 192.168.1.191
Subnet Mask 255.255.252.0
Project
Clear History / Restart ... Gateway 192.168.1.254
. Network DNS 168.95.1.1
" Ethernet / Configure /1...
0 Security
Admin / Update Projec... k
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5. Download Project File to HMI

Step 1. Click [Project] » [Download (PC->HMI)].
Step 2. Select the target HMI for download and click [Download].

Download (PC->HMI) *
|
© Ethernet Password/Port no. of download/upload : | Settings...
4 IP, HMI Name I
HMI | cMT2078X-FAE-4892 « | [192.168.2.52 (Default-test
192.168.2.8 (cMT2078X-FAE-4892)
Search
Search All
What's my [F?
Project Checksum @ SecdSa23a05a2c1159ee68f698b55che

@ runtime  * Necessary if update runtime or execute download first time.

([ Use system settings file

[ synchronize HMI clock with PC

B Reset recipe (RW, RW_A) @ Reset event leg @ Reset data sampling

B Reset recipe database B Reset operation log B Reset string table
@ Reset PRW on HMI and all chT Viewers

() Automatically using current settings to download after compiling

Step 3. After downloading, verify the HMI interface. If the following screen appears,
it indicates communication failure between HMI and PLC. Check connections

and communication parameter settings.

?Dew’ce No Response

10
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Step 4. If the following screen appears, it indicates successful communication
between HMI and PLC.

u

Other company names, product names, or trademarks in this document are the trademarks or registered trademarks of their
respective companies.

This document is subject to change without prior notice.

Copyright® 2024 WEINTEK IOT LTD. All rights reserved.
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