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1. Overview

EasyRemotelO is a tool for users to set up Weintek iR-ETN. In EasyRemotelO, users
can set iR-ETN’s IP address, configure parameters, monitor or modify values.
In EasyRemotelO, users who are using EasyBuilder Pro, CODESYS, or EtherNet/IP

devices can also export files needed for establishing connection with iR-ETN.

2. Quick Start

1. Launch EasyRemotelO, click on [Automatic Scan].

&7 EasyRemotelO (= |EoR ==

File Edit View Online Tools Help

B RED EE50EB8HNEEHBBE

Project Wind 2 A

SR Astomatic Scan || e biap | P |

Channel Name Type Online Falue Froject Falue

Log Message

Date Time Message

2018-02-07 16:10:30.753 EasyRemotelO is started. ProductVersion:1.0.0.0

2. Select [Overwrite the project], and click [Scan]. The default IP of iR-ETN is
192.168.0.212. Please make sure the PC is in the same domain: 192.168.0.*.*.

Automatic Scan @
Mame IP Address Mac Address Sub Mask
@ Owerwrite the project
(7 Add to project
Sean
[ T o »
o
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3. TheiR-ETN can be found in Automatic Scan window. Select the iR-ETN you want
to modify and click OK.

Automatic Scan @
Mame IP Address MWac Address Sub Mask
> [] iR-ETN 1921682183  00-0C-26-01-02-04 255.255.252.0 | @ Overwrite the project
. [[] TONY2 1021681136  00-0C-26-12-34-5B 2552552520 | & add 1o project
> [[] TONYL 1921681138  00-0C-26-12-34-5A 255.255.252.0
Sran

4 T | »

[ ok || Comel

4. TheiR-ETN and the module’s information will be shown as below.

& EasyRemotelO (E=8 Fo8 =
Eile Edit View Online Tools Help
= @R R = @ 1 | B G m
BRE WD 2w BNEEHBE
Project Window 8 x
10/ Modules | Addiessbap | Paramster
4 [ iR-ETN (192.168.2183)
@@ #1 iR-DM16-P Channel Name Type Online Value Project Valve
4 iR-ETN (192.168.2.183)
#1:iR-DM16-P DI/ DO 0x00
Log Message J x
Date Time Message
2018-02-07 16:21:28.500 Auto scan is successfully completed
2018-02-07 16:10:30.753 EasyRemotelO is started. PraductVersion:1.0.0.0

5. Select [Change IP] in [Online] to change the IP address of iR-ETN and then click
OK.
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& EzsyRemotel0 E=RE=E 5
File Edit View[m]'rao\s Help
Eg) [@ Automatic Scan shiftes K] @ @
Project Window [Z] Compare with Offline Shift+C
Address Map Parameter
4 @ RETN @S B} Download
iR = Onling Velve Project Value
TR el T S —
[}:ﬂ Copy to Project name
Special Commands ct code
Change IP ame IR-ETM
are revision
¥ SstartMonitoring Shift+h | o revicion
Eﬂ Stop Monitoring Shift+0 consumption
TOTrEht power consumption
Power supply
Life guard time 0
iBus continue run oM
MNumber of TCP connected

Mumber of modules

Point Of Digital input
Paint Of Digital output
Mumber Of Analog input
Mumber Of Analog output

Log Mesmage 5 X

Date Time Message

2018-02-07 16:21:28.500 Auto scan is successfully completed

2018-02-07 16:10:30.753 EasyRemotelQ is started. ProductVersion:1.0.0.0

ChangeIP address @
Mac Address . 00-0C-26-01-02-04

IPddress: 107 | 168 2 183
SubMask: 255 255 22 0

[ ox ][ conel

6. Inthe Project Window, select iR-ETN and then go to [Parameter] tab in the right
column. Here you can change the related parameters of iR-ETN. The actual value
of iR-ETN is in the [Online Value] column. The new value should be entered in

the [Project Value] column.
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&7 EasyRemotelD
Ele Edit View Online Tools Help

4 | iR-ETN (192.168.2.183)
E} #1:iR-DM16-P

R EZSEBEEBEN BB

Progect Window 5 X

| I0/Modules | AddmessMap | Pasameter

[E=H EEH 5|

Channel Name
4 iR-ETN (192.168.2.183)

Onling Vealue

Vendor name

Product code

Host name

Firmware revision
Hardware revision

Power consumption
Current power consumption
Pawer supply

Life guard time

iBus continue run

MNumber of TCP connected
Number of madules

Paint OF Digital input
Point Of Digital output
Mumber Of Analog input
Mumber Of Analog output

Project Value

iR-ETM

Log Mesmage

Date Time

2018-02-07 16:47:12.631

2018-02-07 16:21:28.500

2018-02-07 16:10:30.753

Message

Auto scan is successfully completed
Auto scan is successfully completed

EasyRemotelQ is started. ProductVersion:1.0.0.0

7. Click [Upload] to read the data from iR-ETN and show in EasyRemotelO.
Click [Download] to write the data in EasyRemotelO to iR-ETN.

® =

Parameter

File Edit WView Online Toolz Help

B =5 B W EBE M

Project Window & o o Up|l:|alf:| Tiressbiap
Eile Edit View Online Toaols Help

PR sSsy @K 6o
Predect Window

IO ¢ Mod _Duwnlnad JMap Pararmeter

8. Select iR-ETN’s module in Project Window. In the 10/Modules tab you can

read/write inputs and outputs value. Click [Download] to write the data from
EasyRemotelO to iR-ETN.
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&7 EasyRemotelD
Ele Edit View Online Tools Help

BB ==

00 B B

Progect Window 5 X
10/ Modules | AddmssMap | Pavameter |
4 [l iR-ETN (192.168.2.183)
i #LiR-DM16-P Chanmel Name Tupe Qnline Falue Project Value
4 #1:iR-DM16-P
Digital Input #0 DI
Digital Input #1 2}
Digital Input #2 DI
Digital Input #3 01
Digital Input #4 oI
Digital Input #5 DI
Digital Input #6 2}
Digital Input #7 DI
Digital Output #0 Do 0
Digital Qutput #1 Do 0
Digital Output #2 DO 0
Digital Output #3 Do ]
Digital Output #4 DO 0
Digital Qutput #5 Do 0
Digital Qutput #6 Do 0
Digital Output #7 DO 0
Log Mesmage 5 x
Date Time Message

2018-02-07 16:47:13.631 Auto scan is successfully completed

2018-02-07 16:21:28.500 Auto scan is successfully completed

2018-02-07 16:10:30.753 EasyRemotelQ is started. ProductVersion:1.0.0.0

9. The Parameter tab allows users to change the parameters of the modules.

&7 EasyRemotelD

Progect Window

file Edit View Online Tools
R D o =
R =

Help

00 B B

| I0/Modules | AddmessMap | Pasameter

[E=H EEH 5|

4 [l iR-ETN (192.168.2.183)
i #1:iR-DM16-P Chawne] Naime Onnline Value Project Value ol
4 #1:iR-DM16-P
Digital input filter time #0 o
Digital input filter time #1 o
Digital input filter time #2 o
Digital input filter time #3 o
Digital input filter time #4 o
Digital input filter time #5 0 3
Digital input filter time #6 o
Digital input filter time #7 o
Digital output error mode #0 Error value
Digital output error mode #1 Error value
Digital output errar mode #2 Error value
Digital cutput error mode #3 Error value B
Digital output errar mode #4 Error value
Digital output error mode #5 Error value
Digital output error mode #6 Error value
Digital autput error mode #7 Errarvalue
Digital cutput eror value #0 Low
Dinital outout ereor value #1 Low A
Log Mesmage 5 x
Date Time Message
2018-02-07 16:47:13.631 Auto scan is successfully completed
2018-02-07 16:21:28.500 Auto scan is successfully completed
2018-02-07 16:10:30.753 EasyRemotelQ is started. ProductVersion:1.0.0.0
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3. Settings
Edit
Add

Network Coupler: Add network coupler manually.

Module: Add module manually.

Online

Automatic Scan

Scan all the iR-ETN in the same domain.
Compare with Offline

Check whether the devices in EasyRemotelO exist in the same domain.

Compare with Offline [ = |
Item Offline Value Cnline Value
#2: Mon-exist online iR-DI16-K X
EasyRemotelO @ Start Compare
Comparision completed. Configuration is different. Target: iR-COP
! N (192.168.1.225)

[ ok || cansl

Download

Write the value from EasyRemotelO’s Project Value column to the iR-ETN.

Upload

Read the value from iR-ETN and show in EasyRemotelO’s Online Value column.
Copy to project

Read the value from iR-ETN and show in EasyRemotelQO’s Online Value and Project
Value columns.



EasyRemotelO

I__| WE!NTEK

[0/ Modules Address Map | Parameter
Chnne] Neame Type Online Falue Project Falue
4 #1:iR-DM16-P

Digital Input #0 oI 0
Digital Input #1 DI 0
Digital Input #2 oI 0
Digital Input #3 oI 0
Digital Input #4 oI 0
Digital Input #5 oI 0
Digital Input #6 DI 0
Digital Input #7 oI 0
Digital Qutput #0 DO 0 0
Digital Qutput #1 DO 0 0
Digital Output #2 DO 0 0
Digital Output #3 DO 0 0
Digital Qutput #4 DO 1 1
Digital Qutput #3 DO 0 0
Digital Output #6 DO 0 0
Digital Qutput #7 DO 0 0

Special Commands

Restart Device: Restart iBus and module.

Restart iBus: Restart iBus only.

Reset to default (except IP setting): Reset all the parameters, except IP settings, to

default.

Special Commands

Restart Device
Restart iBus
Reset to default{except IP Setting)

=3

Hend

Change IP

Change the IP address of iR-ETN.

Change IP address \E\
Mac Address : 00-0C-26-04-05-06
IP hddress: 192 168 1 225
SubMask: 255 255 252 O

OK i | Cancel
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Start Monitoring

Start monitoring iR-ETN. (Read only)
Stop Monitoring

Stop monitoring iR-ETN.

Tools
Modbus
Allows users to run an online MODBUS TCP/IP client on the PC.

Modbus Communication

Communication Setup
Protocol | Modbus TCP IP Address 182 . 168 . 1 . 225

Built-In Messages
REN [ .. ] [(1Read] Digital Input =

Register Index{Dec) O

[T request

Slave ID[Dec) 0 Function |Read Coils

Address(Hex) Quantity(Dec)

Send Data

Hex Dec ASCII IP address

Response

Hex Dec ASCIT BIN
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4. Analog Module
Displaying Channel Value

I__“v WE!NTEK

All channel values are displayed when clicking the [Start Monitoring] button in the

I0/Modules tab.

Address Map Parameter

Channel Name Type Cinling Value Froject Value
W #3:iR-AId-VI
Analog Input #0 Al 0
Analog Input #1 Al 0
Analog Input #2 Al 0
Analog Input #3 Al 0
Writing Channel Value

All channel values are displayed when clicking the [Start Monitoring] button in the

I0/Modules tab.

Specify [Project Value] and then click [Download], the specified value will be written

into [Online Value].

0/ Modvles  Address Map Parameter

Channel Name Type Cinline Valve Froject Value
o F2R-AC-VI

Analog Output #1 AO 0 0
Analog Qutput #2 Al 0 0
Analog Output #3 AC 0 0

Configuring Parameters

Click [Upload All] to read all parameters which are displayed in the Parameter tab.

10 /Modulss  AddressMap

Chanmel Name Oling Vale Project Falue ~
v #3R-AI4-VI
Product Code (425
Firmware Revision 1.0.00
Hardware Revision 1.0.00
Power Consumption 035W
Point of Digital Input 0
Point of Digital Qutput 0
MNumber of Analog Input 4
MNumber of Analog Output 0
Input Mode 20 Close Close 4
Input Mode #1 Close Close &2
Input Mode 2 Close Close v
Input Mode #3 Close Close v
Input Scale Range Upper Limit #0 32000 32000
Input Scale Range Upper Limit #1 32000 32000

Revise channel parameter under [Project Value].
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10 ! Modules Address Map Parameter

Channel Name Onling Value Project Value L
¥ #3iR-AIM-VI
Product Code w0425
Firmware Revision 1.0.0.0
Hardware Revision 1.0.0.0
Power Consumption 0.35W
Point of Digital Input 0
Point of Digital Qutput 0
Mumber of Analog Input 4
Mumber of Analog Qutput 0
ooz e g 3|
Input Mode 1 Close Close =~
Input Mode #2 Close Close =~
Input Mode #3 Close Close
Input Scale Range Upper Limit #0 32000 32000
Input Scale Range Upper Limit #1 32000 32000

Click [Download] to write from [Project Value] into [Online Valuel].

10 /Modules  Address Map Parameter

Channel Name Online Value Project Value ()
v #3iR-AI4-VI

Product Code (0425

Firmware Revision 1.0.0.0

Hardware Revision 1.0.0.0

Power Consumption 0.35W

Point of Digital Input 0

Point of Digital Qutput 0

MNumber of Analog Input 4

MNumber of Analog Output 0

Input Mode #1 ose Close ~
Input Mode #2 Close Close ~
Input Mode #3 Close Close ~
Input Scale Range Upper Limit #0 32000 32000

Input Scale Range Upper Limit #1 32000 32000

sk For more information about channel parameters, please see chapter 6 in
UMO018013E_iR-Axxx-VI_UserManual_20190401_eng

s%Settings in the Parameter tab are written into the analog module’s registers.

A faster way to start analog module is to configure the parameters using
EasyRemotelO and then import the settings on the coupler.

10
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Initializing Module

[Online] » [Special Commands]

I__| WE!NTEK

Select the analog modules to be initialized, and then click [Send] to restore factory

default.

Special Commands

Restart Device

Restart iBus

Reset to default(except IP Setting)

Rezet to manufacture value (#2: iR-A004-Y1)
Reszet to manufacture value (3: iR-AI04-V])
Reset to manufacture value (£4: IR-4I104-TR)
Reset to manufacture value (7 IR-A104-4T)
Reset to manufacture value (& iR-4AC04-V)
Reset to manufacture value (#17; iR-ACM-Y)
Reset to manufacture value (#13: iR-ACQM-Y)

e,

Cancel

11
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5. Export
Export Tag
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When Weintek Remote IO (MODBUS TCP/IP) driver is selected in EasyBuilder Pro,
selecting [Export Tag] in EasyRemotelO can help users quickly build iR-ETN related

parameters.

1. Launch EasyRemotelO and select [File] » [Export Tag].

[l EasyRemotel0

File Edit View Online
| Open

New

Save

@M

Save As
Export Tag

Export PLCopenXML
Export EtherlNet/IP EDS

Tools  Help
k0

Zt’: ? I0/Moduks  AddmssMop  Perometer  Power Informiation
1l
Channe] Nons Modbus Mapping Onling Talue Project Valoe
v E1: iR-AMOG-VI

Product Code 7330 00635
Firmware Revision 7531 1.000
Hardware Revision »T532 1,000
Power Consumption 7533 035W
Point of Digital Input 7356 [}
Point of Digital Output [ % [}
Mumber of Analog Input 7558 4
Mumber of Analog Output 7359 2
Analog Output Error Mode #0 0x1815[0] Error value Error value
Analog Output Error Mode #1 0x1815(1] Error value Error value
Analog Output Error Value £0 w1819 [ 0
Analog Output Error Value £1 1812 [} [}]
Output Mode #0 Oxde20 =10V 107
Output Mode £1 Oxde2] Close Close
Output Scale Range Upper Limit 0 Oxde2d 32000 32000
Output Scale Range Upper Limit £1 Oxde2s 32000 32000
Output Scale Range Lower Limit #0 Oxde28 -32000 -32000
Output Scale Range Lower Limit #1 Oxde28 -32000 -32000 v

<

>

2. Launch EasyBuilder Pro and select [System Parameters] » [New Device] »
[Weintek Remote IO(MODBUS TCP/IP)].

Device Properties

| Weintek Labs., Inc.

Search

Weintek Built4n CODESYS
Weintek Remote 10 (CANopen
Weintek Remote 10 (MODBLUS TCP

3. After importing tags, information about iR-ETN can be found when creating an

object.
—
Device : | yeintek Remote I0 (MODBUS TCP{IP) w
Address type : |iR-ETI. Vendar Name
Address: 4
Q|
Address format : .
Name Data type Description
[ iR-ETN.Vendor Name Undesignated
) iR-ETN.Product Code Undesignated
B iR-ETN.Host Name Undesignated
*To make calculation { | o ip_gn Firmware Revision Undesignated
conversion definition
TagLibrary... | | B iR-ETN.Hardware Revision Undesignated
T | | B iR-ETN.Power Consumption Undesignated
?-E‘I’N.Cur.rent Power Undesignated
onsumption
0 iR-ETN.Power Supply Undesignated
5D CTRLL#n Taaed To [ P bl

Tag: |iR-EI'N.Vendor MName

Ok

12
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Export PLCopenXML
Exporting PLCopenXML file can help users quickly build communication parameters
when establishing connection between a CODESYS device and an iR-ETN.

1. Launch EasyRemotelO and select [File] » [Export PLCopenXML].

FHl EasyRemotelO - [m] x
file | Edit View Online Tools Help
Open Ctr0 BE 20| e B 0e @ ©9 °8
3 New Ctrl+N x
[0/bodules | AddwssMap  Poramster | Power Information
H save Crl+S
B Sovess Channel Hams Modbus Mspping  Onlins Valus Project Felus
— v 1 iR-AMOG-VI
e — Product Code 7530 0x0635
Firmuare Revision 7531 1000
EpmEf=I=AF ES Hardware Revision 7532 1000
Power Consumption 7533 035W
Paint of Digital Input 0xT556 0
Point of Digital Output 07557 0
Number of Analog Input 0x7558 4
Number of Analag Output 7559 2
Anslog Output Error Mode 20 0x1815(0] Errorvalue Errorvalue
Analog Output Ermor Mode 21 Dx1815(1] Errorvalue Errorvalue
Analog Output Error Value 20 x1819 0 0
Analog Output Error Value 21 x181a 0 0
Output Mode %0 [x4e20 10V tiov
Output Mode #1 Dxde2] Close Closs
Output Scale Range Upper Limit 20 Dxde24 32000 32000
Output Scale Range Upper Limit #1 Dxde25 32000 32000
Output Scale Range Lower Limit 20 Dxde28 -32000 -32000
Output Scale Range Lower Limit #1 Dxde29 -32000 -32000 v
< >

2. Launch CODESYS, add [Ethernet] » [Modbus_TCP Master] device.

Devices
=15 PLCopentM
= ﬁ Device (Weintek Built-n CODESYS)
=&l PLC Logic
=1} Application
m Library Manager
WF] PLC_PRG (PRG)
= @ Task Configuration
=-g& MainTask
& PLC_PRG
= m Ethernet (Ethernet)
ﬁ |Mndbus_TCF‘_Master (Modbus TCP Master) |

-~ 0 X

-

3. Import PLCopenXML by selecting [Project] » [Import PLCopenXML].

Devices SUEIX] | R_ETH_192 168 3 212 X
= ALCopenrt -
= Device (Wentek Buitin CODESYS) General Name Access Type Tigger READ Offset  Length  EorHandiing WRITEOffset  Length
=8l pLcLogic 0 1:R-AMOE-VI.Anzlog Input Read Input Registers (Function Code 04) Cyic, t£100ms 1620000 4 Keeplast Value
=€) Application | Medbus Siave Channel 1 LR-AMOSVLANOGOUDUL  Read/Write Multple Registers (Functon Code 23)  Cydlc, t2100ms 1620100 2 Keeplastvaue 1620100 2
i) Lirary Manager —— 2 2 R-DMI6N.Digtal Input Read Discrete Inputs (Function Code 02) Cydc, t#100ms 1620000 s Keeplast Value
9 pic R pRY) 3 2 R-DMIGN.Digital Output(R)  Read Coils (Function Code 01) Cydc, t£100ms 1670000 s Keeplast Value
= [ resk configuration ModbusTCPSlave Parameters 4 2 ROMI6-N.Digital Output(W)  Write Multiple Coils (Function Code 15) Cydic, t£100ms 1650000 s

=& MainTask
&) pLcPrs
=@ Ethernet Ethemet)
= (@ Modbus_TCP_Master (Modbus TCP Master)

ModbusTCPSlave 0 Mapping

Status

Informatin

13
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Export EtherNet/IP EDS
Exporting EtherNet/IP EDS file can generate Electronic Data Sheets of iR-ETN.
1. Launch EasyRemotelO and select [File] » [Export EtherNet/IP EDS].

EasyRemotelO - [m] x
File  Edit View Online Tools Help
Open ao | BB 12 §e @B e @ ©9 °8
3 New Ctri+N
10/Modules  AddeessMap  Povemeter  Powes Information
H save Ctrl+S
B Seveds Channel Neme Modbus Mapping  Online Value Project Value  ~
Export Tog v #10iR-AMOB-VI
Product Code 7530 040635
Export PLCopenXML Firmware Revision 07531 1000
Epri D RS Hardware Revision 07532 1000
Power Consumption 0x7533 035W
Paint of Digital Input 0x7556 0
Paint of Digital Output 0x7557 0
Number of Analog Input 0x7558 4
Number of Analog Output 0x7559 2
Analog Output Error Mode 20 ox1815(0] Error value Error value
Analog Output Error Mode 1 x1815(1] Error value Error value
Analog Output Error Value %0 1819 0 0
Analog Output Error Value #1 1813 0 0
Output Mode #0 Oxde20 =10V Hov
Output Mode #1 Oxde2l Close Close
Output Scale Range Upper Limit #0 Oxded 32000 32000
Output Scale Range Upper Limit #1 Oxdeds 32000 32000
Output Scale Range Lower Limit 20 Oxde28 -32000 -32000
Output Scale Range Lower Limit 1 Oxde29 -32000 -32000 v
< >

2. Import EtherNet/IP EDS in the user interface of EtherNet/IP device. Please see

iR-ETN EtherNet/IP Connection Guide for more information.

14


https://dl.weintek.com/public/iR/eng/UserManual/UM020006E_iR-ETN_EtherNetIP_Connection_Guide_eng.pdf

	1. Overview
	2. Quick Start
	3. Settings
	Edit
	Online
	Tools

	4. Analog Module
	Displaying Channel Value
	Writing Channel Value
	Configuring Parameters
	Initializing Module

	5. Export
	Export Tag
	Export PLCopenXML
	Export EtherNet/IP EDS


