cMT X Series Easyweb 2.0
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l__l WE!NTEK cMT X Series Easyweb 2.0

Chapter 1 System Settings

1.1 Overview

Easyweb 2.0 is a web interface that allows users to configure parameters of cMT X Series HMI.
Additionally, with its Webview feature, users can monitor HMIs through a web browser. This user

manual explains the cMT X Series HMI features that can be configured using Easyweb 2.0.

1.2 Ways to Log In Easyweb 2.0

Connect an HMI via an Ethernet cable, and log in system settings in one of the following ways.

Via internet browser

Open internet browser (IE, Chrome, or Firefox), and enter HMI’s IP address (e.g.: 192.168.2.121).
The web page below opens. If Webview interface is shown after entering the IP address, please
enter https://HMI_IP/admin to open Easyweb 2.0 system login page.

[=[E] s
@ cmr X+

< C A F&= | 192168.2.121/admin/login?redirect=%2Fweb_ihmi%2Findex.php w ® OH g @ :

Set on cMT Viewer devices

Launch cMT Viewer App, tap Search, select the HMI and tap icon to configure.
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https://hmi_ip/admin%20to%20open%20EasyWeb%202.0

- .
T CMT Viewer =N

20170329 10:4806
UTITviewer Connect

Search
cMT-4C66
192.168.2.121

Default HMI

168.2.124

cMT-3E87
192.168.2.127

1x-3072
192.168.2.136
cMT-4C52
192.168.2.141

cMT-2C40
192.168.2.147

Default HMI
192.168.2.151
cMT-04B1

192.168.2.195

! cMT-4C51xQ
192.168.1.212

® © 000060 0 O

1.3 Easyweb 2.0 Login Identities

Three identity levels exist in Easyweb 2.0: [Admin], [Update], and [History]. [Admin] controls all the
settings while [Update] controls limited items. For safety, specify a password before configuration.
A password is needed for opening [History] settings, and the historical data can be backed up after
logging in with password.

The default password is 111111. After successful login, the password for each identity level can be

changed in [System Password] page.

S M7 x 4+

< C A Fz= | 192168.2.121/admin/legin?redirect=%2Fweb_ihmi%2Findex.php + ® O H 2] @ :

Admin

Admin
o
Update

. History
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1.4 Easyweb 2.0 Interface
Dashboard
System status and HMI status are displayed in Dashboard after login.

S[@] s
@ cMT- Dashboard X 4+
< C A F== | 192.168.2.121/admin/dashboard/info %+ ® O Hd 5] @ :
Dashboard - admin
\\® cMT3152X
Easyweb 20
© i System Status
@ Network
(@ Now Date @ Up Time
2020/04/01 05:52:31 1:8:4
HMI Status
4 HMI Name 0N
cMT-4C66 V2.0.11
* OS Versior
20200218 -
Info
In this page the user can edit HMI Name / Date / Time.
S[@] s
@ MT - System Info x  +
< C A F== | 192.168.2.121/admin/system/info + @4 03 5] @ :
Dashboard / System - admin
\ € cMT3152X
Easyweb 20

O i HMI Name: Edit

T Network Date/Time: 2020-04-01 06:01:51
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Network » Ethernet

In this page the user can set the IP address of each Ethernet port.

@ cMT- Ethernet X 4+

< C A F== | 192.168.2.121/admin/network/ethernet

\ © cMT3152X ‘
Easyweb 2.0

O o LAN 1 (WAN) LAN 2 (LAN)

Dashboard / Network / Ethernet

EI Network Mac Address: 00:0c:26:1b:4c:68

Ethemnet Gonfigure IP: Automatic &

= Project Address: 192 . 168 . 2

Netmask: 255 . 255 . 252 .

) Features

—/ Giateway: 192 . 168 . 1
DNS 168 . 95 1

.21

. 254

S[E] %
* a 0B EO @ :

- admin v

Project » Project Management

In this page the user can restart / update / back up the project file.

@ cMT-Project Management X =+

< C A == | 192.168.2.121/admin/project/management

\ © cMT3152X
= b20

Project Management
Restart Project:
Update Project:
Project Management Backup Project:

USB/SD Update:

(®) Features

B Account

Dashboard / Project Project Management

Restart C

Backup

* S OB EQ @ :

= admin
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Project » Email

In this page the user can edit email contacts; e.g., the groups a contact is in, and email addresses.

@ T - Email x 4+

< C A Fz== | 192.168.2.121/admin/project/email

* S OB EQ @ :

® Dashboard / Project Emai
\ cMT3152X
Easyweb 2.0
o Inio SMTP Contaots Upload
@ Network
*Host: stmp.gmail.com
= oo
i “Pot  — 587 +
* Username: test@gmail.com
*Password:  seseesses
* Gonfirm Password:
Authentication: ()
Encryption: None Q9 TS SSL

(®) Features

Sender Information

“Name:

Local HwmI Use HMI Name

=1 NCH S

= admin

Project » Enhanced Security

In this page the user can set operable classes and password for each account.

@ MT - Enhanced Security x  +

< C A F=Z | 192.168.2.121/admin/project/security

Dashboard / Project
\ © cMT3152X
= b20

* S OHEBEQR @ :

Enhanced Security

o Info Accounts Impart User Accounts

T Network Add Account

@ Please click [Save] b

ution afier editing data

== Projeot
D Hide Account ':assm' A B © D E F a
1 admin 11111 ~ ~ 4 4 N4 v Ve
Enhanced Security 2 useri 111 v
3 user2 222 ~ ~
4 user3 333 v v v
5 userd 444 ~ v \/ \/
6 userb 555 J ~ e e e
7 usert 666 ~ ~ ~ 4 N4 Ve

- admin
H 1
v v
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Project » Recipe
In this page the user can update, back up, or clear recipe data on HMI.

@ cMT - Recipe x 4+

<« C A F=2 | 192.168.2.121/admin/project/recipe # ® O | s e @ H

Dashboard / Project Recipe ~ admin
\ € cMT3152X

Easyweb 20

QO o Action

em
T Network Update Backup Clear
Recipe Database Backu
& Project s pd p

nw

Backup

-

(W) Features

Data » Data Log & Trend Display

This page displays data log and the corresponding trend. The data can be exported or backed up.

o= %
@ cMT- Datalag & Trend x 4+
< C A F=2 | 192.168.2.121/admin/data/datalog % ® O H g =@ :
Dashboard / Data / Data log & Trend = admin
\ © cMT8152X
Easyweb 2.0
o Info Datalog Trend Display
@ Network
Object:  logooo
Project - i
0 Refresh @ Option
Time + Channel 1 Channel 2 Channel 3
Lo ol TR DIy 235778  © 2020/04/0113:27:39  -0.422618 0574748 119827
235777 (© 2020/04/01 13:27:38 -0.173648 -0.777817 1.18177
235776 (© 2020/04/01 13:27:37 0.130526 -0.959746 1.09625
235775 © 2020/04/01 13:27:36 0.382683 -1.0587 0.97082
D) Feat 235774 ® 2020/04/01 13:27:35 0.608761 -1.09915 0.802957
) Features
235773 ® 2020/04/01 13:27:34 0.793353 -1.07886 0.6
235772 (& 2020/04/01 13:27:33 0.939693 -0.980107 0.330765
* Export to Spreadshest * Backup database 1
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@ cMT- Datalag & Trend x 4+

< ¢ A F=2 | 192.168.2.121/admin/data/datalog # ® O | s e @ H

® Dashboard / Data / Data log & Trend = admin
oMT3152X b
Ea

Data Log Trend Display

Object:  logooo
Auto Refresh 2 Refresh @ Option

45

Data Log & Trend Display 10

1:23PM 124 PM 125 PM 1:26 PM 1:27 PM 1:28 PM 1:29 PM 1:30 PM 131 PM
— -0.382683 —— 0914817 ——-12

X. Division & Y. Division 7

Data » Event Log

This page displays event logs, and the data can be exported or backed up.

o|=] &
@ MT-Eventlog x  +
& G A F=2 | 192168.2.121/admin/data/eventlog # 4 0[ B =@ :
Dashboard / Data / Eventlog - admin
© cMT3152X
Ea
Time column
2020-03-04 o 2020-04-01
Category range (0 - 255)
0 - 255 -
Keywords Select Language
Add terms Language1
e [EventLog
# Calegory Event Message Event trigger time Retum ip normal time Occurence count
1 1 TankError!! (© 2020/04/01 13:31:25 ® 3 =
2 1 Machine Error !t © 2020/04/01 13:31:25 O 2020/04/01 13:31:31 44
3 255 StartMemory Test  © 2020/04/01 133117 @ 1
Flow Speed Ermor
4 1 . © 2020/04/0118:31112 @ 2020/04/01 13:31:20 17
5 1 Machine Error !t © 2020/04/01 13:31:110 @ 2020/04/01 13:31:18 43
[ 1 TankEmor ! © 2020/04/01 133106 © 20200401 13:31:15 30
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Data » Operation Log

In this page the user can back up operation logs.

o= %
@ cMT - Operation Log X  +
<« C A F=2 | 192168.2.121/admin/data/operationLog % ® O H g =@ :
Dashboard / Daia Operation Log o admin
\ © cMT8152X -
Easyweb 20

+ Backup database

o nfo
oy

&8 Project

Operation Log

Features » Webview Setting
In this page the user can enable Webview and set password. Please see Chapter 2 in this user

manual for more details.

o|=] %
@ MT - Webview setting x 4+
< C A F=2 | 192.168.2.121/admin/features/webview # ® O | a = @ H
Dashboard / Features Webview setting = admin

\ © cMT3152X
Easyweb 20

QO o webview w

Enable: [ @)
@ Network

set as homepage

Control User: password free

Change password @

@ Control users can control Webview

Webview Setting
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Features » EasyAccess 2.0

In this page the user can activate EasyAccess 2.0 and configure the proxy server.

o= %
@ MT-EA2D x 4+

<« C A F=2 | 192.168.2.121/admin/features/eas20 % ®# O H g =@ :

Dashboard / Features | EA20 = admin

\ © cMT3152X

Easyweb 2.0

o Info EasyAccess 2.0 Proxy
@ Network Hardware key: TBCPIYER-NVGA-7PM5-DJUG-QGJIM-PAULBURC
&8 Project Status: Not Agtivated

&= Dam Click to Activate with Partner Account

@ Features

Features » CODESYS

In this page the user can activate CODESYS® and manage settings for firmware updates.

SEIES
@ cMT-CODESYS X 4+

< C A F== | 192.168.2.121/admin/features/codesys # % O | 8| = @ H

Easyweb 2.0

Dashboard / Features / CODESYS - admin v
\ @ cMT83152X b

o Info Status

@ Network Status: Not Activated

&8 Project Click to Activate
E Data

@ Features

e CODESYS

B Account
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Account » System Password

There are four different levels of password protection: System Setting, Update Project, History, and

User, and in this page the user can change the passwords. The default passwords are 111111.

[System Setting]: This is the highest level. It has an access to change all system settings, download,

upload project, back up historical data, or change passwords for other levels.
[Upload Project]: This level can download, upload project, and back up historical data.
[History]: This level controls FTP access and it can back up historical data.

[User]: This level can operate cMT X projects via cMT Viewer. Other three levels above can all do

this.

@ cMT - Password

< C A == | 192.168.2.121/admin/account/password

© cMT3152X

Easyweb 20

System Password

* S OB EQ @ :

Dashboard / Account Goniro Password = admin

| Please select identity to edit password.

System Setting
Gurrent password:

New password:

Confirm new password:

Submit Reset

UMO020001E_20200516

System Setting
Update Project
History

User
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Chapter 2 How to Use Webview

2.1 Overview

cMT X Series HMI can be monitored and controlled using an internet browser (IE, Chrome, or
Firefox). Up to 4 users can log in simultaneously.

2.2 Enabling Webview

Log in Easyweb 2.0, open Webview Setting page and toggle on [Enable]. In this page, whether a
password is required for logging in Webview can be set.

o|=] %
@ MT - Webview setting x 4+
< C A F=2 | 192.168.2.121/admin/features/webview # ® O | a = @ H
Dashboard / Features Webview setting o admin
\‘@ cMT3152X =
Easyweb 20

webview w

Enable: [ @)

set as homepage

Control User: password free

Change password @

@ Control users can control Webview

& Webview Setling

2.3 Log In Webview using an Internet Browser

Step1l. Open internet browser and enter HMI's Webview address (e.g.: 192.168.2.121
/app/dashboard). In Webview settings, if “Set as homepage” option is selected, then
simply enter the IP address (e.g.192.168.2.121). Webview interface opens after entering
the password.
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S vt x  +
& C A F=2 | 192168.2.121/app/login?auto=stop - % ®% O @ B =@ :

Control Mode

Step 2. The HMI screen is displayed in the browser window. Certain HMI screen resolutions may
exceed the browser window size. When this happens, to change the view area, drag the
white frame that represents browser window in the lower-right corner and move within
the gray area that represents HMI screen.

[=[@] % ]
S oMT x 4+
C A F=2 | 192.168.2.121/app/dashboard - % 4 OH B =@ :

VNC Viewer run on HMI allows remote monitoring devices with VNC Server installed for
flexible operation.

Step 3. The toolbar that opens by clicking the three-line icon in the upper-left corner of the

window is shown below. From left to right, the toolbar is separated into three groups of
items.

UMO020001E_20200516 Copyright© 2020 Weintek Lab., Inc. All rights reserved.
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In the first group, the HMI screen can be resized to fit in the browser window, or
displayed with HMI’s actual screen resolution.

In the second group, the position of the icon that opens the toolbar and the dragging
panel that moves the view area can be changed.

In the third group are the system settings icon and the logout icon.

8 B

@ Note

B When “Set as homepage” is selected in Webview, the Webview interface can be opened by
directly entering HMI IP address. When login password is forgotten, please enter
https://HMI IP/admin to return to the default system settings page. This prevents the

situation where Webview functions cannot be used once password is forgotten.

2.4 When Webview Doesn’t Open

When a login attempt fails and the page below shows, try the following ways to troubleshot.

1. Check whether Webview is enabled for the HMI.

2. Check whether the browser supports Webview, and please use recommended browsers such as
IE, Chrome, or Firefox.

3. Maximum number of users may be exceeded (4 users at a time).

SEIES
S T X 4+

< G ® F=2 | 192.168.2.121/app/dashboard # % O | B =@ :

CONNECTING

T

If it takes a long time to connect.

Possible causes :

1. Webview feature is disabled on this HMI.

2. This browser does not support Webview.

3. Maxinum connections for Webview has been reached.

CODESYS is a trademark of 3S-Smart Software Solutions GmbH.
Other company names, product names, or trademarks in this document are the trademarks or registered trademarks of their respective companies.
This document is subject to change without prior notice.
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