Reference section ：

Some parameters can be provided by the actual value of another programmed function as following.

■ 1/2 Series ：

· Analog comparator: Ax - Ay

· Analog threshold trigger: Ax

· Analog amplifier: Ax

· Up/Down counter: Cnt

■ 5/6 Series：

· Analog comparator: Ax - Ay

· Analog threshold trigger: Ax

· Analog amplifier: Ax

· Up/Down counter: Cnt

· On-delay: Ta

· Off-delay: Ta

· On-/Off-delay: Ta

· Retentative on-delay: Ta

· Wiping relay (pulse output): Ta

· Edge triggered wiping relay: Ta

· Asynchronous pulse generator: Ta

· Stairway lighting switch: Ta

· Multiple functions switch: Ta

· Stopwatch : AQ

· Threshold trigger: Fre

· Mathematical instruction: AQ

· Analog multiplexer: AQ

· Analog ramp: AQ

· PI controller: AQ

· Max/Min: Ax

· Analog filter : AQ

· Average value : AQ

· BCD : AQ

· BIN : AQ

· ROL : AQ

· ROR : AQ

· SHL : AQ

· SHR : AQ

· AND_MASK : AQ

· OR_MASK : AQ

· NOT_MASK : AQ

· NAND_MASK : AQ

· NOR_MASK : AQ

· XOR_MASK : AQ

· ARRMX_MI_AV : AQ

· ACMX_MI_AV : AQ

· RAND : AQ

· MOD : AQ

· REM : AQ

· LOG : AQ

· SQRT : AQ

· ABS : AQ

· GCD : AQ

· LCM : AQ

· POW2 : AQ

· EXP : AQ

· FIX : AQ

· ROUND : AQ

· SIN : AQ

· COS : AQ

· TAN : AQ

· COT : AQ

· SEC : AQ

· CSC : AQ

· MEM : AQ

· Quadratic equation : AQ

· ENCODER : Cnt


Inputs

Input blocks represent the input terminals of 1/2/5/6 Series.

There are up to 256 digital inputs available to you.

These inputs are categorized into 8 groups which are shown as follows :

Module | Input Number
Main | I000 ~ I031
Ext. 1 | I100 ~ I131
Ext. 2 | I200 ~ I231
Ext. 3 | I300 ~ I331
Ext. 4 | I400 ~ I431
Ext. 5 | I500 ~ I531
Ext. 6 | I600 ~ I631
Ext. 7 | I700 ~ I731

Each input block has a unique number in the circuit program.


Function Keys

The ATP module has five function keys that can be used as digital inputs in the circuit program. You program the function keys in the same way as other inputs of your circuit program. Function keys can save both switches and inputs, and allow operator control of the circuit program.


Shift register bits

The 1/2 series provides 16 shift register bits S0 to S15, which are read-only attribute in the circuit program. The content of shift register bits can only be modified by means of the shift register special function.

The 5/6 series provides a maximum of 64 shift registers bits S0.0 to S3.15.


Permanent logical levels

Status 1 (high)

Set the block input to logical hi (high) to set it permanently to logical 'H' state.

Status 0 (low)

Set the block input to logical lo (low) to set it permanently to logical 'L' state.


Outputs

Output blocks represent the output terminals of 1/2/5/6 Series. There are up to 128 digital outputs available to you.

These outputs are categorized into 8 groups which are shown as follows :

Module | Output Number
Main | Q000 ~ Q015
Ext. 1 | Q100 ~ Q115
Ext. 2 | Q200 ~ Q215
Ext. 3 | Q300 ~ Q315
Ext. 4 | Q400 ~ Q415
Ext. 5 | Q500 ~ Q515
Ext. 6 | Q600 ~ Q615
Ext. 7 | Q700 ~ Q715

Each output block has a unique number in the circuit program.


Open connectors

You can connect the output of an block to the open connector block. The block is different from the output block. Imagine the open connector block as a terminal.

Number of the open connectors: 128.


Flags

Analog Flags

The size of a digital flag is 1 bit.The flag block outputs its input signal. 1/2/5/6 series provides 512 digital flags M0 to M511 and 512 analog flags AM0 to AM511. Each flag block has a unique number in the circuit program.

Analog Flags: AM0 to AM511

The size of an analog flag is 2 bytes. The analog flag can be used as markers for analog inputs or analog instruction blocks. The analog flag merely accepts an analog value as input and outputs that value.

Message text character set flag: M511 ( 5/6 series only )

The M511 flag determines whether the message texts of the primary or the secondary character set will display if used. Select the two character sets from either the Msg Config menu of 5/6 series or the File → Message Text Settings menu command of PC Soft. Then when configure message texts , select whether a particular message text consists of characters from the primary character set (Character Set 1) or the secondary character set (Character Set 2).

In the circuit program, M511 can enable the message texts of either the primary or secondary character set and disable the message texts of the other. When M511 = 0 (low), the primary character set display message texts. When M511 = 1 (high), the secondary character set displays the message texts from the secondary character set.


Analog inputs

Analog input blocks represent the analog input terminals of 1/2/5/6 Series. There are up to 64 analog inputs available to you. These inputs are categorized into 8 groups which are shown as follows. Each input block has a unique number in the circuit program.

Module | Input Number
Main | AI000 ~ AI007
Ext. 1 | AI100 ~ AI107
Ext. 2 | AI200 ~ AI207
Ext. 3 | AI300 ~ AI307
Ext. 4 | AI400 ~ AI407
Ext. 5 | AI500 ~ AI507
Ext. 6 | AI600 ~ AI607
Ext. 7 | AI700 ~ AI707

The analong inputs have a dual definition: they can be used as either digital or analog inputs. You don't have to make any settings.

 | 11/51 Series Input | 21/61 Series Input
AI | 0 ~ 10V | 0 ~ 10V
DI | status low : < +2VDC status high : > 4VDC~30VDC | AC Supply TYPE: status low : < 40VAC status high : >79VAC DC Supply TYPE : status low: < 5VDC status high: > 8.5VDC

Example
In 1x89 / 2x89 / 5x89 / 6x89 Series, an input signal, which comes from AI0, is also detected on DI4.


Analog outputs

Analog output blocks represent the analog output terminals of 1/2/5/6 Series. There are up to 32 analog outputs available to you. These outputs are categorized into 8 groups which are shown as follows. Each output block has a unique number in the circuit program.

Module | Output Number
Main | AQ000 ~ AQ003
Ext. 1 | AQ100 ~ AQ103
Ext. 2 | AQ200 ~ AQ203
Ext. 3 | AQ300 ~ AQ303
Ext. 4 | AQ400 ~ AQ403
Ext. 5 | AQ500 ~ AQ503
Ext. 6 | AQ600 ~ AQ603
Ext. 7 | AQ700 ~ AQ703

Note that the analog output value ranges between 0 and 1000.

As of the 5/6 device series, The behavior of analog outputs in Init mode is configuable. Analog outputs can retain their last values when 5/6 series goes to Init mode. Alternatively,

you can configure and set specific values for AQ when 5/6 series goes to Init mode.

As of the 5/6 device series, you can also set the analog output value range. There are two choices:

· 0-10 V or 0-20 mA ( Default )

· 4-20 mA


AND

The output of an AND function is only 1 if all inputs are 1, that is, when they are closed.

A block input that is not used (x) is assigned: x = 1.

AND function logic table:

Input1 | Input2 | Input3 | Input4 | Output
0 | 0 | 0 | 0 | 0
0 | 0 | 0 | 1 | 0
0 | 0 | 1 | 0 | 0
0 | 0 | 1 | 1 | 0
0 | 1 | 0 | 0 | 0
0 | 1 | 0 | 1 | 0
0 | 1 | 1 | 0 | 0
0 | 1 | 1 | 1 | 0
1 | 0 | 0 | 0 | 0
1 | 0 | 0 | 1 | 0
1 | 0 | 1 | 0 | 0
1 | 0 | 1 | 1 | 0
1 | 1 | 0 | 0 | 0
1 | 1 | 0 | 1 | 0
1 | 1 | 1 | 0 | 0
1 | 1 | 1 | 1 | 1


AND with edge evaluation

The output of an AND with edge evaluation is only 1 if all inputs are 1 and at least one input was 0 during the last cycle.

The output is set to 1 for the duration of one cycle and must be reset to 0 for the duration of the next cycle before it can be set to 1 again.

A block input that is not used (x) is assigned: x = 1.

Timing diagram of an AND with edge evaluation:


NAND

The output of an NAND function is only 0 if all inputs are 1, i.e. when they are closed.

A block input that is not used (x) is assigned: x = 1.

Input 1 | Input 2 | Input 3 | Input 4 | Output
0 | 0 | 0 | 0 | 1
0 | 0 | 0 | 1 | 1
0 | 0 | 1 | 0 | 1
0 | 0 | 1 | 1 | 1
0 | 1 | 0 | 0 | 1
0 | 1 | 0 | 1 | 1
0 | 1 | 1 | 0 | 1
0 | 1 | 1 | 1 | 1
1 | 0 | 0 | 0 | 1
1 | 0 | 0 | 1 | 1
1 | 0 | 1 | 0 | 1
1 | 0 | 1 | 1 | 1
1 | 1 | 0 | 0 | 1
1 | 1 | 0 | 1 | 1
1 | 1 | 1 | 0 | 1
1 | 1 | 1 | 1 | 0


NAND with edge evaluation

The output of a NAND with edge evaluation is only 1 if at least one input is 0 and all inputs were 1 during the last cycle.

The output is set to 1 for the duration of one cycle and must be reset to 0 at least for the duration of the next cycle before it can be set to 1 again.

A block input that is not used (x) is assigned: x = 1.


OR

The output of an OR is 1 if at least one input is 1 (closed).

A block input that is not used (x) is assigned: x = 0.

OR function logic table:

Input 1 | Input 2 | Input 3 | Input 4 | Output
0 | 0 | 0 | 0 | 0
0 | 0 | 0 | 1 | 1
0 | 0 | 1 | 0 | 1
0 | 0 | 1 | 1 | 1
0 | 1 | 0 | 0 | 1
0 | 1 | 0 | 1 | 1
0 | 1 | 1 | 0 | 1
0 | 1 | 1 | 1 | 1
1 | 0 | 0 | 0 | 1
1 | 0 | 0 | 1 | 1
1 | 0 | 1 | 0 | 1
1 | 0 | 1 | 1 | 1
1 | 1 | 0 | 0 | 1
1 | 1 | 0 | 1 | 1
1 | 1 | 1 | 0 | 1
1 | 1 | 1 | 1 | 1


NOR

The output of a NOR (NOT OR) is only 1 if all inputs are 0 (open). When one of the inputs is switched on (logical 1 state), the output is switched off.

A block input that is not used (x) is assigned: x = 0.

NOR function logic table:

Input 1 | Input 2 | Input 3 | Input 4 | Output
0 | 0 | 0 | 0 | 1
0 | 0 | 0 | 1 | 0
0 | 0 | 1 | 0 | 0
0 | 0 | 1 | 1 | 0
0 | 1 | 0 | 0 | 0
0 | 1 | 0 | 1 | 0
0 | 1 | 1 | 0 | 0
0 | 1 | 1 | 1 | 0
1 | 0 | 0 | 0 | 0
1 | 0 | 0 | 1 | 0
1 | 0 | 1 | 0 | 0
1 | 0 | 1 | 1 | 0
1 | 1 | 0 | 0 | 0
1 | 1 | 0 | 1 | 0
1 | 1 | 1 | 0 | 0
1 | 1 | 1 | 1 | 0


XOR

The XOR (exclusive OR) output is 1 if the signal status of the inputs is different.

A block input that is not used (x) is assigned: x = 0.

XOR function logic table:

Input 1 | Input 2 | Output
0 | 0 | 0
0 | 1 | 1
1 | 0 | 1
1 | 1 | 0


NOT

The output is 1 if the input is 0. The NOT block inverts the input status.

Advantage of the NOT, for example: PC soft no longer requires break contacts. You simply use a make contact and convert it into a break contact with the help of the NOT function.

NOT function logic table:

Input 1 | Output
0 | 1
1 | 0


On-Delay

The output is not switched on until a configured delay time has expired.

Connection | Description
Input Trg | The on delay time is triggered via the Trg (Trigger) input.
Parameter | T represents the on delay time after which the output is switched on (output signal transition 0 to 1). Retentivity on = the status is retentive in memory.
Output Q | Q switches on after a specified time T has expired, provided Trg is still set.

Parameter T

The time in parameter T can be provided by the value of another already programmed function. Please refer to reference section.

Timing diagram

Description of the function

The time Ta (the current time in 1/2/5/6 series) is triggered with the 0 to 1 transition at input Trg.

If the status at input Trg stays 1 at least for the duration of the configured time T, the output is set to 1 when this time has expired (the on signal of the output follows the on signal of the input with delay).

The time is reset if the status at input Trg changes to 0 again before the time T has expired. The output is reset to 0 when input Trg is 0.


Off-Delay

The output with off delay is not reset until a defined time has expired.

Connection | Description
Input Trg | Start the off delay time with a negative edge (1 to 0 transition) at input Trg (Trigger).
Input R | Reset the off delay time and set the output to 0 via the R (Reset) input. Reset has priority over Trg.
Parameter | T: The output is switched off on expiration of the delay time T (output signal transition 1 to 0). Retentivity on = the status is retentive in memory.
Output Q | Q is switched on for the duration of the time T after a trigger at input Trg.

Parameter T

The time in parameter T can be provided by the value of another already programmed function. Please refer to reference section.

Timing diagram

Description of the function

Output Q is set to 1 instantaneously with a 0 to 1 transition at input Trg.

At the 1 to 0 transition at input Trg, 1/2/5/6 series retrigger the current time T, and the output remains set. The output Q is reset to 0 when Ta reaches the value specified in T (Ta=T) (off delay).

A one-shot at input Trg retriggers the time Ta.

You can reset the time Ta and the output via the input R (Reset) before the time Ta has expired.


On-/Off-Delay

The on/off delay function block is used to set an output after a configured on delay time and then reset it again upon expiration of a second configured time.

Connection | Description
Input Trg | You trigger the on delay with a positive edge (0 to 1 transition) at input Trg (Trigger). You trigger the off delay with a negative edge (1 to 0 transition).
Parameter | TH is the on delay time for the output (output signal transition 0 to 1). TL is the off delay time for the output (output signal transition 1 to 0). Retentivity on = the status is retentive in memory.
Output Q | Q is switched on upon expiration of a configured time TH if Trg is still set. It is switched off again upon expiration of the time TL and if Trg has not been set again.

Parameters TH and TL

For the 5/6 series devices, the on-/off-delay time in parameter TH and TL that can be provided by the value of another already programmed function. Please refer to reference section.

Timing diagram

Description of the function

The time TH is triggered with a 0 to 1 transition at input Trg.

If the status at input Trg is 1 for at least the duration of the configured time TH, the output is set to logical 1 upon expiration of this time (output is on delayed to the input signal).

The time TH is reset if the status at input Trg is reset to 0 before this time has expired.

The time TL is triggered with the 1 to 0 transition at the output.

If the status at input Trg remains 0 at least for the duration of a configured time TL, the output is reset to 0 upon expiration of this time (output is off delayed to the input signal).

The time TL is reset if the status at input Trg returns to 1 before this time has expired.


Retentive On-Delay

A one-shot at the input triggers a configurable time. The output is set upon expiration of this time.

Connection | Description
Input Trg | Trigger the on delay time via the Trg (Trigger) input.
Input R | Reset the on delay time and reset the output to 0 via input R (Reset). Reset takes priority over Trg.
Parameter | T is the on delay time for the output (output signal transition 0 to 1). Retentivity on = the status is retentive in memory.
Output Q | Q is switched on upon expiration of the time T.

Parameter T

The time set in parameter T can be formed by the actual value of another already programmed function. Please refer to reference section.

Timing diagram

Description of the function

The current time Ta is triggered with a 0 to 1 signal transition at input Trg. Output Q is set to 1 when Ta reaches the time T. A further pulse at input Trg does not affect Ta.

The output and the time Ta are only reset to 0 with a 1 signal at input R.

If retentivity is not set, output Q and the expired time are reset after a power failure.


Wiping relay (pulse output)

An input signal generates an output signal of a configurable length.

Connection | Description
Input Trg | You trigger the time for the wiping relay with a signal at input Trg (Trigger).
Parameter | T represents the time after which the output is reset (output signal transition 1 to 0). Retentivity on = the status is retentive in memory.
Output Q | A pulse at Trg sets Q. The output stays set until the time T has expired and if Trg = 1 for the duration of this time. A 1 to 0 transition at Trg prior to the expiration of T also resets the output to 0.

Parameter T

For the 5/6 series devices, the off time T can be provided by the value of another already programmed function. Please refer to reference section.

Timing diagram

Description of the function

With the input signal Trg = 1, output Q is set to 1. The signal also triggers the time Ta, while the output remains set.

When Ta reaches the value defined at T (Ta=T), the output Q is reset to 0 state (pulse output).

If the signal at input Trg changes from 1 to 0 before this time has expired, the output is immediately reset from 1 to 0.


Edge triggered wiping relay

An input pulse generates a preset number of output pulses with a defined pulse/pause ratio (retriggerable), after a configured delay time has expired.

Connection | Description
Input Trg | You trigger the times for the Edge-triggered wiping relay with a signal at input Trg.
Input R | The output and the current time Ta are reset to 0 with a signal at input R.
Parameter | TH, TL: The pulse width TH and the interpulse width TL are adjustable. N determines the number of pulse/pause cycles TL / TH. Value range: 1...9. Retentivity on = the status is retentive in memory.
Output Q | Output Q is set when the time TL has expired and is reset when TH has expired.

Parameters TH and TL

For the 5/6 series devices, the width TH (Paluse) and TL (Interpaluse) can be provided by the value of another already programmed function. Please refer to reference section.

Timing diagram

Description of the function

With the change at input Trg to 1, the time TL (time low) is triggered. After the time TL has expired, output Q is set to 1 for the duration of the time TH (time high).

If input Trg is retriggered prior to the expiration of the preset time (TL + TH), the time Ta is reset and the pulse/pause period is restarted.


Asynchronous Pulse Generator

The pulse shape at the output can be modified by a configurable pulse/pause ratio.

Connection | Description
Input En | You enable/disable the asychronous pulse generator with the signal at input En.
Input Inv | The Inv input can be used to invert the output signal of the active asynchronous pulse generator.
Parameter | TH,TL: You can customize the pulse width (TH) and the interpulse width (TL). Retentivity on = the status is retentive in memory.
Output Q | Q is toggled on and off cyclically with the pulse/pause times TH and TL .

Parameters TH and TL

For the 5/6 series devices, the width TH (Paluse) and TL (Interpaluse) can be provided by the value of another already programmed function. Please refer to reference section.

Timing diagram

Description of the function

You can set the pulse/pause ratio at the TH (Time High) and TL (Time Low) parameters.

The INV input can be used to invert the output signal. The input block INV only inverts the output signal if the block is enabled with EN.


Random Generator

The output of a random generator is toggled within a configurable time.

Connection | Description
Input En | The positive edge (0 to 1 transition) at the enable input En (Enable) triggers the on delay for the random generator. The negative edge (1 to 0 transition) triggers the off delay for the random generator.
Parameter | TH: The on delay is determined at random and lies between 0 s and TH. TL: The off delay is determined at random and lies between 0 s and TL.
Output Q | Q is set on expiration of the on delay if En is still set. It is reset when the off delay time has expired and if En has not been set again.

Parameters TH and TL

For the 5/6 series devices, the on-/off-delay time TH and TL can be provided by the value of another already programmed function. Please refer to reference section.

Timing diagram

Description of the function

With the 0 to 1 transition at input En, a random time (on delay time) between 0 s and TH is set and triggered. If the status at input En is 1 for at least the duration of the on delay, the output is set to 1 when this on delay time has expired.

The time is reset if the status at input En is reset to 0 before the on delay time has expired.

When input En is reset 0, a random time (off delay time) between 0 s and TL is set and triggered.

If the status at input En is 0 at least for the duration of the off delay time, the output Q is reset to 0 when the off delay time has expired.

The time is reset if the status at input En returns to 1 before the on delay time has expired.


Stairway Lighting Switch

The edge of an input pulse triggers a configurable time. The output is reset when this time has expired. An off warning can be output prior to the expiration of this time.

Connection | Description
Input Trg | You trigger the time (off delay) for the stairway switch with a signal at input Trg (Trigger).
Parameter | T : The output is reset (1 to 0 transition) when the off delay time T has expired. T! determines the triggering time for the prewarning. T!L determines the length of the prewarning time. Retentivity on = the status is retentive in memory.
Output Q | Q is reset after the time T has expired. A warning signal can be output before this time has expired.

Parameters T, T! and T!L

For the 5/6 series devices, the prewarning time T! and the prewarning period T!L can be provided by the value of another already programmed function. Please refer to reference section.

Timing diagram

Time base T | Prewarning time | Prewarning period
Seconds* | 750 ms | 50 ms
Minutes | 15 s | 1 s
Hours | 15 min | 1 min

* only for programs with a cycle time < 25 ms

Description of the function

Output Q is set to 1 with a 0 to 1 signal transition at input Trg. The 1 to 0 transition at input Trg triggers the current time and output Q remains set.

Output Q is reset to 0 when Ta reaches the time T. Before the off delay time (T - T!) has expired, you can output a prewarning that resets Q for the duration of the off prewarning time T!L.

Ta is retriggered (optional) at the next high/low transition at input Trg and if Ta is expiring.


Multiple Function Switch

Switch with two different functions :

● Pulse switch with off delay

● Switch (continuous light)

Connection | Description
Input Trg | A signal at input Trg (Trigger) sets output Q (permanent light) or resets Q with an off delay. When active, output Q can be reset with a signal at input Trg.
Input R | A signal at input R resets the current time Ta and resets the output.
Parameter | T: determines the off delay time. The output is reset (1 to 0 transition) when the time T expires. TL determines the period during which the input must be set in order to enable the permanent light function. T! determines the on delay for the prewarning time. T!L determines the length of the prewarning time period. Retentivity on = the status is retentive in memory.
Output Q | Output Q is set with a signal at input Trg, and it is reset again after a configured time has expired and depending on the pulse width at input Trg, or it is reset with another signal at input Trg.

Parameters T, TL, T! and T!L

For the 5/6 series devices, the permanent light time TL (off-delay), the prewarning time T! (on-delay), and the prewarning time period T!L can be provided by the value of another already programmed function. Please refer to reference section.

Timing diagram

The time base for the T, T! and T!L must be identical.

Description of the function

Output Q is set to 1 with a 0 to 1 signal transition at Trg.

If output Q = 0, and input Trg is set hi for at least the duration of TL, the permanent lighting function is enabled and output Q is set accordingly.

The off delay time T is triggered when the status at input Trg changes to 0 before the time TL has expired. Output Q is reset when the Ta = T.

You can output an off-warning signal prior to the expiration of the off delay time (T - T!) that resets Q for the duration of the off prewarning time T!L. A subsequent signal at input Trg always resets T and output Q.


Weekly timer

The output is controlled by means of a configurable on/off date. The function supports any combination of weekdays.

Connection | Description
Parameter | At the No1, No2, No3 (Cam) parameters you set the on and off time triggers for each cam of the weekly timer. The parameter units are the days and the time of day.
Output Q | Q is set when the configured cam is actuated.

Timing diagram (three practical examples)

Description of the function

Each weekly timer is equipped with three cams. You can configure a time hysteresis for each individual cam. At the cams you set the on and off hysteresis. The weekly timer sets the output at a certain time, provided it is not already set.

The weekly timer resets the output at the off time if you configured an off time, or at the end of the cycle if you specified a pulse output. A conflict is generated in the weekly timer when the on time and the off time at another cam are identical. In this case, cam 3 takes priority over cam 2, while cam 2 takes priority over cam 1.

The switching status of the weekly timer is determined by the status at the No1, No2 and No3 cams.

On times

The on time is any time between 00:00 h and 23:59 h.

Special characteristics to note when configuring

The block properties window offers a tab for each one of the three cams. Here you can set the day of the week for each cam. Each tab offers you in addition an option of defining the on and off times for each cam in hour and minute units. Hence, the shortest switching cycle is one minute. Also on each tab you have the option of specifying a pulse output for the cam.

You can disable the on and off times individually. You can achieve switching cycles extending across more than one day, for example, by setting the on time for cam 1 to Monday 7:00 h and the off time of cam 2 to Wednesday 13:07 h, while disabling the on time for cam 2.

Backup of the real-time clock

The internal real-time clock of 1/2/5/6-Series is buffered against power loss.


Yearly timer

■ For 1/2 Series :

The output is controlled by means of a configurable on/off date.

Connection | Description
Parameter | At the No (cam) parameter you set the on and off trigger for the cam of the yearly timer.
Output Q | Q is set on when the configured cam is switched on.

Timing diagram

Description of the function

The yearly timer sets and resets the output at specific on and off times.
The off-date identifies the day on which the output is reset again. The first value defines the month, the second the day.
When you select the Monthly check box, the yearly clock switches on or off at a certain day of Monthly.

Backup of the real-time clock

The internal real-time clock of device is buffered against power failure.

Special characteristics to note when configuring

A click on the dialog box enables direct keyboard input of the month and day values. The values entered may not exceed the logical maximum of the relevant input boxes, otherwise PC soft returns an error message.

The calendar icon offers you an easy way of setting the date. It opens a window where you can set the days and months by clicking the relevant buttons.

Sample configuration

The output of a device is to be switched on annually, from 1st of March to 4th of April and from 7th of July to 19th of November. This requires two blocks for configuring the specific on times. The outputs are then linked via an OR block.

Place two yearly timer switch SFBs on your programming interface and configure the blocks as specified.

■ for 5/6 Series :

The output is controlled by means of a configurable on/off date such as activate on a yearly, monthly, or user-defined time basis. With any mode, output can also be pulsed by configuring timer during the defined time period. The time period is configurable within the date range of January 1, 2000 to December 31, 2099.

Connection | Description
Parameter | At the No (cam) parameter you set the on and off trigger for the cam of the yearly timer.
Output Q | Q is set on when the configured cam is switched on.

Timing diagrams

Example 1: If you choose “Yearly selected” and set On Time = 2000.06.01, Off Time = 2099.08.31, every year on June 1 the timer output will switch and remain on until August 31 to switch off.

Example 2: If you choose “Yearly selected” and “Pulse selected” and set On Time = 2000.03.15, Off Time = 2099.**.**,every year on March 15 the timer will switch on for one cycle.

Example 3: If you choose “Yearly selected” and set On Time = 2008.06.01, Off Time = 2010.08.31. the timer output will switch and remain on June 1 of 2008, 2009, and 2010 until August 31.

Example 4: If you choose “Yearly selected” and “Pulse selected” and set On Time = 2008.03.15, Off Time = 2010.**.**, the timer output will switch on March 15 of 2008, 2009, and 2010for one cycle.

Example 5: If you choose “Monthly not selected” and “Yearly not selected” and set On Time = 2008.06.01, Off Time = 2010.08.31, the timer output will switch and remains on June 1, 2008 until August 31, 2010.

Example 6: If you choose “Monthly not selected”, “Yearly not selected”, “Pulse selected” and set On Time = 2008.03.15, Off Time = ****.**.**, the timer switches on March 15, 2008 for one cycle. Because the timer neither has monthly action nor yearly action, the timer output will only pulse one time at the specified On Time.

Example 7: If you choose “Yearly selected” and set On Time = 2008.12.15, Off Time =2010. 01.07, the timer output will switch and remains on December 15 of 2008 and 2009 until January 7 of the following year. When the timer output turns off on January 7, 2010, it WILL NOT turn on again the following December 15.

Example 8: If you choose “Monthly selected” and set On Time = 2008.**.01, Off Time = 2010.**.05, the timer output switches on the first day of each month (starting in 2008) and switches off on the fifth day of the month. The timer continues in this pattern through the last month of 2010.

Description of the function

The yearly timer sets and resets (executed 00:00) the output at specific on and off dates. If application requires a different time, use both weekly and yearly timer together in the circuit program.

The On Time specifies the month and day when the timer is set. The Off Time identifies the month and day on which the output is reset again. The first value defines the year, the second the month and the third the day.

When you select the Monthly check box, the timer output switches on and remain the specified day of each month(start time) until the specified day of the Off Time. The “On Year” = the timer is activated. The “Off Year” = the timer turns off. **The maximum year is 2099.

If you select the Yearly check box, the timer output switches on and remain the specified month and day of each year (start time) until the specified month and day of the Off Time. The “On Year” = the timer is activated. The “Off Year” = the timer turns off. **The maximum year is 2099.

If you select the Pulse check box, the timer output switches on for one cycle and then it is reset. Pulsing a timer on a monthly or yearly basis, or just a single time is allowable.

If none of the Monthly, Yearly, or Pulse check boxes are be selected, On/Off time can be defined a specific time period. It can span any time period that is choosen.

For a process that is to be switched on/off at multiple but irregular times during the year, multiple yearly timers can be defined with the outputs connected by an OR function block.

Backup of the real-time clock

The internal real-time clock of 5/6 series buffer retains the time function working properly while power failure.

Special characteristics to note when configuring

Numerically enter values to the month and day fields is allowable. PC soft returns an error message if you enter values which is not logical range.

The calendar icon helps you setting the date easily. It opens a window where you can set the days and months by clicking the relevant buttons.

Sample configuration

The output of 5/6 series is to be switched on annually, from 1st of March to 4th of April and from 7th of July to 19th of November. This requires two blocks for configuring the specific on times. The outputs are then linked via an OR block.

Place two yearly timer switch SFBs on programming interface.

1) Configure the On Time : 00.03.01 for the first yearly timer and 99.04.04. (Off time)

2) Configure the On Time : 00.07.07 for the second yearly timer and 99.11.19. (Off time)

Create a standard OR block and connect with two timers. The OR output is 1 if at least one of the yearly timer switches is set.


Astronomical clock

For Geographical location of 5/6 series, the astronomical clock SFB sets an output high between sunrise and sunset based on the local time. The output status of astronomical clock function depends on the configuration of summer and winter time conversion.

Connection | Description
Parameter | The location info contains longitude, latitude and time zone.
Output Q | Q is set to hi when sunrise time is reached and holds until sunset time is reached.

In the astronomical clock function window, one of the following time zone location of 5/6 series can be selected :

· Beijing

· Berlin

· London

· Rome

· Moscow

· Tokyo

· Washington

· Ankara

· Madrid

· Amsterdam

If anyone of these locations has been selected, PC soft uses the latitude, longitude, and time zone of your selection.

Alternatively, set a specific latitude, longitude, and time zone for your location and provide a name for this custom location is allowable.

The correct sunrise and sunset time of current day of 5/6 series will be calculated based on the location and time zone. The configured block also takes summer and winter time, if PC soft is installed on the computer.

Configuration: select check box of "Automatically adjust clock for daylight for saving changes" in the "Date and Time Properties" dialog.

Timing diagram

The function calculates the value at the input and sets or resets Q depending on the sunrise and sunset time at the configured location and time zone of the module.


Stopwatch

The function of stopwatch is to record the time elapsed when it was enabled.

Connection | Description
Input En | En (Enable) is the monitoring input. The elapsed time starts counting when En transitions from 0 to 1. If En transitions from 1 to 0, the elapsed time will be frozen.
Input Lap | Input Lap (positive edge (0 to 1 transition)) pauses the stopwatch and sets output to lap time. Input Lap (negative edge (1 to 0 transition)) resumes the stopwatch and sets the output to current elapsed time.
Input R | input R (Reset) is to clear the current elapsed time and lap time.
Parameter | Elapsed time that can set hours, minutes, seconds, or 1/100ths of seconds.
Output AQ | When input lap is negative edge (1 to 0 transition), the value of output AQ will be current elapsed time. When input lap is positive edge (0 to 1 transition), the value of output AQ will be Lap time. The value of output AQ will be reseted to 0 when it is positive edge (0 to 1 transition).

Parameters Time base

The time base can be set for the analog output:

The elapsed time of time base can be in hours, minutes, seconds, or 1/100ths of seconds (units of 10 milliseconds). The smallest time base is 10 milliseconds, or 1/100ths of seconds.

Timing diagram

Description of the function

When En = 1, the current time increases.

When En = 0, the current time counting pauses.

When En = 1 and Lap = 0, the value of output AQ is current elapsed time.

When En = 1 and Lap = 1, the current time continue increasing, but the value output AQ is Lap time.

When En = 0 and Lap =1, the value of output AQ is Lap time.

When En = 0 and Lap = 0, the value output AQ is latest current time.

When R = 1, both the current time and the Lap time are reset.


Up/Down counter

An input pulse increments or decrements an internal value, depending on the parameter setting. The output is set or reset when a configured threshold is reached. The direction of count can be changed with a signal at input Dir.

Connection | Description
Input R | You reset the output and the internal counter value to the start value (StartVal) with a signal at input R (Reset).
Input Cnt | This function counts the 0 to 1 transitions at input Cnt. It does not count 1 to 0 transitions. l Use the inputs I0~ I3 for high-frequency counts: max. 250 kHz, if the fast input is directly connected to the Up/Down counter function block. l Use any other input or circuit element for low-frequency counts (typically 5 Hz).
Input Dir | Input Dir (Direction) determines the direction of count: Dir = 0: Up Dir = 1: Down
Parameter | On: On threshold Value range: 0 ~ 999999 Off: Off threshold Value range: 0 ~ 999999 StartVal: Initial value from which to begin counting either down or up. Value range: 0 ~ 999999 Retentivity on = the status is retentive in memory.
Output Q | Q is set and reset according to the actual value at Cnt and the set thresholds.

* Start value (StartVal) is always equal to 0 for 1/2 series devices.

Parameters On and Off

The on threshold On and off threshold Off can be provided by the value of another already programmed function. Please refer to reference section.

Timing diagram

Description of the function

The function increments (Dir = 0) or decrements (Dir = 1) the internal counter by one count with every positive edge at input Cnt.

You can reset the internal counter value to the start value with a signal at the reset input R. As long as R=1, the output Q is 0 and the pulses at input Cnt are not counted.

Output Q is set and reset according to the actual value at Cnt and the set thresholds. See the following rules for calculation.

Calculation rule

If the on threshold >= off threshold, then:
Q = 1, if Cnt >= On
Q = 0, if Cnt < Off.

If the on threshold < off threshold, then:
Q = 1, if On <= Cnt < Off.

Q = 0, if Cnt >= Off or Cnt < On

Caution

The function polls the limit value of the counter once in each cycle.

Thus, if the pulses at the fast inputs I0~ I3 are faster than the scan cycle time, the SFB might not switch until the specified limit has been exceeded.

Example: Up to 100 pulses per cycle can be counted; 900 pulses have been counted so far. On = 950; Off = 1000. The output is set in the next cycle, after the value has reached 1000.

The output would not be set at all if the value Off = 980.


Hours counter

A configured time is triggered with a signal at the monitoring input. The output is set when this time has expired.

Connection | Description
Input R | A positive edge (0 to 1 transition) at input R resets output Q and sets a configured value MI at the counter for the duration of the time-to-go (MN).
Input En | En is the monitoring input. 1/2/5/6-Series scan the On Time of this input.
Input Ral | A positive edge at input Ral (Reset all) resets the hours counter (OT) and the output, and sets the time-to-go value (MN) to the configured maintenance interval (MI): ● Output Q = 0 ● The measured operating hours OT = 0 ● The time-to-go of the maintenance interval MN=MI.
Parameter | MI: Maintenance interval to be specified in units of hours and minutes. Value range : 0000...9999 h, 0…59 m ( * ) OT: Accumulated total operating time. An offset start time can be specified in hours and minutes. Value range : 00000...99999 h, 0...59 m ( * ) Q à 0: ● When "R" is selected: Q = 1, if MN = 0; Q = 0, if R = 1 or Ral = 1 ● When "R+En" is selected: Q = 1, if MN = 0; Q = 0, if R = 1 or Ral = 1 or En = 0.
Output Q | The output is set when the time-to-go MN = 0. The output is reset: ● When "Qà 0:R+En", if R = 1 or Ral = 1 or En = 0 ● When "Qà 0:R", if R = 1 or Ral = 1.

* MI and OT are not support minutes unit for 1/2 series devices.

Parameter MI

For the 5/6 series devices,the maintenance interval MI can be provided by the actual value of another already programmed function. Please refer to reference section.

Timing diagram

MI = Configured time interval
MN = Time-to-go
OT = Total time expired since the last 1 signal at the Ral input
These values are always retentive.

Description of the function

The hours counter monitors input En. As long as the status at this input is 1, 1/2/5/6 Series calculate the expired time and the time-to-go MN. 1/2/5/6 Series display these times when set to configuration mode. The output is set to 1 when the time-to-go is equal to zero.

You reset output Q and the time-to-go counter to the specified value MI with a signal at input R. The operation hour counter OT remains unaffected.

You reset output Q and the time-to-go counter to the specified value MI with a signal at input Ral. The operation hour counter OT is reset to 0.

Depending on your configuration of the Q parameter, the output is either reset with a reset signal at input R or Ral ("Q à R"), or when the reset signal is 1 or the En signal is 0 ("Q à R+En").

Limit value of OT

The value of the operating hours in OT are retained when you reset the hours counter with a signal at input R. The hours counter OT continues the count as long as En = 1, irrespective of the status at the reset input R. The counter limit of OT is 99999 h. The hours counter stops when it reaches this value.

In programming mode, you can set the initial value of OT. The counter starts operation at any value other than zero. MN is automatically calculated at the START, based on the MI and OT values.

Example: MI = 100, OT = 130, the result is MN = 70


Threshold trigger

The output is switched on and off depending on two configurable frequencies.

Connection | Description
Input Fre | The function counts 0 to 1 transitions at input Fre. Transitions from 1 to 0 are not counted. ● Use the inputs I0, I1, I2, and I3 for high-frequency counts: max 250 kHz (hi-speed checked), if the fast input is directly connected to the threshold trigger function block ● Use any other input or circuit element for low frequencies (typical 5 Hz).
Parameter | On: On threshold. Value range: 0000...9999 Off: Off threshold. Value range: 0000...9999 G_T: Time interval or gate time during which the input pulses are measured. Value range: 00:00s...99:99s
Output Q | Q is set or reset according to the threshold values.

Parameter G_T

For the 5/6 series devices,the gate time G_T can be provided by the actual value of another already programmed function. Please refer to reference section.

Timing diagram

Description of the function

The trigger measures the signals at input Fre. The pulses are captured during a configurable period G_T. Q is set or reset according to the set thresholds. See the following calculation rule.

Calculation rule

● If the threshold (On) ≥ threshold (Off), then:
Q = 1, if fa > On ;

Q = 0, if fa ≤ Off.

● If the threshold (On) < threshold (Off), then

Q = 1, if On <= fa < Off.


Mathematical instruction

The Mathematical instruction calculates the value AQ of an equation formed from the user-defined operands and operators.

Connection | Description
Input En | Enable the function of Mathematical instruction.
Parameter | V1: Value 1: First operand V2: Value 2: Second operand V3: Value 3: Third operand V4: Value 4: Fourth operand Operator1: First operator Operator2: Second operator Operator3: Third operator Priority1: Priority of first operation Priority2: Priority of second operation Priority3: Priority of third operation p: Number of decimals Range of values : 0, 1, 2, 3, 4, 5
Output AQ | The result of AQ is equation formed from the operand values and operators.

Parameters V1, V2, V3, and V4

The values V1, V2, V3, and V4 can be provided by the actual value of another programmed function. Please refer to reference section.

Parameter p (number of decimals)

Parameter p applies to the display of V1, V2, V3, V4 and AQ in a message text.

Description of the function

The Mathematical instruction function equation is combined by four operands and three operators. The operator can be any one of the four operators: +, -, *, or /. For each operator, you must set a unique priority of High ("H"), Medium ("M"), or Low ("L"). The high operation, followed by the medium operation, will be performed first, and then by the low operation. Exactly one operation of each priority is required. The operand values can refer to previously-defined function to provide the value.

The number of operand values is fixed at four and the number of operators is fixed at 3. To use fewer operands, you can use constructions such as " + 0" or " * 1" to fill the remaining parameters.

You can also configure the behavior of the function when the Enable parameter "En"=0. The function block can either retain its last value or be set to 0.

Examples

The following tables show some simple example Mathematical instruction block parameters, resulting equations and output values:

V1 | Operator1 (Priority 1) | V2 | Operator2 (Priority 2) | V3 | Operator3 (Priority 3) | V4
12 | + (M) | 6 | / (H) | 3 | - (L) | 1

Equation: (12 + (6 / 3)) - 1

Result: 13

V1 | Operator1 (Priority 1) | V2 | Operator2 (Priority 2) | V3 | Operator3 (Priority 3) | V4
2 | + (L) | 3 | * (M) | 1 | + (H) | 4

Equation: 2 + (3 * (1 + 4))

Result: 17

V1 | Operator1 (Priority 1) | V2 | Operator2 (Priority 2) | V3 | Operator3 (Priority 3) | V4
100 | - (H) | 25 | / (L) | 2 | + (M) | 1

Equation: (100 – 25) / (2 + 1)

Result: 25


Analog comparator

The output is set or reset depending on two configurable thresholds (hysteresis).

Connection | Description
Inputs Ax, Ay | Inputs Ax, Ay are two analog signals.
Parameter | A: Gain Value range: +- 10.00 B: Zero offset Value range: +- 10,000 On: On threshold Value range: +- 20,000 Off: Off threshold Value range: +- 20,000 p: Number of decimals Value range: 0, 1, 2, 3
Output Q | Q is set or reset depending on the set thresholds.

Parameters On and Off

For the 5/6 series devices,the on threshold On and the off threshold Off can be provided by the actual value of another programmed function. Please refer to reference section.

Parameter p (number of decimals)

Parameter p applies only to Ax, Ay, Delta, On and Off values displayed in a message text.

Parameter p does not apply to the comparison of on and off values. (The compare function ignores the decimal point.)

Timing diagram

Description of the function

The function reads the value of the signal at the analog input Ax.

This value is multiplied by the value of parameter A (gain). Parameter B (offset) is added to the product, hence

(Ax × gain) + offset = Actual value Ax.
(Ay × gain) + offset = Actual value Ay.

Output Q is set or reset depending on the difference of the actual values Ax – Ay and the set thresholds. See the following calculation rule.

Calculation rule

● If threshold On >= threshold Off, then:
Q = 1, if (actual value Ax - actual value Ay) > On
Q = 0, if (actual value Ax - actual value Ay) <= Off.

● If threshold On < threshold Off, then Q = 1, then:
On <= (actual value Ax - actual value Ay) < Off.

Reducing the input sensitivity of the analog comparator

You can delay the output of the analog comparator selectively by means of the "on delay" and "off delay" SFBs. By doing so, you determine that output Q is only set if the input trigger length Trg (= output of the analog comparator) exceeds the defined on delay time.

This way you can set a virtual hysteresis, which renders the input less sensitive to short changes.


Analog threshold trigger

The output is set or reset depending on two configurable thresholds (hysteresis).

Connection | Description
Input Ax | Input Ax is one of analog signals.
Parameter | A: Gain Value range: +- 10.00 B: Zero offset Value range: +- 10,000 On: On threshold Value range: +- 20,000 Off: Off threshold Value range: +- 20,000 p: Number of decimals Value range: 0, 1, 2, 3
Output Q | Q is set or reset depending on the set thresholds.

Parameters On and Off

For 5/6 series devices, the On and Off parameters can be provided by the actual value of another programmed function.

Parameter p (number of decimals)

Parameter p applies only to the display of On, Off and Ax values in a message text.

Parameter p does not apply to the comparison of On and Off values. (The compare function ignores the decimal point.)

Timing diagram

Description of the function

The function reads the value of the signal at the analog input Ax.
This value is multiplied by the value of parameter A (gain). Parameter B (offset) is added to the product, hence

(Ax * Gain) + Offset = Actual value Ax.

Output Q is set or reset depending on the set threshold values. See the following calculation rule.

Calculation rule

● If threshold (On) >= threshold (Off), then:
Q = 1, if the actual value Ax > On
Q = 0, if the actual value Ax <= Off.

● If threshold (On) < threshold (Off), then Q = 1, if
On <= the actual value Ax < Off.

Particular characteristics to be noted when configuring

Note

The decimal point setting must be identical in the minimum and maximum range.


Analog amplifier

This SFB amplifies an analog input value and returns it at the analog output.

Connection | Description
Input Ax | Input Ax is a analog signals.
Parameter | A: Gain Value range: +- 10.00 B: Zero offset Value range: +- 10,000 p: Number of decimals Value range: 0, 1, 2, 3
Output AQ | Value range for AQ: -32768...+32767

Parameter p (number of decimals)

Parameter p applies only to the display of Ax and Ay values in a message text.

Parameter p does not apply to the comparison of On and Off values. (The compare function ignores the decimal point.)

Description of the function

The function reads the value of an analog signal at the analog input Ax.

This value is multiplied by the gain parameter A. Parameter B (offset) is added to the product, as follows:

(Ax × gain) + offset = Actual value Ax.

The actual value Ax is output at AQ.

Analog output

If you connect this special function to a real analog output, then note that the analog output can only process values from 0 to 1000. To do this, connect an additional amplifier between the analog output of the special function and the real analog output. With this amplifier you standardize the output range of the special function to a value range of 0 to 1000.

Example: additional amplifier behind an analog multiplexer.


Analog watchdog

This special function saves the process variable of an analog input to memory, and sets the output when the output variable exceeds or drops below this stored value plus a configurable offset.

Connection | Description
Input En | A positive edge (0 to 1 transition) at input En saves the analog value at input Ax ("Aen") to memory and starts monitoring of the analog range Aen +- Delta.
Input Ax | You apply the analog signal to be monitored at input Ax. Use the analog inputs AI, the analog flags AM, the block number of a function with analog output, or the analog outputs AQ. AI: 0 - 10 V corresponds with 0 - 1000 (internal value).
Parameter | A: Gain Value range: +- 10.00 B: Zero offset Value range: +- 10,000 Threshold 1 (upper +): Difference value above Aen: on/off threshold Value range: 0 - 20,000 (*) Threshold 2 (lower -): Difference value below Aen: on/off threshold Value range: 20,000 - 0 (*) p: Number of decimals Value range: 0, 1, 2, 3
Output Q | Q is set/reset, depending on the stored analog value and the offset.

* For 1/2 series devices , Threshold = upper+ = lower-.

Parameters Threshold 1 and Threshold 2

For 5/6 series devices, the two threshold (Threshold 1 and Threshold 2) parameters can be provided by the actual value of another programmed function. Please refer to reference section.

Parameter p (number of decimals)

Does not apply to the display of On, Off and Ax values in a message text.

Does not apply to the comparison of On and Off values! (The compare function ignores the decimal point.)

Timing diagram

Description of the function

A 0 to 1 transition at input En saves the value of the signal at the analog input Ax. This saved process variable is referred to as Aen".

Both the analog actual values Ax and Aen are multiplied by the value at parameter A (gain), and parameter B (offset) is then added to the product, i.e.

(Ax × gain) + offset = Actual value Aen, when input En changes from 0 to 1, or

(Ax × gain) + offset = Actual value Ax.

Output Q is set when the signal at input En = 1 and if the actual value at input Ax is out of range of Aen+upper / Aen-lower.

Output Q is reset, when the actual value at input Ax lies within the range of Aen+upper / Aen-lower, or when the signal at input En changes to lo.


Analog differential trigger

The output is set and reset depending on a configurable threshold and a differential value.

Connection | Description
Input Ax | You apply the analog signal to be analyzed at input Ax. Use the analog inputs AI, the analog flags AM, the block number of a function with analog output, or the analog outputs AQ. 0 - 10 V is proportional to 0 - 1000 (internal value).
Parameter | A: Gain Range of values: ±10.00 B: Zero offset Range of values: ±10,000 On: On/Off threshold Range of values: ±20,000 Δ: Differential value for calculating the off parameter Range of values: ±20,000 p: Number of decimals Range of values: 0, 1, 2, 3
Output Q | Q is set or reset, depending on the threshold and difference values.

Parameter p (number of decimals)

Parameter p applies only to the display of On, Off and Ax values in a message text.

Parameter p does not apply to the comparison of On and Off values. (The compare function ignores the decimal point.)

Timing diagram A: Function with negative difference Delta

Timing diagram B: Function with positive difference Delta

Description of the function

The function fetches the analog signal at input Ax.

Ax is multiplied by the value of the A (gain) parameter, and the value at parameter B (offset) is added to product, i.e.

(Ax * gain) + offset = actual value of Ax.

Output Q is set or reset, depending on the set (On) threshold and difference value (Delta). The function automatically calculates the Off parameter: Off = On + Delta, whereby Delta may be positive or negative. See the calculation rule below.

Calculation rule

● When you set a negative differential value Delta, the On threshold >= Off threshold, and:
Q = 1, if the actual value Ax > On
Q = 0, if the actual value Ax <= Off.
See the timing diagram A.

● When you set a positive differential value Delta, the On threshold < the Off threshold, and Q = 1, if:
On <= the actual value Ax < Off.
See the timing diagram B.


Analog MUX

When Analog MUX is enabled, the analog multiplexer SFB displays one of four pre-defined analog values, depending on input conditions.

Connection | Description
Input En | 1 on input En (Enable) switches, dependent on S1 and S2, a parameterized analog value to the output AQ. 0 on input EN switches 0 to the output AQ.
Inputs S1 and S2 | S1 and S2 (selectors) for selecting the analog value to be issued. S1 = 0 and S2 = 0: The value V1 is issued S1 = 0 and S2 = 1: The value V2 is issued S1 = 1 and S2 = 0: The value V3 is issued S1 = 1 and S2 = 1: The value V4 is issued
Parameter | V1-V4: Analog values (Value) that will be issued. Value range: -32768 to +32767 p: Number of decimal places. Possible settings: 0, 1, 2, 3
Output AQ | Analog output , Value range for AQ: -32768 to +32767

Parameters V1…V4

The values for V1…V4 can be provided by the value of another programmed function. Please refer to reference section.

Parameter p (number of decimal places)

Parameter p only applies to the display of AQ, V1, V2, V3 and V4 values in message text.

Timing diagram

Description of function

If input En is set, the function issues one of four possible analog values V1 to V4 at the output AQ, and depending on the inputs S1 and S2.

If the input En is not set, the function issues the analog value 0 at output AQ.

Particular characteristics to be noted when configuring.

Analog output

If you connect this special function to a real analog output, the analog output can only process values from 0 to 1000. To do this, connect an additional amplifier between the analog output of the special function and the real analog output. With this amplifier you standardize the output range of the special function to a value range of 0 to 1000.

Example: additional amplifier behind an analog multiplexer.


Analog Ramp

The Analog Ramp allows the output to be changed from the current level to the selected level at a specified rate.

Connection

Description

Input En

A change in the status from 0 to 1 at input En (Enable) applies the start/stop level (Offset "B" + StSp) to the output for 100 ms and starts the ramp operation to the selected level.

A change in the status from 1 to 0 immediately sets the current level to Offset "B", which makes output AQ equal to 0.

Input Sel

Sel = 0: The step 1 (level 1) is selected.

Sel = 1: The step 2 (level 2) is selected.

A change in status of Sel causes the current level to start changing to the selected level at the specified rate.

Input St

A change in the status from 0 to 1 at input St (Decelerated Stop) causes the current level to decrease at a constant rate until the start/stop level (Offset "B" + StSp) is reached. The start/stop level is maintained for 100 ms and then the current level is set to Offset "B", which makes output AQ equal to 0.

Parameter

Level1 and Level2: Levels to be reached.

Value range for each level: -10,000 to +20,000

MaxL: Maximum value that must not be exceeded.

Value range: -10,000 to +20,000

StSp: Start/Stop offset: value that is added to Offset "B" to create the start/stop level. If the Start/Stop offset is 0, then the start/stop level is Offset "B").

Value range: 0 to +20,000

Rate: Speed with which level 1, level 2 or 0ffset is reached. Steps/seconds are issued.
Value range: 1 to 10,000

A: Gain

Value range: 0 to 10,00

B: Offset

Value range: +- 10.000

p: Number of decimal places

Value range: 0, 1, 2, 3

Output AQ

The output AQ is scaled using the formula: (Current Level - Offset "B") / Gain "A"

Note: When AQ is displayed in parameter mode or message mode, it is displayed as an unscaled value (engineering units: current level).

Value range for AQ: 0...+32767

Parameters Level1 and Level2

The level parameters Level1 and Level2 can be provided by the actual value of another programmed function. Please refer to reference section.

Parameter p (number of decimal places)

Parameter p only applies to display the values of AQ, level 1, level 2, MaxL, StSp, and Rate in message text.

Timing diagram for AQ

Description of function

If the input En is set, the function sets the value StSp + Offset "B" for 100 ms.

The function runs from the level StSp + Offset "B" to either level 1 or level 2 at the acceleration set in Rate that depends on the connection of Sel.

If the input St is set, the function runs to a level of StSp + B at the acceleration set in Rate. Then the function holds the level at StSp + Offset "B" for 100 ms.

After 100 ms, the level is set to Offset "B". output AQ, and the scaled value (output AQ) is 0.

If the input St is set, the function can only be restarted once the inputs St and En have been reset.

If input Sel has been changed, the function runs from the current target level to the new target level at the rate that is specified, and depending on the connection of Sel.

If the input En is reset, the function immediately sets the current level to Offset "B".

The current level is updated every 100 ms.

Note the relationship between output AQ and the current level:

Output AQ = (current level – Offset "B") / Gain "A"


PI controller

PI controller is a proportional-action and integral-action controller that can be used on both proportional action and integral action individually or combined.

Connection | Description
Input A/M | Set the mode of the controller: 0: manual mode 1: automatic mode
Input R | Use the input R to reset the output AQ. As long as this input is set, the input A/M is disabled. The output AQ is set to 0.
Input PV | Analog value: process value, influences the output
Parameter | Sensor: Type of sensor being used Min.: Minimum value for PV Value range: -10,000 to +20,000 Max.: Maximum value for PV Value range: -10,000 to +20,000 A: Gain Value range: +- 10.00 B: Offset Value range: +- 10,000 SP: Set-value assignment Value range: -10,000 to +20,000 Mq: Value from AQ with manual mode. Value range: 0 to 1,000 Parameter sets: application-related presets for KC, TI and Dir (see below) KC: Gain Value range: 00.00 to 99.99 TI: Integral time Value range: 00:01 min to 99:59 min Dir: Action direction of the controller Value range: + or - p: Number of decimal places Value range: 0, 1, 2, 3
Output AQ | Analog output (manipulated variable) Value range for AQ: 0 to 1,000

Parameters SP and Mq

The set-value SP and the value for Mq can be provided by the actual value of another programmed function. Please refer to reference section.

Parameter P (number of decimal places)

Parameter p only applies to display the values from PV, SP, Min. and Max. in essage text.

Timing diagram

The nature, manner and speed with which the AQ changes depends on the parameters KC and TI. Thus, the course of AQ in the diagram is merely an example. A control action is continuous; therefore the diagram portrays just an extract.

1

A disturbance causes the PV to drop, as Dir is positioned upwards, AQ increases until PV corresponds again to SP.

2

A disturbance causes the PV to drop, as Dir is positioned upwards, AQ decreases until PV corresponds again to SP.

Dir is coordinated to the basic conduct of a control loop. The direction (dir) cannot be changed during the term of the function. The change in Dir here is shown for the purposes of clarification.

3

As AQ is set to 0 by means of the input R, PV changes. This is based on the fact that PV increases, which on account of Dir = upwards causes AQ to drop.

Description of Function

If the input A/M is set to 0, the special function issues output AQ with the value that you set with parameter Mq.

If the input A/M is set to 1, automatic mode commences.

As an integral sum the value Mq is adopted, the controller function begins the calculations in accordance with the formulas.

The updated value PV is used in the formulas.

Updated value PV = (PV * gain) + offset

If the updated value PV = SP, the special function does not change the value of AQ.

Dir = upwards/+ (timing diagram number 1,3)

If the updated value PV > SP, then the special function reduces the value of AQ.

If the updated value PV < SP, then the special function increases the value of AQ.

Dir = downwards/- (timing diagram number 2)

If the updated value PV > SP, the special function increases the value of AQ.

If the updated value PV < SP, the special function reduces the value of AQ.

With a disturbance, AQ increases or decreases until the updated value PV again corresponds to SP.

The speed with which AQ changes depends on the parameters KC and TI.

If the input PV exceeds the parameter Max., the updated value PV is set to the value of Max.

If the PV falls short of the parameter Min., the updated value PV is set to the value of Min.

If the input R is set to 1, the AQ output is reset.

As long as R is set, the input A/M is disabled.

Sampling time

The sampling time is fixed at 500 ms.

Parameter sets

In order to simplify the use of the PI controller, the parameters of KC, TI and Dir are already given as sets for the following applications:

Parameter set | Application example | Parameter KC | Parameter TI (s) | Parameter Dir
Temperature fast | Temperature, cooling control of small spaces; small volumes | 0.5 | 30 | +
Temperature slow | Heating, ventilation, temperature, cooling control of large spaces; large volumes | 1.0 | 120 | +
Pressure 1 | Quick pressure change, compressor control | 3.0 | 5 | +
Pressure 2 | Slow pressure change, differential pressure control (flow controller) | 1.2 | 12 | +
Full level 1 | Vat and/or reservoir filling without drain | 1.0 | 99:59 | +
Full level 2 | Vat and/or reservoir filling with drain | 0.7 | 20 | +


PWM

The Pulse Width Modulator (PWM) modulates the analog input value Ax to a pulsed digital output signal. The pulse width is proportional to the analog value Ax.

Connection | Description
Input En | A positive edge (0 to 1 transition) at input En enables the PWM function block.
Input Ax | Analog signal to be modulated to a pulsed digital output signal.
Parameter | A: Gain Range of values: -10.00 to +10.00 B: Zero offset Range of values: -10,000 to +10,000 PT: Periodic time over which the digital output is modulated Out : Q0 ~ Q3(High speed) , disable (low speed) p: Number of decimals Possible settings: 0, 1, 2, 3
Output Q | Q is set or reset for the proportion of each time period according to the proportion of the standardized value Ax to the analog value range ( when selected Q0 to Q3 , block output Q is always 0).

Parameter PT

The periodic time PT can be provided by the actual value of programmed function. Please refer to reference section.

Parameter p (number of decimals)

Parameter p only applies to the display of the Ax value in message text.

Description of the function

The function reads the value of signal at the analog input Ax.

This value is multiplied by the value of parameter A (gain). Parameter B (offset) is added to the product, as follows:

(Ax * Gain) + Offset = Actual value Ax

The function block calculates the proportion of the value Ax to the range. The block sets the digital output Q high for the same proportion of the PT (periodic time) parameter, and sets Q low for the remainder of the time period.

Examples with Timing Diagrams

The following examples show how the PWM instruction modulates a digital output signal from the analog input value:

Example 1: Analog input value: 500 (range 0...1000) Periodic time T: 4 seconds

The digital output of the PWM function is 2 seconds high, 2 seconds low, 2 seconds high, 2 seconds low and continues in that pattern as long as parameter "En" = high.

Example 2: Analog input value: 300 (range 0...1000) Periodic time T: 10 seconds

The digital output of the PWM function is 3 seconds high, 7 seconds low, 3 seconds high, 7 seconds low and continues in that pattern as long as parameter "En" = high

Calculation rule

Q = 1, for (Ax – Min) / (Max – Min) of time period PT
Q = 0, for PT – [(Ax – Min) / (Max – Min)] of time period PT.

Note: Ax in calculation refers to the actual value Ax as calculated using the Gain and Offset.

Min and Max refer to the minimum and maximum values specifed for the range.


Analog filter

Connection | Description
Input Ax | Input Ax is one of the following analog signals: ● AI (*) ● AM ● AQ ● The block number of a function with analog output
Parameter | Sn (Number of samples): determines how many analog values are sampled within the program cycles that are determined by the set number of samples. 51/61 series samples an analog value within every program cycle. The number of program cycles is equal to the set number of samples. Possible settings: 8, 16, 32, 64, 128, 256
Output AQ | AQ outputs an average value of the analog input Ax over the current number of samples, and it is set or reset depending on the analog input and the number of samples.

* AI : 0 to 10 V corresponds with 0 to 1000 (internal value).

Parameter

You can set the number of samples to the values as shown below:

After you set the parameter, the analog filter calculates the average value of the samples and assigns this value to AQ.

Timing diagram

Description of function

The function outputs the average value after sampling the analog input signal according to the set number of samples. This SFB can reduce the error of analog input signal.

Note : Maximum eight analog filter function blocks which are available to use in the circuit program.


Max/Min

The Max/Min function block records the maximum or minimum value.

Connection | Description
Input En | The function of input En (Enable) depends on the settings of parameter Mode and the selection of check box "when En = 0, reset Max/Min".
Input S1 | This input is enabled when you set Mode =2: A positive transition (0 to 1) at input S1 sets the output AQ to the maximum value.. A negative transition (1 to 0) at input S1 sets the output AQ to the minimum value.
Input Ax | Input Ax is one of the following analog signals: ● AI (*) ● AM ● AQ ● The block number of a function with analog output
Parameter | Mode: Possible settings: 0, 1, 2, 3 Mode = 0: AQ = Min Mode = 1: AQ = Max Mode = 2 and S1= 0 (low): AQ = Min Mode = 2 and S1= 1 (high): AQ = Max Mode = 3 or a block value is referenced: AQ = Ax
Output AQ | AQ ouptuts a minimum, maximum, or actual value depending on the inputs, or is reset to 0 if configured to do so when function is disabled

* AI : 0 to 10 V corresponds with 0 to 1000 (internal value).

Parameter Mode

You can set the values for parameter Mode which is based on the actual values of programmed function.

Timing diagram

Description of the function

If you select the check box "when En = 0, reset Max/Min":

En = 0: The function sets the AQ value to 0.

En = 1: The function outputs a value at AQ, depending on the settings of Mode and S1.

If you do not select the check box "when En = 0, reset Max/Min":

En = 0: The function holds the value of AQ at the current value.

En = 1: The function outputs a value at AQ, depending on the settings of Mode and S1.

Mode = 0: The function sets AQ to the minimum value

Mode = 1: The function sets AQ to the maximum value

Mode = 2 and S1 = 0: The function sets AQ to the minimum value

Mode = 2 and S1 = 1: The function sets AQ to the maximum value

Mode = 3 or a block value is referenced: The function outputs actual analog input value.


Average Value

The average value function samples the analog input signal during configured time period and outputs the average value at AQ.

Connection | Description
Input En | A positive edge (0 to 1 transition) at input En (Enable) sets the output AQ to the average value of input Ax after the configured time. A negative edge (1 to 0 transition) holds the output at its last calculated value.
Input R | A positive edge (0 to 1 transition) at input R (Reset) resets the output AQ to 0.
Input Ax | Input Ax is one of the following analog signals: ● AI (*) ● AM ● AQ ● The block number of a function with analog output
Parameter | St (Sampling time): You can set it to Seconds, Days, Hours or Minutes. Range of values: If St = Seconds: 1 to 59 If St = Days: 1 to 365 If St = Hours: 1 to 23 If St = Minutes: 1 to 59 Sn (Number of samples): Range of values: If St = Seconds: 1 to St*100 If St = Days: 1 to 32767 If St = Hours: 1 to 32767 If St = Minutes and St ≤ 5 minutes: 1 to St*6000 If St = Minutes and St ≥ 6 minutes: 1 to 32767
Output AQ | AQ outputs the average value over the specified time of sampling.

* AI : 0 to 10 V corresponds with 0 to 1000 (internal value).

Parameter St and Sn

Parameter St represents the sampling time, and parameter Sn represents the number of samples.

Timing diagram

Description of the function

When En = 1, the average value function calculates the average value of the samples during the configured time interval.

At the end of the sampling time, this function sets output AQ to this calculated average value.

When En = 0, the calculation stops, and AQ retains the last calculated value. When R = 0, AQ is reset to 0.


Latching relay

A signal at input S sets output Q. A signal at input R resets output Q.

Connection | Description
Input S | Set output Q with a signal at input S (Set).
Input R | Reset output Q with a signal at input R (Reset). Output Q is reset if S and R are both set (reset has priority over set).
Parameter | Retentivity set (on) = the status is retentive in memory.
Output Q | Q is set with a signal at input S and remains set until it is reset with signal at input R.

Timing diagram

Description of the function

The latching relay represents a simple binary memory logic. The output value depends on the input states and the previous status at the output.

Logic table of the latching relay:

S | R | Q | Remark
0 | 0 | x | Status unchanged
0 | 1 | 0 | Reset
1 | 0 | 1 | Set

When retentivity is enabled, the output signal corresponds with the signal status prior to the power failure.


Pulse relay

The output is set and reset with a short one-shot at the input.

Connection | Description
Input Trg | You switch output Q on or off with a signal at input Trg (Trigger) input.
Input S | A one-shot at input S (Set) sets the output to logical 1.
Input R | A one-shot at input R (Reset) resets the output to logical 0
Parameter | Selection: RS (input R priority), or SR (input S priority) Retentivity set (on) = the status is retentive in memory.
Output Q | Q is switched on with a signal at Trg and is reset again at the next Trg pulse, if both S and R = 0.

Timing diagram

Description of the function

The status of output Q changes with each 0 to 1 transition at input Trg and if both S and R = 0, that is, the output is switched on or off.

Input Trg does not influence the SFB when S = 1 or R = 1.

A one-shot at input S sets the pulse relay, that is, the output is set to logical 1.

A one-shot at input R resets the pulse relay to its initial state, that is, the output is set to logical 0.

Either the input R takes priority over input S (the signal at input S has no effect as long as R = 1), or the input S takes priority over input R (the signal at input R has no effect as long as S = 1), depending on your configuration.

Caution

If Trg = 0 and Par = RS, the "Pulse relay" SFB corresponds with the "Latching relay" SFB function.


Message Text

For 1/2 Series :

Short description
This function displays message texts and parameters of other blocks on 1/2-Series when it is in RUN mode.

Connection | Description
Inputs En | A 0 to 1 transition at En (Enable) triggers the output of the message text.
Inputs P | P is the priority of the message text. 0 is the lowest, 15 the highest priority. Ack: Acknowledgement of the message text.
Parameter | Text: Input of the message text Par: Parameter or actual value of another, already configured , which can be displayed numerically or as a bar graph (see "Visible parameters or actual values") Time: Shows the continuously updated time-of-day Date: Shows the continuously updated date EnTime: Display of the time of the 0 to 1 transition EnDate: Display of the date of the 0 to 1 transition
Output Q | Q remains set as long as the message text is queued.

Description of the function
With a 0 to 1 transition of the signal at input En, the display outputs your configured message text (actual value, text, date) in RUN mode.

Acknowledgement disabled (Ack = Off):

The message text is hidden with a 0 to 1 signal transition at input En.

Acknowledgement enabled (Ack = On):

After input En is reset to 0, the message text is displayed until acknowledged by pressing the OK button. The message text cannot be acknowledged as long as input En is high.

If several message text functions were triggered with En=1, the message with the highest priority (0 = lowest, 15 = highest) is displayed. This also implies that a new message text is only displayed if its priority is higher than that of previously enabled message texts.

After a message text is disabled or acknowledged, the function automatically shows the previously active message text that takes the highest priority.

Restrictions
Up to 16 message text functions are available.

For 5/6 Series :

Short Description

In RUN mode, The function can operate on the 5/6 Series controller or ATP2 text panel. It can display the controller status and parameters.

The 5/6 Series controller and ATP2 text panel can support whole new functions. You can via the software to edit the program.

Connection

Description

Input En

0 to 1 transition at En (Enable) triggers the output of the message text.

Input P

P is the priority of the message text.

0 is the lowest, 15 is the highest priority.

Ack: Acknowledgement of the message text

Parameter

Text: Input of the message text

Par: Parameter or actual value of another, already configured function, Diversity Patterns, Scroll-in Text, Bar Charts.

Time: Shows the continuously updated time-of-day

Date: Shows the continuously updated date

EnTime: Shows the time of the 0 to 1 transition

EnDate: Shows the 0 to 1 transition of the date

I/O States： Display digital input or output status, for example “On” & “Off”. The 5/6 series controller can display below elements states.

  • Digital input
  • Digital output
  • Flag
  • Function Key
  • Shift Register
  • Function Block output

Analog input： Display of analog input value to the shown in message text and updated according to the analog time.

Scale time（5/6 Series）： Display of the actual value of a referenced function block as a time value scaled based on the timebase configured for the message text function block. Possible time display formats are as shown below:

  • hours : minutes : seconds . milliseconds
  • hours : minutes : seconds
  • hours : minutes
  • hours

（for example, “02:30:15.15”）

Output Q

Q remains set as long as the message text is queued.

Settings

In addition to the function block inputs and the parameters of the message text, the following setting provides additional control over the display of message texts: ：

  • Character set selection： You can choose to compose a message text from characters from the primary character set or the secondary character set. You set the two character sets from either the “Msg Config” menu on the 5/6 series controller, or by using the software File → Message Text Settings menu command.
  • Message destination: You can choose to display the message text on the 5/6 series controller on-board display, or the ATP2 text panel, or both.
  • Tick settings: The message text can tick or not tick, meaning it can scroll on and off the display. The tick capabilities and your choices are described in more detail below.

Description of the function

In RUN mode, with a 0 to 1 transition of the signal at input En, the 5/6 series controller on-board display and/or ATP2 text panel displays your configured message text, or both.

When the “Acknowledgement message” checkbox is not selected, the message text is hidden with a 1 to 0 signal transition at input En.

When the “Acknowledgement message” checkbox is selected, then after input En is reset to 0, the message text is displayed until acknowledged by pressing the OK button. The message text cannot be acknowledged as long as input En is high.

If several message text functions were triggered with En=1, the message with the highest priority (0=lowest, 15=highest) is displayed. This also implies that a new message text is only displayed if its priority is higher than that of previously enabled message texts.

If the circuit program uses flag M511, then whenever M511 = 0（low）, the 5/6 series controller only displays message texts that are in the primary character set (Character Set 1). If M511 = 1（high），the 5/6 series controller only displays message texts that are in the secondary character set (Character Set 2).

After a message text is disabled or acknowledged, the display automatically shows the previously active message text with the highest priority.

You can change between the display in RUN mode and the message texts by means of the▲ and the ▼ buttons.

Particular characteristics to be noted when configuring.

①

Block name area

Here you can provide a name for the block.

②

Settings area

Here you can configure the following settings:

  • Priority of the message text
  • Acknowledge Message check box: if set requires a message to be acknowledged in order to be closed
  • Character set selection for the message text

③

Tick area

Here you define the tick parameters for the message text:

  • Character by Character tick format
  • Line by Line tick format
  • Tick enabled checkbox for each display line

④

Message destination area

Here you choose whether the target destination for the message is the 5/6 series controller on-board display, the ATP2 text panel, or both.

Above this area are additional buttons:

Special characters button: for inserting special characters into the message area

Bar Graph button: for placing a horizontal or vertical bar graph into the message area

AI button: for placing an analog input value into the message area

ON/OFF button: for specifying a digital value to be represented by one of two strings corresponding to the 0 state and 1 state, for example “OFF” and “ON”.

Scale time button: for referencing an actual value and showing it in a specified time base format.

AM button： for place analog flag value into the message area

Scope display: for choice use Scope to display the value in the message text

Indicator display: for use indicator to display the value

* Graph display: for use graph disply

⑤

Block area

Here is where you select blocks from all of the blocks in the circuit program. You can subsequently choose parameters from these blocks to display in the message text.

⑥

Block parameters area

Here you can select the parameters to be displayed in the message text from the block that is selected in the Blocks area.

⑦

Insert Parameter button

This button is for inserting a selected block parameter into the message text.

To arrange the message text

The message area shows a grid of four lines and character positions. The message text configuration area is 24 characters wide for Western European character sets or 12 characters wide for Asian character sets. Either way, the character width of each line is double that of the 5/6 series controller on-board display or ATP2 text panel. Message lines that are longer than the width of the actual display can be set to “tick”.

To configure the content of a message text, follow these steps:

  1. From the “Blocks” area, select the block whose parameters you want to output.
  2. Drag and drop the parameters required from the “Block parameters” to the “Message Text” area. You can also use the “Insert” button to insert a parameter value.
  3. In the “Message Text” area, you can add parameter data, time or date values from the block parameter area as required and enter the text. To enter text, select the character set for the message text, and then type. You can also use the buttons above the message text area to add special characters, bar graphs, analog input values, and names for digital I/O states.

Message text character set

The 5/6 Series controller and higher versions support Western European character, Traditional Chinese, Simple Chinese Character. Of these, you can select two for the display of message texts with the File → Message Text Settings menu command or from the “Msg Config” menu of the 5/6 Series controller. Of the sixty possible message texts that you can configure, you can select any number of them to be the first language and any number from the second language. For example, you could configure sixty message text function blocks that have a single message text for Character Set 1. Alternatively, you could configure eight message text function blocks, each of which has two message texts: one for Character Set 1 and one for Character Set 2. Any combination is valid such that the total does not exceed sixty.

The Message text dialog displays the character sets that are currently available for your message text, as configured in the message text settings. To use a character set, select the “Enabled” check box, and the button for the character set. Characters that you subsequently type will be from the character set that you enabled and selected. If you deselect the “Enabled” check box for a character set, the software will prompt you for confirmation and then delete the message text, if it exists, that corresponds to that character set.

The character set of a message text is independent of the language setting for the 5/6 series controller on-board display menus. They can be different.

Chinese character set

The 5/6 series controller and ATP2 text panel can support Traditional Chinese (Big 5) and Simple Chinese (GB-2312). The devices use Microsoft Windows encoding for this character set. The Windows encoding allows the devices to display the same characters as shown in the software message text editor when you are using a Chinese emulator or a Chinese version of Microsoft Windows.

The Chinese character set requires a Chinese version of Windows or a Chinese emulateortoproperly display Chinese characters in the software message text editor. You must start the Chinese emulator before you open the message text function block in software.

Message ticker

You can configure a message text to tick, or to not tick. Two types of message ticking exist:

  • Character by character
  • Line by line

Messages that tick character by character scroll off the characters of the message line one character at a time to the left with the additional characters scrolling in one at a time from the right. The time interval for the tick is specified by the TickTime message text setting.

Messages that tick line by line by line scroll one half of the message of the display to the left with the second half of the message scrolling in from the right. The time interval for the tick is ten times the TickTime parameter. The two halves of the message simply alternate on the 5/6 series controller on-board display or ATP2 text panel.

The tick time is the interval of time by which a character or a line of text ticks off the screen. The tick time is a global message text parameter for all message texts.

Example: Tick Message Character by Character

The following illustration shows the configuration in the software of a one-line, 24-character message text:

If you set this message to tick “character by character” with a tick interval of 0.1 seconds, then the initial appearance of this message line on the 5/6 series controller on-board display or ATP2 text panel is as shown in this illustration:

After 0.1 second, one character of the message line ticks. The message appears as follows on the 5/6 series controller on-board display or ATP2 text panel:

After next 0.1 second, another character of the message line ticks. The message appears as follows on the 5/6 series controller on-board display or ATP2 text panel:

Example: Tick Message Line by Line

The following example uses the same message configuration as the previous example:

If you set this message to tick “line by line” with a tick interval of 0.1 seconds, then the initial appearance of this message on the 5/6 series controller on-board display or ATP2 text panel is the left half of the message as shown in this illustration:

After 1 second (10x0.1 second), the message ticks to show the right half of the message as shown in this illustration:

The screen display alternated between the two message halves every second.

You can configure each individual line of a message text to tick or not to tick at all. The “character by character” or “line by line” setting applies to all lines that you configure to tick. Select the check box beside a line number to enable ticking for that line.

Bar graphs

You can specify a bar graph representation for the actual value of any other function block in your circuit program. The bar graph can be horizontal or vertical on the 5/6 series controller on-board display or ATP2 text panel. You can configure up to eight bar graphs per message text.

Use the bar graph button [image] in the message text area to place a bar graph in the message text area. From the Bar Setting dialog you must provide the following information:

  • Block from your circuit program that the bar graph represents
  • Minimum and maximum value for the bar graph: the 5/6 series controller will calculate the length or height of the bar graph by scaling the actual value between the minimum and maximum values.
  • Orientation of the bar graph: horizontal or vertical
  • Width or height of the bar graph, in character spaces

Example:

Consider a bar graph in a message text with the following characteristics:

  • Configured bar graph length: 4 character spaces
  • Orientation: Horizontal
  • Configured minimum value: 1000
  • Configured maximum value: 2000
  • Actual value: 1750

The resulting bar graph will be 3 character spaces long.

Text representation of digital I/O states

You can assign names such as “On” or “Off” to the two states of a digital input or output. With the 5/6 series controller, you can display this name of a digital I/O state in a message text. The maximum number of characters for a state name is eight for ASCII character sets; Use the ON/OFF button in the message text area to define names for the two states of a digital input or output to be used in the message text.

Within one circuit program, a maximum of 12 I/O state names can be used in message text function blocks.

Display of remaining timer time

With the 5/6 series controller, you can display the remaining time of a timer in a message text. Prior to this feature you could display the current elapsed time of a timer and the timer parameters.

When placed in a message text, the remaining time will show the time that remains before the timer expires. For timers with multiple timer values (for example on-delay time), you can display the remaining time of each one in a message text.

Display of analog inputs

You can also select analog inputs to be displayed in a message text. Use the AI button in the message text area to select a specific AI to place in the message text area.

If you have analog inputs in a message text, the global message text setting for the Analog input filter timer specified how often the message text is updated with current values. The refresh time choices are 100 ms, 200 ms, 400 ms, 800 ms and 1000 ms. If you have more than one analog input in a message text, the refresh rate applies to them all.

Display of analog flag

You can also select an analog flag to be displayed in a message text. Use the AM button in the message text area to select a specific AM to place in the message text area.

Display Scope

You can select the display of Scope in a message text. Use the [image] button in the message text area to select a specific Scope to place in the message text area.

If you have a Scope display in the message text, the global message text setting for the Scope display input filter timer specified how often the message text is updated with current values. The refresh time choice is 50ms~500000ms. If you have more than one Scope in a message text, the refresh rate applies to them all.

Display of Indicator

You can select the display of Indicator in a message text. Use the [image] button in the message text area to select a specific Indicator to place in the message text area. The maximum and minimum values ​​based on user-set is divided into 30 scale display.

Display of Graph

You can select the display of Graph. Use the [image] button in the message text area to select 30 types of graph to place in the message text area.

Scale time

To configure the time scale for a function block, click [image] button to display the “Scaletime setting” dialog:

With this dialog, you can configure the scale time base for a function block value. You select a function block, an actual value and a time base, and click “OK” to confirm your settings.

The calculation for displaying a time value in a message text based on the configured timebase is shown below, where “C” represents the actual value:

Time base of message text | Time format | Calculation for time value
Hour | xx | C
Minute | xx : xx | C / 60 : C % 60
Second | xx : xx : xx | (C / 60) / 60 : (C / 60) % 60 :C % 60
10 milliseconds | xx : xx : xx : xx | C / 100 / 60 / 60 : ((C / 100 / 60) % 60 : (C / 100) % 60 :C % 100
/ : Integer division % : Remainder of integer division

Copying and pasting text characters

Whenever you enter characters into the message text area or into the I/O status name text edit area, you can use the keyboard shortcuts for copy（Ctrl + C）and paste（Ctrl + V）. You can copy and paste characters between any document on your computer, text in a message text, text in an I/O status name, or text in the 5/6 series controller or ATP2 text panel Power-up screen text edit area. The software verifies that any characters to be pasted are valid for the selected character set. Only character entry areas of text messages, I/O status names, and the ATP2 text panel Power-up screen support copy and paste. You cannot, for example, copy and paste bar graphs, function block parameters, or anything other than text characters of the selected character set.

You cannot use Ctrl-x to cut characters for pasting, except from a document on your computer. The software does not support the cut operation from the message text, I/O status name.

Message text after changing the character set

The software keeps the text information when you change the character set.

The software keeps only the characters supported by the current character set, and display a ”?” in place of the unsupported characters.

Restrictions

The following restrictions apply to message text function blocks:

  • Up to 16 message text functions are available.
  • Up to 256 total bar graphs in message texts are available.
  • Support all of the defined features for message texts.
  • Each message line can contain 24 characters (Western language character sets) or 12 characters (Asian language character sets). Within a message text the following limitations apply:
    • Maximum number of parameters: un-limitation
    • Maximum number of bar graphs: 256
    • Maximum number of I/O status names: 384
    • Maximum number of time/date values: un-limitation
    • Maximum number of analog inputs: un-limitation


Shift register

■ for 1/2 Series :

The shift register function can be used to read an input value and to shift the bits. The output value corresponds with the configured shift register bit. The shift direction can be changed at a special input.

Connection | Description
Input In | The function when started reads this input value.
Input Trg | The SFB is started with a positive edge (0 t 1 transition) at input Trg (Trigger). A 1 to 0 transition is irrelevant.
Input Dir | You define the shift direction of the shift register bits S0...S15 at the Dir input: Dir = 0: shift up (S0 >> S15) Dir = 1: shift down (S15 >> S0)
Parameter | Shift register bit that determines the value of output Q. Possible settings: S0 ... S15 Retentivity set (on) = the status is retentive in memory.
Output Q | The output value corresponds with the configured shift register bit.

Timing diagram

Description of the function

The function reads the value of input In with a positive edge (0 to 1 transition) at input Trg (Trigger).

This value is written to shift register bits S0 or S15, depending on the set shift direction:

● Shift up: S0 accepts the value of input In; the previous value of S0 is shifted to S1, S1 is shifted to S2.

● Shift down: S15 accepts the value of input In; the previous value of S15 is shifted to S14, S14 is shifted to S13.

Q outputs the value of the configured shift register bits.

If retentivity is not enabled, the shift function restarts at S0 or S15 after a power loss.

Note :

The special function shift register can be used only once in the circuit program.

■ for 5/6 Series :

The shift register function reads an input value and shifts the bits. The output value corresponds with the configured shift register bit. The shift direction can be changed at a special input.

You can use a maximum of four shift registers with 16 bits for each shift register in one circuit program.

Connection

Description

Input In

The function when started reads this input value.

Input Trg

The SFB is started with a positive edge (0 to 1 transition) at input Trg (Trigger). A 1 to 0 transition is irrelevant.

Input Dir

You define the shift direction of the shift register bits Sx.0 to Sx.15 at the Dir input:
Dir = 0: shift up (Sx.0 >> Sx.15)
Dir = 1: shift down (Sx.15 >> Sx.0)

NOTE: "x" refers to the index of the shift register.

Parameter

Shift register index: the index of shift register in the circuit program.

Possible settings: 0 to 3
Shift register bit that determines the value of output Q.

Possible settings: 0 to 15
Retentivity set (on) = the status is retentive in memory.

Output Q

The output value corresponds with the configured shift register bit.

Parameter

5/6 series devices provide four shift registers, with 16 bits for each shift register. The shift register index correponds to one of the four shift registers in the circuit program. The shift register bits are numbered in Sx.y, in which x is the index, and y is the bit number.

Timing diagram

If the shift register index is 0, the shift register bits will be S0.0 to S0.15.

Description of the function

The function reads the value of input In with a positive edge (0 to 1 transition) at input Trg (Trigger).

This value is written to shift register bits Sx.0 to Sx.15, depending on the set shift direction:

● Dir = 0 (Shift up): Sx.0 accepts the value of input In, the previous value of Sx.0 is shifted to Sx.1, Sx.1 to Sx.2 ... Sx.14 to Sx.15

● Dir = 1 (Shift down): Sx.15 accepts the value of input In; the previous value of Sx.15 is shifted to Sx.14, Sx.14 to Sx.13 ... Sx.1 to Sx.0.

Q outputs the value of the configured shift register bits.

If retentivity is not enabled, the shift function restarts at Sx.0 or Sx.15 after a power failure.


MathDetection

The Mathematical instruction error detection block sets an output if an error has occurred in the referenced Mathematical instruction function block.

Connection | Description
Input En | Enable the mathematic instruction error detection function block.
Input R | Reset the output.
Parameter | Referenced FB: block number of an mathematic instruction Error to detect: Zero division, Overflow, or Zero division OR Overflow. Auto Reset: Reset the output when the failure condition clears.
Output Q | Q is set high if the error to detect occurred in the last execution of the referenced mathematic instruction function block.

Parameter Referenced FB

The value for the Referenced FB parameter references the block number of a programmed Mathematical instruction function block.

Description of the function

The Mathematical instruction error detection block sets the output when the referenced Mathematical instruction function block has an error. You can program the function to set the output on a zero division error, an overflow error, or when either type of error occurs.

If you select the Automatically reset checkbox, the output is reset prior to the next execution of the function block.

If not, the output retains its state until the Mathematical instruction error detection block is reset with the R parameter.

In any scan cycle, if the referenced Mathematical instruction function block executes before the Mathematical instruction error detection function block, the error is detected in the same scan cycle.

If the referenced Mathematical instruction function block executes after the Mathematical instruction error detection function block, the error is detected in the next scan cycle.

Mathematical instruction error detection logic table

In the table below, Error to Detect represents the parameter of the Mathematical instruction error detection instruction that selects which type of error to detect.

Zero represents the zero division bit set by the Mathematical instruction instruction at the end of its execution: 1 if the error occurred, 0 if not.

OF represents the overflow bit set by the Mathematical instruction instruction: 1 if the error occurred, 0 if not. Zero division OR Overflow represents the logical OR of the zero division bit and the overflow bit of the referenced Mathematical instruction instruction.

Output (Q) represents the output of the Mathematical instruction error detection function. An “x” indicates that the bit can be either 0 or 1 with no influence on the output.

Error to Detect | Zero | OF | Output (Q)
Zero division | 1 | x | 1
Zero division | 0 | x | 0
Overflow | x | 1 | 1
Overflow | x | 0 | 0
Zero division OR Overflow | 1 | 0 | 1
Zero division OR Overflow | 0 | 1 | 1
Zero division OR Overflow | 1 | 1 | 1
Zero division OR Overflow | 0 | 0 | 0

If the Referenced Mathematical instruction FB is null, then the output is always 0.


Modbus Read

When the signal at En is high, the Modbus Read block will be activated. And the controller can communicate with a peripheral device as a master via RS232 or RS485 interface. Furthermore, the output will be switched on if the communication is established successfully, otherwise the output remains "off" if the communication is failed.

A signal at input R resets output Q and disables the block at the same time.

Connection | Description
Input En | A high signal at En input activates the "Modbus Read" function block.
Input R | Reset the value read from peripheral and set the output to 0 via the input R (Reset). Reset has higher priority than En.
Parameter | Cycle : transmission times: 0 ~ 9999 (cycle = 0 : continuous transmission) Slave address : 1 ~ 255, the default value is 1. Port(Master) : COM0(RS232) or COM1(RS485) or COM2(RS485) Command : Modbus function code : 01 Read Coils(0x) 02 Read Discrete Inputs(1x) 03 Read Holding Registers(4x) 04 Read Input Registers(3x) Register Address : The address of the first coil/input/register to be read data. Count : The total number of coils/inputs/registers requested. count <= 128 , if command = 01 or 02. count <= 32, if command = 03 or 04. Data Address : The starting address of the memoy to store the read data.
Output Q | Q is set or reset depending on the communication status. Q=1, if the communication is successful. Q=0, if the communication is failed.

Note : This function is available only if the Model of COM Port is set to Master.

Example : Read the status of the digital input I6 (address = 00007) of a Slave controller, which is a remote I/O module and its Slave Address is 2, and then save the status of I6 to M3 via COM1(RS485).

Setp 1 : Place a Modbus Read function block into your circuit program and set the parameters.

(1). Cycle = 0 ( successive )

(2). Slave Address = 2

(3). Port(Master) = COM1(RS485)
(4). Command = 01 Read Coils(0x)
(5). Register Address = 6 (Modbus address = 00007, start address = 0007 - 1 = 0006)
(6). Count = 1
(7). Data Address = M3

Step 2 : Make the following settings.

(1). Options à Properties à COM1 : Model = Master.

(2). Choose a protocol and communication settings.

Step 3 : When En =1, controller sends the Modbus messages via COM1 continuously.

Q=1, if communication is successful.

Q=0, if communication is failed.

Note : The numbers of Q, I, AI, AQ and AM in Data Address are continuous. In Example 3 below, the number of Q should be set as Q16 instead of Q100. The same rule is applicable to I, AI, AQ and AM. The rule is also applicable to the Modbus Write function block.

The following table illustrates how to set the parameters.

MODEL | Modbus Dialog Box | I,Q,AI,AQ Number | I,Q,AI,AQ Block
Main | I0-I31 | I000-I031 | Main : I0-31
 | Q0-Q15 | Q000-Q015 | Main : Q0-Q15
 | AI0-AI7 | AI000-AI007 | Main : AI0–AI7
 | AQ0-AQ3 | AQ000-AQ003 | Main : AQ0-AQ3
Expansion 1 (Ext1) | I32-I63 | I100-I131 | Ext1 : I0 - I31
 | Q16-Q31 | Q100-Q115 | Ext1 : Q0-Q15
 | AI8-AI15 | AI100-AI107 | Ext1 : AI0-AI7
 | AQ4-AQ7 | AQ100-AQ103 | Ext1 : AQ0-AQ3
Expansion 2 (Ext2) | I64-I95 | I200-I231 | Ext2 : I0-I31
 | Q32-Q47 | Q200-Q215 | Ext2 : Q0-Q15
 | AI16-AI23 | AI200-AI207 | Ext2 : AI0-AI7
 | AQ8-AQ11 | AQ200-AQ203 | Ext2 : AQ0-AQ3
The contents of Ext3 ~ Ext7 are the same as Ext1's and Ext2's.

Data format instructions

Name | Data format
I , Q , M | Bit
AI , AQ , AM | Signed Short Integer (16 bits)


Modbus Write

When the signal at En is high, the Modbus Write block will be activated and the controller can communicate with a peripheral device as a master via RS232 or RS485 interface. Furthermore, the output will be switched on if the communication is established successfully, otherwise the output remains "off" if the communication is failed.

A signal at input R resets output Q and disables the block at the same time.

Connection

Description

Input En

A high signal at En input activates the "Modbus Write" function block.

Input R

Reset the output.
Reset has higher priority than En.

Parameter

Cycle : transmission times: 1 ~ 9999 , cycle = 0 --> continuous transmission

Slave address : 1 ~ 255, the default value is 1.
Port(Master) : COM0(RS232) or COM1(RS485) or COM2(RS485)
Command : Modbus function code :
05 Write Single Coil
06 Write Single Register
15 Write Multiple Coils
16 Write Multiple Registers
Register Address : The address of the first coil/register to store the write data.
Count : The total number of coils/registers written.
count = 1 , if command = 05 or 06.
count <= 32 , if command = 15.
count <= 2, if command = 16.
Writing Mode : The mode can be either of the following options:
Auto --> Data Address : The starting address of the memoy to be write data.

The data is then written to Register Address.
Manual : The assigned value is written to Register Address.

Output Q

Q is set or reset depending on the communication status.
Q=1, if the communication is successful.
Q=0, if the communication is failed.

Note : This function is available only if the Model of COM Port is set to Master.

Example : Write the status of the digital input I6 (address = 00007) of a Master controller to the digital output Q2 (address = 00018) of a Slave controller via COM1(RS485). The Slave module is a remote I/O module and its Slave Address is 1.

Setp 1 : Place a Modbus Write function block into your circuit program and set the parameters.

(1). Cycle = 1

(2). Slave Address = 1
(3). Port(Master) = COM1(RS485)
(4). Command = 05 Write Single Coil
(5). Register Address = 0017 (Modbus address = 00018, start address = 0018 - 1 = 0017)
(6). Count = 1
(7). Data Address = I6

Step 2 : Make the following settings.

(1). Options à Properties à COM1 : Model = Master.
(2). Choose a protocol and communication settings.

Step 3 : When En =1, controller sends the Modbus messages via COM1 continuously.

Q=1, if communication is successful.

Q=0, if communication is failed.

Note : The numbers of Q, I, AI, AQ and AM in Data Address are continuous. In Example 3 below, the number of Q should be set as Q16 instead of Q100. The same rule is applicable to I, AI, AQ and AM. The rule is also applicable to the Modbus Read function block.

The following table illustrates how to set the parameters.

MODEL | Modbus Dialog Box | I,Q,AI,AQ Number | I,Q,AI,AQ Block
Main | I0-I31 | I000-I031 | Main : I0-31
 | Q0-Q15 | Q000-Q015 | Main : Q0-Q15
 | AI0-AI7 | AI000-AI007 | Main : AI0–AI7
 | AQ0-AQ3 | AQ000-AQ003 | Main : AQ0-AQ3
Expansion 1 (Ext1) | I32-I63 | I100-I131 | Ext1 : I0 - I31
 | Q16-Q31 | Q100-Q115 | Ext1 : Q0-Q15
 | AI8-AI15 | AI100-AI107 | Ext1 : AI0-AI7
 | AQ4-AQ7 | AQ100-AQ103 | Ext1 : AQ0-AQ3
Expansion 2 (Ext2) | I64-I95 | I200-I231 | Ext2 : I0-I31
 | Q32-Q47 | Q200-Q215 | Ext2 : Q0-Q15
 | AI16-AI23 | AI200-AI207 | Ext2 : AI0-AI7
 | AQ8-AQ11 | AQ200-AQ203 | Ext2 : AQ0-AQ3
The contents of Ext3 ~ Ext7 are the same as Ext1's and Ext2's.

Data format instructions

Name | Data format
I , Q , M | Bit
AI , AQ , AM | Signed Short Integer (16 bits)


WiFi Digital Read

When the signal at En is high, the WiFi Digital Read block will be activated. And the controller can communicate with a peripheral device over the WiFi protocol.

Connection | Description
Input En | A high signal at En input will enable “WIFI Digital Read” function block to be activated
Parameter | Read value from : Wifi Digital Read blocks can read values from the following types : Station ,VM and Diagnostic Wifi ID : Read digital IO from Statoin WiFi ID (station 1 ~ 7 ) Read VM value from Groups WiFi ID ( Server:0 Group1~ 7 ) Block Type : I , Q Block Number : I : 0 ~ 31 / Q : 0 ~ 15 / VM : 0 ~ 31
Output Q | Output the value.

Wifi Digital Read blocks can read values from the following types:

● Station

● VM

● Diagnostic

If read a value from a module (Station mode), must text the WiFi ID number. The block type is the input or output of the Station module. Wifi Digital Read blocks can read values from I0 to I31 or Q0 to Q15 of a Station module.

If read a value from a module (Groups mode), must text the WiFi ID number. Wifi Digital Read blocks can read values from VM0 to VM31 of a Group module.

The Diagnostic option is use for check the WiFi communication with other WiFi device. If the Diagnostic status is 0, it means the communication failed. If the Diagnostic status is 1, it means the communication successful.

(Note, 1 unit Server module can communicate with arbitrary 7 units Gorups + Station module at sync)


WiFi Digital Write

When the signal at En is high, the WiFi Digital Write block will be activated and the controller can communicate with a peripheral device over the WiFi protocol.

Connection | Description
Input En | A high signal at En input will enable “WiFi Digital Write” function block to be activated
Input In | The input value to write to Q of Station module or VM of Groups module .
Parameter | Write value to : WiFi Digital Write blocks can write values to the following types : Station and VM. Wifi ID : Write digital output to Statoin WiFi ID ( 1 ~ 7 ). Write digital value to VM of its own wifi ID. Block Type : Q Block Number : Q : 0 ~ 15 / VM : 0 ~ 31

When the module is in Station mode, can assign a WiFi output on the server module to control a digital output on the Station module. Then text the Station WiFi ID number into the communicate item. The WiFi outputs number from Q0 to Q15.

When the module is in Groups mode, can assign a VM value of its own WiFi ID number. Server module and other Groups module can read the VM value over “WiFi Digital Read” function block.

(Note, 1 unit Server module can communicate with arbitrary 7 units Gorups + Station module at sync)


WiFi Analog Read

When the signal at En is high, the WiFi Analog Read block will be activated. And the controller can communicate with a peripheral device over the WiFi protocol.

Connection | Description
Input En | A high signal at En input will enable “WIFI Analog Read” function block to be activated
Parameter | Read value from : WiFi Analog Read blocks can read values from the following types : Station and VAM Wifi ID : Read Analog IO from Statoin WiFi ID ( 1 ~ 7 ) Read VM value from Groups WiFi ID ( Server:0 Group1~ 7 ) Block Type : AI , AQ Block Number : A I : 0 ~ 7 / AQ : 0 ~ 3 / VAM : 0 ~ 31
Output AQ | Output the analog value.

WiFi Analog Read blocks can read values from the following types:

● Station

● VAM

If read a value from a module (Station mode), must text the WiFi ID number. The block type is the analog input or analog output of the Station module. WiFi Analog Read blocks can read values from AI0 to AI7 or AQ0 to AQ3 of a Station module.

If read a value from a module (Groups mode), must text the WiFi ID number. Wifi Analog Read blocks can read values from VAM0 to VAM31 of a Group module.

(Note, 1 unit Server module can communicate with arbitrary 7 units Gorups + Station module at sync)


WiFi Analog Write

When the signal at En is high, the WiFi Analog Write block will be activated and the controller can communicate with a peripheral device over the WiFi protocol.

Connection | Description
Input En | A high signal at En input will enable “WiFi Analog Write” function block to be activated
Input In | The 16-bit input value to write to AQ of Station module or VAM of Group module .
Parameter | Write value to : WiFi Analog Write blocks can write values to the following types : Station and VAM. Wifi ID : Write analog output to Statoin WiFi ID ( 1 ~ 7 ). Write analog value to VAM of its own WiFi ID. Block Type : AQ Block Number : A Q : 0 ~ 3 / VAM : 0 ~ 31

When the module is in Station mode, can assign a WiFi analog output on the Server module to control an analog output to the Station module.

Must text the Station WiFi ID number into the communicate item. The WiFi outputs number from AQ0 to AQ3.

When the module is in Groups mode, can assign a VAM value of its own wifi ID. Server module and other Groups module can read the VAM value over “WiFi Analog Read” function block.

(Note, 1 unit Server module can communicate with arbitrary 7 units Gorups + Station module at sync)


Boolean function

The BOOLEAN function gives the value of the output according to the combination of inputs.

The function has four inputs, and therefore 16 combinations. These combinations can be found in a truth table; for each of these, the output value can be adjusted. The number of configurable combinations depends on the number of inputs connected to the function.

Non-connected inputs are set to 0.

The following diagram shows an example of part of the Boolean function truth table:

Parameters

Having connected at least one input, you can configure the value of the output in the truth table, in the Parameters window.

The output values can be 0 for the Inactive state, and 1 for the Active state.

By selecting the Output ON if result is TRUE option, the output takes the value configured in the truth table.

By selecting the Output OFF if result is TRUE option, the output takes the inverse value of the value configured in the truth table.


TDT

Record the current time (year / month / day / hour / minute / second) to a specific memory.

Connection | Description
Input Trg | When Trg is low to high , write date and time to memory ( YYMMDDHHMMSS )
Input R | Reset output and memory data
Parameter | Retentivity set (on) = the status is retentive in memory.
Output Q | When writing success，Output Q = 1.

Calculation rule

When Input Trg = low to high, the accurate date will be recorded in the memory of functional block. The following table:

Modbus Address

Description

R/W

Note

42001 | Output Status _ B0 | R | B0
42002 | YYMM (Year/Month) _ B0 | R | B0
42003 | DDHH (Day/Time) _ B0 | R | B0
42004 | MMSS (Minute/Second) _ B0 | R | B0
42005 | Output Status _ B1 | R | B1
42006 | YYMM (Year/Month) _ B1 | R | B1
42007 | DDHH (Day/Time) _ B1 | R | B1
42008 | MMSS (Minute/Second) _ B1 | R | B1
.......................................................


BCD

Binary to BCD conversion

Connection | Description
Input IN | Integer value Value range : 0 ~ 9999
Output AQ | Integer value

Calculation rule

If Input IN = 1234 , then Output AQ = 0x1234

If Input IN = 9999 , then Output AQ = 0x9999


BIN

BCD to Binary conversion.

Connection | Description
Input IN | Integer value Value range : 0x0000 ~ 0x9999 and each of digit must not exceed 9
Output AQ | Integer value ( Q=0 for invalid value )

Calculation rule

If Input IN = 0x1234 , then Output AQ = 1234

If Input IN = 0x9999 , then Output AQ = 9999

If Input IN = 0x12A4 , then Output AQ = 0 ( Q=0 for invalid value )


ROL

Make the bits of an integer rotate to the left. Rotation is made on 16 bits.

Connection | Description
Input IN | Any integer value
Parameter | NbR : Number of 1 bit rotations (in set [1..15])
Output AQ | Left rotated value ( no effect if NbR <= 0 )

Parameters NbR

The NbR can be provided by the actual value of another programmed function.

Calculation rule

IN = 21385 ( Binary: 0101 0011 1000 1001 ) , NbS = 2

---> Output AQ = 20005 ( Binary: 0100 1110 0010 0101 )


ROR

Make the bits of an integer rotate to the right. Rotation is made on 16 bits.

Connection | Description
Input IN | Any integer value
Parameter | NbR : Number of 1 bit rotations (in set [1..15])
Output AQ | Right rotated value ( no effect if NbR <= 0 )

Parameters NbR

The NbR can be provided by the actual value of another programmed function.

Calculation rule

IN= 5001 ( Binary: 0001 0011 1000 1001 ) , NbS = 2

---> Output AQ = 17634 ( Binary: 0100 0100 1110 0010 )


SHL

Shifts the 16 bits of an integer to the left and places a 0 in the least significant bit.

Connection | Description
Input IN | Any integer value
Parameter | NbS : Number of 1 bit shifts (in set [1..15])
Output AQ | Left shifted value ( no effect if NbS <= 0 ) 0 replaces the least significant bit

Parameters NbS

The NbS can be provided by the actual value of another programmed function.

Calculation rule

IN= 5001 ( Binary: 0001 0011 1000 1001 ) , NbS = 1

---> Output AQ = 10002 ( Binary: 0010 0111 0001 0010 )


SHR

Shifts the 16 bits of an integer to the right and places a 0 in the most significant bit.

Connection | Description
Input IN | Any integer value
Parameter | NbS : Number of 1 bit shifts (in set [1..15])
Output AQ | Right shifted value ( no effect if NbS <= 0 ) 0 replaces the most significant bit

Parameters NbS

The NbS can be provided by the actual value of another programmed function.

Calculation rule

IN= 5001 ( Binary: 0001 0011 1000 1001 ) , NbS = 1

---> Output AQ = 2500 ( Binary: 0000 1001 1100 0100 )


AND_MASK

Bit-to-bit logical AND between Input IN and MSK

Connection | Description
Input IN | Any integer value
Parameter | MSK : 16-bit value
Output AQ | Bit-to-bit logical AND between Input IN and MSK

Parameters MSK

The MSK can be provided by the actual value of another programmed function.


OR_MASK

Bit-to-bit logical OR between Input IN and MSK

Connection | Description
Input IN | Any integer value
Parameter | MSK : 16-bit value
Output AQ | Bit-to-bit logical OR between Input IN and MSK

Parameters MSK

The MSK can be provided by the actual value of another programmed function.


NOT_MASK

Bit-to-bit logical NOT of Input IN

Connection | Description
Input IN | Any integer value
Output AQ | Bit-to-bit logical NOT of Input IN.


NAND_MASK

Bit-to-bit logical NAND between Input IN and MSK

Connection | Description
Input IN | Any integer value
Parameter | MSK : 16-bit value
Output AQ | Bit-to-bit logical NAND between Input IN and MSK

Parameters MSK

The MSK can be provided by the actual value of another programmed function.


NOR_MASK

Bit-to-bit logical NOR between Input IN and MSK

Connection | Description
Input IN | Any integer value
Parameter | MSK : 16-bit value
Output AQ | Bit-to-bit logical NOR between Input IN and MSK

Parameters MSK

The MSK can be provided by the actual value of another programmed function.


XOR_MASK

Bit-to-bit logical XOR between Input IN and MSK

Connection | Description
Input IN | Any integer value
Parameter | MSK : 16-bit value
Output AQ | Bit-to-bit logical XOR between Input IN and MSK

Parameters MSK

The MSK can be provided by the actual value of another programmed function.


ARRMX_MI_AV

Get the maximum / minimum / average of array.

Connection | Description
Parameter | Mode : MAX / MIN / AVG Data address : AMx / AIx / AQx Array starting address Count : the value of array [ 1~32 ]
Output AQ | The maximum / minimum / average of output array.

Parameters Mode and Number

The mode and the number can be provided by the actual value of another programmed function.

Calculation rule

Mode=MAX, Data address=AM2 , Count =3 , ( AM2=2 , AM3=6, AM4=13 ) : Output AQ = 13

Mode=MIN, Data address=AM2 , Count =3 , ( AM2=2, AM3=6, AM4=13 ) : Output AQ = 2

Mode=AVG, Data address=AM2 , Count =3 , ( M2=2, AM3=6, AM4=13 ) : Output AQ = (2+6+13) / 3 = 7

Mode=MAX, Data address=AQ3 , Count =2 , ( AQ3=2 , AQ4=6 ) : Output AQ = 6

The following table illustrates how to set the parameters.

MODEL | ARR Dialog Box | AI,AQ Number | AI,AQ Block
Main | AI0-AI7 | AI000-AI007 | Main : AI0–AI7
 | AQ0-AQ3 | AQ000-AQ003 | Main : AQ0-AQ3
Expansion 1 (Ext1) | AI8-AI15 | AI100-AI107 | Ext1 : AI0-AI7
 | AQ4-AQ7 | AQ100-AQ103 | Ext1 : AQ0-AQ3
Expansion 2 (Ext2) | AI16-AI23 | AI200-AI207 | Ext2 : AI0-AI7
 | AQ8-AQ11 | AQ200-AQ203 | Ext2 : AQ0-AQ3
The contents of Ext3 ~ Ext7 are the same as Ext1's and Ext2's.


ACMX_MI_AV

Get the maximum / minimum / average of IN1, IN2.

Connection | Description
Input IN1 | Any 16-bit input value.
Input IN2 | Any 16-bit input value.
Parameter | Mode : MAX / MIN / AVG.
Output AQ | Output maximum / minimum / average of IN1, IN2.

Parameters Mode

The mode can be provided by the actual value of another programmed function.

Calculation rule

IN1= 2 , IN2= 8 , Mode = MAX : Output AQ = 8

IN1= 2 , IN2= 8 , Mode = MIN : Output AQ = 2

IN1= 2 , IN2= 8 , Mode = AVG : Output Q = ( 2 + 8 ) / 2 = 5


RAND

Gives a random integer value in a given range.

Connection | Description
Parameter | Base : Defines the allowed set of number
Output AQ | Random value in set [0..base-1]

Parameters Base

The base can be provided by the actual value of another programmed function.

Calculation rule

Base = 10 : Output AQ = 0 to 9

Base = 15 : Output AQ = 0 to 14


MEM

Get the parameter of another,already configured function.

Connection | Description
Input R | Reset output to 0
Parameter | Par: Parameter of another, already configured function.
Output AQ | Output the parameter value Value range : -32768 ~ 32767

Calculation rule

If input reset = 0, then output AQ will directly output the current parameter.

( range : -32768 ~ 32767 )

If input reset = 1, then output AQ = 0.


ENCODER

Get the encoder value from I0/I1 or I2/I3.

Connection | Description
Input R | Reset output
Parameter | Start Value :Initial value from which to begin counting. Value range: -999999 ~ 999999 Encoder Source : 0 --> I0/I1 , 1 --> I2/I3 On: On threshold Value range: -999999 ~ 999999 Off: Off threshold Value range: -999999 ~ 999999 Retentivity set (on) = the status is retentive in memory.
Output Q | Q is set and reset according to the actual value at Cnt and the set thresholds.

Parameters On and Off

The on and off thresholds can be provided by the actual value of another programmed function.

Calculation rule

● If the on threshold >= off threshold, then:
Q = 1, if Cnt >= On
Q = 0, if Cnt < Off.

● If the on threshold < off threshold, then:
Q = 1, if On <= Cnt < Off.

Q = 0, if Cnt >= Off or Cnt < On


Stepping Motor Control

Generate pulse signal to drive stepping motor.

Connection | Description
Input En | 0: Stop to generate pulse signal. 1: Start to generate pulse signal.
Input Dir | 0 : CW (clock_wise) 1 : CCW (count clock-wise)
Parameter | Mode : Half step (1-2 phase excite megatic, each step 0.9 degree) Full step (1-2 phase excite megatic, each step 1.8 degree) Pin : Q0~Q3 Q4~Q7 Speed : 0.005 ms/step (Half step mode) 0.01 ms/step (Full step mode) Value range : 0 ~ 99999999
Output Q | Q is set and reset according to the Input En.

Parameters Period T

The Speed can be provided by the actual value of another programmed function.

Example

Set stepping motor 1000ms per circle(360 dgree).

● Mode = Half step

A circle = 360 degree = 0.9(degree/step) x 400(step)

--> 1000 ms needs to send 400 steps (pulses)

--> A step need 1000/400 = 2.5 ms

--> Speed = 2.5 / 0.005 = 500

● Mode = Full step

A circle = 360 degree = 1.8(degree/step) x 200(step)

--> 1000 ms needs to send 200 steps (pulses)

--> A step need 1000/200 = 5 ms

--> Period T = 5 / 0.01 = 500

Connection

* 0.9 or 1.8 degree two phases of six wired stepping motor.

* 0.9 or 1.8 degree two phases of four wired stepping motor.


Stepping Motor Control (Edge)

Generate specific number of pulse signal to drive stepping motor.

Connection | Description
Input Trg | When trg=0 to 1 , start to generate specific number pulse signal.
Input R | Reset ouput and stop to generate pulse signal.
Input Dir | 0 : CW (clock_wise) 1 : CCW (count clock-wise)
Parameter | Mode : Half step (1-2 phase excite megatic, each step 0.9 degree) Full step (1-2 phase excite megatic, each step 1.8 degree) Out : 0 --> Q0~Q3 1--> Q4~Q7 Speed : 0.005 ms/step (Half step mode) 0.01 ms/step (Full step mode) Value range : 0 ~ 99999999 Steps : Output the number of Steps. Value range : 0 ~ 99999999
Output Q | When output pulse signal, Output Q=1

Parameters T and Steps

The Speed and the Steps can be provided by the actual value of another programmed function.

Example

Set stepping motor 1000ms per circle (360 degree) and stop after 50 circles。

● Mode = Half step

A circle = 360 degree = 0.9(degree/step) x 400(step)

--> 1000 ms needs to send 400 steps (pulses)

--> A step need 1000/400 = 2.5 ms

--> Speed = 2.5 / 0.005 = 500 ( 0.005ms/step)

Steps = 50 (circles) x 400 (Steps/circle) = 2000 Steps

● Mode = Full step

A circle = 360 degree = 1.8(degree/step) x 200(step)

--> 1000 ms needs to send 200 steps (pulses)

--> A step need 1000/200 = 5 ms

--> Speed = 5 / 0.01 = 500 ( 0.01ms/step)

Steps = 50 (circles) x 200 (Steps/circle) = 1000 Steps

Connection

* 0.9 or 1.8 degree two phases of six wired stepping motor.

* 0.9 or 1.8 degree two phases of four wired stepping motor.


PTO (Pulse train output)

Pulse(duty=50%) continuous output.

Connection | Description
Input En | When En=1 , start to generate pulse continuous ouptput.
Parameter | Pin : Pulse output pin Q0 ~ Q3. Value range : 0 ~ 3 Pulse width : 0 ~ 10000000 ( 0.01ms / pulse ). Value range : 0 ~ 99999999 ● pulse width = 1 → 1 x 0.01 ms/pulse → 0.00001 sec/pulse → 100K Hz ● pulse width = 10000000 → 10000000 x 0.01ms/pulse = 100000 ms/pulse → 100 sec/pulse → 0.01 Hz
Output Q | During the output pulse, Output = 1

Timing diagram


PTOE (Pulse train output)

Output specific number of pulse(duty=50%).

Connection | Description
Input Trg | When trg = 0 to 1 , start to output the specific number of pulse.
Input R | Reset output and count value.
Parameter | Pin : Pulse output pin Q0 ~ Q3 , value range : 0 ~ 3 Pulse width : 0 ~ 99999999 ( 0.01ms / pulse ). Value range : 0 ~ 99999999 ● pulse width = 1 → 1 x 0.01 ms/pulse → 0.00001 sec/pulse → 100K Hz ● pulse width = 10000000 → 10000000 x 0.01ms/pulse = 100000 ms/pulse → 100 sec/pulse → 0.01 Hz Count : The setting value of pulse number. Value range : 0 ~ 99999999
Output Q | During the output pulse, Output = 1

Timing diagram


SEG

Turn hexadecimal values into seven-segment display encoding output.

Connection | Description
Input Trg | When Trg=1 , start to turn hexadecimal value into seven-segment display encoding output.
Input Ax | Hexadecimal value. value range : 0(Hex) ~ F(Hex)
Output AQ | Encoding output of seven-segment display.

Ax | - g f e d c b a | Output AQ
0 | 0 0 1 1 1 1 1 1 | 0x3F
1 | 0 0 0 0 0 1 1 0 | 0x06
2 | 0 1 0 1 1 0 1 1 | 0x5B
3 | 0 1 0 0 1 1 1 1 | 0x4F
4 | 0 1 1 0 0 1 1 0 | 0x66
5 | 0 1 1 0 1 1 0 1 | 0x6D
6 | 0 1 1 1 1 1 0 1 | 0x7D
7 | 0 0 0 0 0 1 1 1 | 0x07
8 | 0 1 1 1 1 1 1 1 | 0x7F
9 | 0 1 1 0 0 1 1 1 | 0x67
A | 0 1 1 1 0 1 1 1 | 0x77
B | 0 1 1 1 1 1 0 0 | 0x7C
C | 0 0 1 1 1 0 0 1 | 0x39
D | 0 1 0 1 1 1 1 0 | 0x5E
E | 0 1 1 1 1 0 0 1 | 0x79
F | 0 1 1 1 0 0 0 1 | 0x71


Word to Bit

Obtained the value of a particular bit in 16-bit data.

Connection | Description
Input Ax | 16-bit value.
Parameter | Nb : To take the first few bit output. Value range : 0 ~ 15
Output Q | Ouput the value of bit.

Input Ax | Binary | Nb | Output
0x1234 | 0001 0010 0011 0100 | 0 | 0
 |  | 1 | 0
 |  | 2 | 1
 |  | 3 | 0
 |  | 4 | 1
 |  | 5 | 1
 |  | 6 | 0
 |  | 7 | 0
 |  | 8 | 0
 |  | 9 | 1
 |  | 10 | 0
 |  | 11 | 0
 |  | 12 | 1
 |  | 13 | 0
 |  | 14 | 0
 |  | 15 | 0


UDC

Transmission of custom format data through communication port. When the transmission of prefix or end characters is selected, the transferred data will add a prefix or end characters. When receiving prefix or receiving end characters is selected, the received data will first check the prefix or end characters.If the information correct, the data will be filled in the receiving address.

Connection | Description
Input En | 0 --> disable , 1-->enable.
Parameter | Com port : 0 ~ 2 (com0 ~ com2) Tx_Pre_Char : transmit prefix character Tx_End_Char : transmit end character Tx_Start : AI0~AI63 / AM0~AM511 / AQ0 ~ AQ31 Tx_Num : transmit words. Value range: 1~127 (not include prefix and end character) Rx_Pre_Char : receive prefix character Rx_End_Char : receive end character Rx_Start : AM0~AM511 Rx_Num : receive words. Value range: 1~127 (not include prefix and end character) Cycle : transmission times. Value range : 0 ~ 9999 ( cycle = 0 : continuous transmission )
Output Q | When transmission success，output = 1

Example :

Tx_Pre_Char = 0x03, Tx_End_Char = 0x0A , Tx_Start = AM0, Tx_Num = 3,

Rx_Pre_Char = 0x03, Rx_End_Char = 0x0A, Rx_Start = AM16, Rx_Num = 4,

AM0=0x2211, AM1=4433, AM2=0x6655, Cycle = 1, Com port = 0.

● Tx :

1. When Tx_Pre_Char and Tx_End_Char are unchecked, Input En = 1 --> the data frame

below will be transmitted(once) in order from rs-232 port (com0)Data frame :

Tx : 11 22 33 44 55 66 (Hex)

2. When Tx_Pre_Char and Tx_End_Char are checked, Input En = 1 --> the data frame

below will be transmitted (once) in order from rs-232 port (com0).

Tx : 03 11 22 33 44 55 66 0A (Hex)

● Rx :

1. When Rx_Pre_Char and Rx_End_Char are unchecked, the data 4 words( 8 bytes)

receive via rs-232(com0) will be sequentially add into AM16 ~ AM19. Assuming

receive the data 4 words ( 8 bytes) is :

Rx : 99 88 77 66 55 44 33 22 (Hex)

AM16 = 0x8899 , AM17 = 0x6677 , AM18 = 0x4455 , AM19 = 0x2233

2. When Rx_Pre_Char and Rx_End_Char are checked, the prefix and end characters

receive via rs-232(com0) will be checked first. If they are correct, the prefix and end

characters will be eliminated then add value into AM16~AM19. Assuming receive the

data is :

Rx : 03 99 88 77 66 55 44 33 22 0A (Hex)

AM16 = 0x8899 , AM17 = 0x6677 , AM18 = 0x4455 , AM19 = 0x2233

The following table illustrates how to set the parameters.

MODEL | UDC Dialog Box | AI,AQ Number | AI,AQ Block
Main | AI0-AI7 | AI000-AI007 | Main : AI0–AI7
 | AQ0-AQ3 | AQ000-AQ003 | Main : AQ0-AQ3
Expansion 1 (Ext1) | AI8-AI15 | AI100-AI107 | Ext1 : AI0-AI7
 | AQ4-AQ7 | AQ100-AQ103 | Ext1 : AQ0-AQ3
Expansion 2 (Ext2) | AI16-AI23 | AI200-AI207 | Ext2 : AI0-AI7
 | AQ8-AQ11 | AQ200-AQ203 | Ext2 : AQ0-AQ3
The contents of Ext3 ~ Ext7 are the same as Ext1's and Ext2's.


CRC16

Calculate the value of CRC16.

Connection | Description
Input En | When En=1 , start to calculate the value of CRC16.
Parameter | Type : CRC16 Addrss_start : startup address : AM0 ~ AM511 Number : number (words). Value range : 1~128
Output AQ | Directly output the value of CRC16

Example :

Start Address = AM0 , number = 5

When Input En = 1 ，Output AQ will output the value of CRC16 of AM0 ~ AM4.


ODD

Tests the parity of an integer: result is odd or even.

Connection | Description
Input IN | Any signed integer value
Output Q | TRUE if input value is odd FALSE if input value is even

Calculation rule

IN= 2 : Output Q = 0 ( EVEN )

IN= 3 : Output Q = 1 ( ODD )


EVEN

Tests the parity of an integer: result is even or odd

Connection | Description
Input IN | Any signed integer value
Output Q | TRUE if input value is even FALSE if input value is odd

Calculation rule

IN= 2 ---> Output Q = 1 ( EVEN )

IN= 3 ---> Output Q = 0 ( ODD )


MOD

Calculates the modulo of an integer value.

Connection | Description
Input IN | Any signed integer value
Parameter | Base : divisor
Output AQ | Modulo calculation (input MOD base) returns 0 if Base = 0

Parameters Base

The base can be provided by the actual value of another programmed function.

Calculation rule

1. If Input IN and Base are the sames sign, then the value of Output AQ and Input IN or Base are the same sign.

IN = 42 , Base = 5 --> 42 = 5 × 8 + 2 --> Output AQ = 2

IN = - 42 , Base = - 5 --> - 42 = -5 × (-8) + (-2) --> Output AQ = - 2

2. If Input IN and Base have different sign, then the sign(positive or negative) of OutputAQ is

depends on Base.

IN = 42 , Base = - 5 --> 42 = -5 × (-9) + (-3) --> Output AQ = -3

IN = - 42 , Base = 5 --> - 42 = 5 ×(-9) + 3 --> Output AQ = 3


REM

Calculates the remainder of an integer value.

Connection | Description
Input IN | Any signed integer value
Parameter | Base : divisor
Output AQ | Remainder calculation returns 0 if Base = 0

Parameters Base

The base can be provided by the actual value of another programmed function.

Calculation rule

1. Input IN and Base are the same sign --> The value of Output AQ and Input IN or Base are the same sign.

IN = 42 , Base = 5 --> 42 = 5 × 8 + 2 --> Output AQ = 2

IN = - 42 , Base = - 5 --> - 42 = -5 × (-8) + (-2) --> Output AQ = - 2

2. Input IN and Base have different sign --> The sign(positive or negative) of Output AQ is

depend on Input IN

IN = 42 , Base = - 5 --> 42 = -5 × (-8) + 2 --> Output AQ = 2

IN = - 42 , Base = 5 --> - 42 = 5 × (-8) + (-2) --> Output AQ = - 2


LOG

Calculates the logarithm of a real value.

Connection | Description
Input IN | Must be greater than zero
Parameter | Base: e / 2 / 10 Amp : magnification ( -10000.00 ~ 10000.00 )
Output AQ | Logarithm of the input value multiply the value of Amp.

Parameters Base

The base can be provided by the actual value of another programmed function. Please refer to reference section.

Calculation rule

Output Q = logbase(IN ) × Amp

Base = 0 , IN = 10 , Amp = 10 : Output AQ = loge(10) × 10 = 2.30 × 10 = 23

Base = 1 , IN = 10 , Amp = 10 : Output AQ = log2(10) × 10 = 3.3 × 10 = 33

Base = 2 , IN = 10 , Amp = 10 : Output AQ = log10(10) × 10 = 1.0 × 10 = 10


SQRT

Calculates the square root of a real value.

Connection | Description
Input IN | Must be greater than or equal to zero
Parameter | Amp : magnification ( -10000.00 ~ 10000.00 )
Output AQ | Square root of the input value multiply the value of Amp. ( if input IN<0, then Output AQ= -1 )

Calculation rule

Output Q = Sqr(IN) × Amp

IN = 9 , Amp = 1.0 : Output AQ = Sqrt(9) × 1.0 = 3

IN = 4 , Amp = 1.0 : Output AQ = Sqrt(4) × 1.0 = 2


ABS

Gives the absolute (positive) value of a real value

Connection | Description
Input IN | Any signed real value
Output AQ | Absolute value (always positive)

Calculation rule

Output Q = ABS(IN)

IN = 3 : AQ = ABS(3) = 3

IN = -3 : AQ = ABS(-3) = 3


GCD

Get Input IN1, IN2 greatest common divisor ( GCD )

Connection | Description
Input IN1 | Any 16-bit input value ( IN1 > 0 )
Input IN2 | Any 16-bit input value ( IN2 > 0 )
Output AQ | The GCD of IN1 and IN2 . ( AQ = 0 if Input IN1<=0 or IN2 <= 0 )

Calculation rule

Output AQ = GCD(IN1 , IN2)

IN1 = 8 , IN2= 12 : AQ = GCD(8,12) = 4

IN1 = 3 , IN2= 5 : AQ = GCD(3,5) = 1

IN1 = -8 , IN2= 12 : AQ = GCD(-8,12) = 0 ( Q=0 if IN1 <=0 or IN2<=0 )


LCM

Get Input IN1 , IN2 lowest common multiple ( LCM )

Connection | Description
Input IN1 | Any 16-bit input value ( IN1 > 0 )
Input IN2 | Any 16-bit input value ( IN2 > 0 )
Output AQ | The LCM of IN1 and IN2. ( AQ = 0 if Input IN1<=0 or IN2<= 0 )

Calculation rule

Output AQ = LCM(IN1 , IN2)

IN1 = 3 , IN2 = 5 : AQ = LCM(3,5) = 15

IN1 = 6 , IN2 = 9 : AQ = LCM(6,9) = 18

IN1 = -3 , IN2 = 5 : AQ = LCM(-3,5) = 0 ( AQ=0 if IN1<=0 or IN2<=0 )


POW2

This function computes 2 to the power of IN, 2^IN

Connection | Description
Input IN | Any 16-bit input value
Parameter | Amp : Magnification value range : -10000.00 ~ 10000.00
Output AQ | Output 2 to the power of IN then multiply the value of Amp

Calculation rule

Output AQ = 2 IN × Amp

IN = 3 , Amp = 1.0 : Output AQ = 23 × 1.0 = 8


EXP

Calculates the natural exponent value.

Connection | Description
Input IN | Any 16-bit input value
Parameter | Amp : Magnification Value range : -10000.00 ~ 10000.00
Output AQ | Output e to the power of Input IN then multiply the value of Amp

Calculation rule

Output AQ = e IN × Amp

IN = 3 , Amp = 1.0 : Output AQ = e3 × 1.0 = 20.085 = 20


FIX

Calculate the value of Input IN after round down.

Connection | Description
Input IN | Any 16-bit input value
Parameter | Base : Rounding down of numbers that begin from the first
Output AQ | The output value after round down( AQ=0 if Base exceed the digit of IN )

Parameters Base

The base can be provided by the actual value of another programmed function.

Calculation rule

( 1 ) IN >= 0 :

IN = 25836 , Base = 1 : Output AQ = 25830

IN = 25836 , Base = 2 : Output AQ = 25800

IN = 25836 , Base = 3 : Output AQ = 25000

( 2 ) IN < 0 :

IN = -25836 , Base = 1 : Output AQ = -25830

IN = -25836 , Base = 2 : Output AQ = -25800

IN = -25836 , Base = 3 : Output AQ = -25000


ROUND

Calculate the value of Input IN after round off。

Connection | Description
Input IN | Any 16-bit input value
Parameter | Base : Rounding off of numbers that begin from the first
Output AQ | Output value after round off( AQ=0 if Base exceed the digit of IN )

Parameters Base

The base can be provided by the actual value of another programmed function.

Calculation rule

( 1 ) IN >= 0 :

IN = 25836 , Base = 1 : Output AQ = 25840

IN = 25836 , Base = 2 : Output AQ = 25800

IN = 25836 , Base = 3 : Output AQ = 26000

( 2 ) IN < 0 :

IN = -25836 , Base = 1 : Output AQ = -25840

IN = -25836 , Base = 2 : Output AQ = -25800

IN = -25836 , Base = 3 : Output AQ = -26000


SIN

Calculating sine of radians IN.

Connection | Description
Input IN | Any 16-bit input value ( degree )
Parameter | Amp : Magnification Value range : -10000.00 ~ 10000.00
Output AQ | Sine of the input value (in set [ -1.0 .. +1.0 ] ) multiply the value of Amp

Calculation rule

RADIAN = Degree × ( pi / 180)

Output AQ = Sin ( Input IN × ( pi / 180)) × Amp


COS

Calculating cosine of radians IN

Connection | Description
Input IN | Any 16-bit input value ( degree )
Parameter | Amp : Magnification Value range : -10000.00 ~ 10000.00
Output AQ | Cosine of the input value (in set [ -1.0 .. +1.0 ] ) multiply the value of Amp

Calculation rule

RADIAN = Degree × ( pi / 180)

Output AQ = Cos ( Input IN × ( pi / 180)) × Amp


TAN

Calculating tangent of radians IN.

Connection | Description
Input IN | Cannot be equal to PI/2 modulo PI. ( degree )
Parameter | Amp : Magnification Value range : -10000.00 ~ 10000.00
Output AQ | Tangent of the input value multiply the value of Amp ( Output AQ = 32767 for invalid input )

Calculation rule

RADIAN = Degree × ( pi / 180)

Output AQ = Tan ( Input IN × ( pi / 180)) × Amp


COT

Calculating cotangent of radians IN.

Connection | Description
Input IN | Cannot be equal to 0 modulo PI. ( degree )
Parameter | Amp : Magnification Value range : -10000.00 ~ 10000.00
Output AQ | Cotangent of the input value multiply the value of Amp ( Output AQ = 32767 for invalid input )

Calculation rule

RADIAN = Degree × ( pi / 180)

Output AQ = Cot ( Input IN × ( pi / 180)) × Amp


SEC

Calculating secant of radians IN.

Connection | Description
Input IN | Cannot be equal to PI/2 modulo PI. ( degree )
Parameter | Amp : Magnification Value range : -10000.00 ~ 10000.00
Output AQ | Secant of the input value multiply the value of Amp ( Output AQ = 32767 for invalid input )

Calculation rule

RADIAN = Degree × ( pi / 180)

Output AQ = Sec ( Input IN × ( pi / 180)) × Amp


CSC

Calculating cosecant of radians IN.

Connection | Description
Input IN | Cannot be equal to 0 modulo PI. ( degree )
Parameter | Amp : Magnification value range : -10000.00 ~ 10000.00
Output AQ | Cosecant of the input value multiply the value of Amp ( Output AQ = 32767 for invalid input )

Calculation rule

RADIAN = Degree × ( pi / 180)

Output AQ = Csc ( Input IN × ( pi / 180)) × Amp


Quadratic equation

Calculates the result of quadratic equation.

Connection | Description
Input Reset | Reset output to 0
Input y | Any integer value
Parameter | a,b,c : Any integer value ( a <> 0 ) Dir : Dir = 0 --> x = ( -b + sqrt(b2-4a(c-y))) / 2a Dir = 1 --> x = ( -b - sqrt(b2-4a(c-y))) / 2a Amp : Magnification Value range : -10000.00 ~ 10000.00
Output AQ | The x value(calculated) multiply the value of Amp

Calculation rule

y = ax2 + bx + c

--> ax2 + bx + (c-y) = 0

--> x = ( -b + sqrt(b2-4a(c-y)) ) / 2a or x = ( -b - sqrt(b2-4a(c-y)) ) / 2a

● If a = 0 , then x = 0 : AQ = 0

● If b2-4a(c-y) < 0 , then x = 0 : AQ = 0

● If b2-4a(c-y) > 0 , then x = (-b+sqrt(b2-4a(c-y)))/2a ( when Dir = 0 )

or x = (-b-sqrt(b2-4a(c-y)))/2a ( when Dir = 1 )

AQ = X x Amp


Data Log

You can configure Data Log to record the actual values of the function blocks and memory areas in circuit program. You can configure one data log per circuit program.

Connection | Description
Input En | The Data Log begins logging data with a positive edge (0 to 1 transition) at input En (Enable)

Configuring the Data Log

In circuit program, only one Data Log can be configured to record the actual values of function blocks, and the following memory areas:

● I

● Q

● M

● AI

● AQ

● AM

For digital I/O and memory, you must log data in groups of eight bits; for example: I0 to I7, Q8 to Q15, M16 to M23. For analog data, you select one value to be logged; for example: AI1, AQ2, or AM1.

You can log a maximum of 32 items (analog values or eight-bit digital groups) in the Data Log.

Data Log can only be configured from PC soft . The Data Log cannot be created, configured, or deleted from a 5/6 device.

Transferring the Data Log

After configuring the Data Log, the circuit program can be downloaded into the 5/6 series devices and transferred the Data Log to SD card as .CSV format.

.CSV file

There are maximum 2000 records of a csv file.

It will creat a new csv file automatically when the device turns to NML mode from INI mode.


Address Mapping_1x

1/2 Series Address Mapping

Supported Modbus Code: 01/02/05/15 ( Readable & writable in normal mode )

Address | Description | R/W | Note
00001 ~ 00032 | Main Digital Input Value ( I000 ~ I031) | R | (0/1)
00033 ~ 00064 | Ext1 Digital Input Value ( I100 ~ I131) | R | (0/1)
00065 ~ 00096 | Ext2 Digital Input Value ( I200 ~ I231) | R | (0/1)
00097 ~ 00128 | Ext3 Digital Input Value ( I300 ~ I331) | R | (0/1)
00129 ~ 00160 | Ext4 Digital Input Value ( I400 ~ I431) | R | (0/1)
00161 ~ 00192 | Ext5 Digital Input Value ( I500 ~ I531) | R | (0/1)
00193 ~ 00224 | Ext6 Digital Input Value ( I600 ~ I631) | R | (0/1)
00225 ~ 00256 | Ext7 Digital Input Value ( I700 ~ I731) | R | (0/1)
00257 ~ 00272 | Main Digital Output Value ( Q000 ~ Q016) | R | (0/1)
00273 ~ 00288 | EXT1 Digital Output Value ( Q100 ~ Q116) | R | (0/1)
00289 ~ 00304 | EXT2 Digital Output Value ( Q200 ~ Q216) | R | (0/1)
00305 ~ 00320 | EXT3 Digital Output Value ( Q300 ~ Q316) | R | (0/1)
00321 ~ 00336 | EXT4 Digital Output Value ( Q400 ~ Q416) | R | (0/1)
00337 ~ 00352 | EXT5 Digital Output Value ( Q500 ~ Q516) | R | (0/1)
00353 ~ 00368 | EXT6 Digital Output Value ( Q600 ~ Q616) | R | (0/1)
00369 ~ 00384 | EXT7 Digital Output Value ( Q700 ~ Q716) | R | (0/1)
00385 ~ 00896 | 0~511 Digital Flag (M0 ~ M511) | R | (0/1)
00897 ~ 00912 | 0~15 Shift register bit (S0 ~ S15 ) | R | (0/1)
00913 | Flag of SCAN Time | R | (0/1)

Supported Modbus Code: 01/02 ( Readable in normal mode )

Address | Description | R/W | Note
02001~02004 | Status of Function Block B0 | R |
02005~02008 | Status of Function Block B1 | R |
02009~02012 | Status of Function Block B2 | R |
…………………………………………………
06093~06096 | Status of Function Block B1023 | R |

Supported Modbus Code: 03/04 ( Readable in normal mode )

Address | Description | R/W | Note
40001 | Com0 model | R | 0x00 : Slave 0x01 : Master
40002 | Com0 protocol | R | 0x00 : RTU 0x01 : ASCII
40003 | Com0 device address | R | 1~255
40004 | Com0 baudrate | R | 0x00 : 1200 0x01 : 2400 0x02 : 4800 0x03 : 9600 0x04 : 14400 0x05 : 19200 0x06 : 28800 0x07 : 38400 0x08 : 57600 0x09 : 115200
40005 | Com0 parity | R | 0x00 : None 0x01 : Odd 0x02 : Even
40006 | Com0 data bit | R | 0x00 : 7-bit 0x01 : 8-bit
40007 | Com0 stop bit | R | 0x00 : 1-bit 0x01 : 2-bit
40008 | Com0 timeout | R | 50 ~ 65535 ms
40009 | Com0 delay between polls | R | 0 ~ 65535 ms
40010 | Com0 data register index | R | 0x00 : High Low 0x01:Low High
40011 | Com0 status flag | R |
40012 | Com1 model | R | 0x00 : Slave 0x01: Master
40013 | Com1 protocol | R | 0x00 : RTU 0x01 : ASCII
40014 | Com1 device address | R | 1~255
40015 | Com1 baudrate | R | 0x00 : 1200 0x01 : 2400 0x02 : 4800 0x03 : 9600 0x04 : 14400 0x05 : 19200 0x06 : 28800 0x07 : 38400 0x08 : 57600 0x09 : 115200
40016 | Com1 parity | R | 0x00 : None 0x01 : Odd 0x02 : Even
40017 | Com1 data bit | R | 0x00 : 7-bit 0x01 : 8-bit
40018 | Com1 stop bit | R | 0x00 : 1-bit 0x01 : 2-bit
40019 | Com1 timeout | R | 50 ~ 65535 ms
40020 | Com1 delay between polls | R | 0 ~ 65535 ms
40021 | Com1 data register index | R | 0x00 : High Low 0x01:Low High
40022 | Com1 status flag | R |
40023 | Com2 model | R | 0x00 : Slave 0x01 : Master
40024 | Com2 protocol | R | 0x00 : RTU 0x01 : ASCII
40025 | Com2 device address | R | 1~255
40026 | Com2 baudrate | R | 0x00 : 1200 0x01 : 2400 0x02 : 4800 0x03 : 9600 0x04 : 14400 0x05 : 19200 0x06 : 28800 0x07 : 38400 0x08 : 57600 0x09 : 115200
40027 | Com2 parity | R | 0x00 : None 0x01 : Odd 0x02 : Even
40028 | Com2 data bit | R | 0x00 : 7-bit 0x01 : 8-bit
40029 | Com2 stop bit | R | 0x00 : 1-bit 0x01 : 2-bit
40030 | Com2 timeout | R | 50 ~ 65535 ms
40031 | Com2 delay between polls | R | 0 ~ 65535 ms
40032 | Com2 data register index | R | 0x00 : High Low 0x01:Low High
40033 | Com2 status flag | R |

Supported Modbus Code: 03/04 ( Readable in normal mode )

Address | Description | R/W | Note
40211 | Module Name 1 | R | A-1188/1189 Ex:0x1188
40212 | Module Name 2 | R | 0x0000
40213 | Firmware Version 1 | R | A1.00 Ex:0xA100
40214 | Firmware Version 2 | R | 0x0000
40215 | Mac Serial Number 1 | R |
40216 | Mac Serial Number 2 | R |
40217 | Mac Serial Number 3 | R |
40218 | Mac Serial Number 4 | R |
40219 | Mac Serial Number 5 | R |
40220 | Mac Serial Number 6 | R |
40221 | Redundancy condition | R | 0x00: None 0x01:Master 0x02:Slave
40222 | Redundancy operating time (low word) (ms) | R | 0x0000 ~ 0xFFFF
40223 | Redundancy operating time (Hi word) (ms) | R | 0x0000 ~ 0xFFFF
40224 | LCM Control Register | R |
40225 | Machine internal tempature (度C) | R | -32768 ~ 32767
40226 | Controller Fault Status | R |
40227 | System Status 1 | R |
40228 | System Status 2 | R |
40229 | Scan Cycle Time (ms) | R | 1 ~ 65535
40230 | Redundancy status | R | 0x00 : stop 0x01:standby 0x02:active
40231 | Power On Hours (Hr) | R | 0~65535
40232 | COM0 communication success rate 次/分 | R | 0~65535
40233 | COM0 communication error rate 次/分 | R | 0~65535
40234 | COM1 communication success rate 次/分 | R | 0~65535
40235 | COM1 communication error rate 次/分 | R | 0~65535
40236 | COM2 communication success rate 次/分 | R | 0~65535
40237 | COM2 communication error rate 次/分 | R | 0~65535
40238 | COM3 communication success rate 次/分 | R | 0~65535
40239 | COM3 communication error rate 次/分 | R | 0~65535
40240 | COM4 communication success rate 次/分 | R | 0~65535
40241 | COM4 communication error rate 次/分 | R | 0~65535
40242 | COM5 communication success rate 次/分 | R | 0~65535
40243 | COM5 communication error rate 次/分 | R | 0~65535
40244 | COM6 communication success rate 次/分 | R | 0~65535
40245 | COM6 communication error rate 次/分 | R | 0~65535
40246 | COM7 communication success rate 次/分 | R | 0~65535
40247 | COM7 communication error rate 次/分 | R | 0~65535
40248 | Downloading number of times | R | 0~65535
40249 | History Temperature_min (度C) | R | -32768 ~ 32767
40250 | History Temperature_max (度C) | R | -32768 ~ 32767
40251 | High temperature protection point | R | -32768 ~ 32767
40252 | Low temperature protection point | R | -32768 ~ 32767
40253 | Power On Count (low word) | R | 0x0000 ~ 0xFFFF
40254 | Power On Count (high word) | R | 0x0000 ~ 0xFFFF
40255 | DOWNLOAD_STATUS | R | 0x00 : normal 0x01 : fail
40256 | Last shutdown time-Week_RTC | R | 0 ~ 6
40257 | Last shutdown time-Year_RTC | R | 2010 ~ 2036
40258 | Last shutdown time-Month_RTC | R | 1 ~ 12
40259 | Last shutdown time-Day_RTC | R | 1 ~ 31
40260 | Last shutdown time-Hour_RTC | R | 0 ~ 23
40261 | Last shutdown time-Min_RTC | R | 0 ~ 59
40262 | Last shutdown time-Sec_RTC | R | 0 ~ 59
40263 | RTC Calibrate sign | R | 0:plus 1:minus
40264 | RTC Calibrate value | R | 0 ~ 30 (sec/week)

Supported Modbus Code: 03/04 ( Readable in normal mode )

Address | Description | R/W | Note
40301 | Week_RTC | R | 0 ~ 6
40302 | Year_RTC | R | 2010 ~ 2036
40303 | Month_RTC | R | 1 ~ 12
40304 | Day_RTC | R | 1 ~ 31
40305 | Hour_RTC | R | 0 ~ 23
40306 | Min_RTC | R | 0 ~ 59
40307 | Sec_RTC | R | 0 ~ 59

Supported Modbus Code: 03/04 ( Readable in normal mode )

Address | Description | R/W | Note
40501 ~ 40508 | Main Analog Input Value ( AI000 ~ AI007 ) | R |
40509 ~ 40516 | EXT1 Analog Input Value ( AI100 ~ AI107 ) | R |
40517 ~ 40524 | EXT2 Analog Input Value ( AI200 ~ AI207 ) | R |
40525 ~ 40532 | EXT3 Analog Input Value ( AI300 ~ AI307 ) | R |
40533 ~ 40540 | EXT4 Analog Input Value ( AI400 ~ AI407 ) | R |
40541 ~ 40548 | EXT5 Analog Input Value ( AI500 ~ AI507 ) | R |
40549 ~ 40556 | EXT6 Analog Input Value ( AI600 ~ AI607 ) | R |
40557 ~ 40564 | EXT7 Analog Input Value ( AI700 ~ AI707 ) | R |
40565 ~ 40568 | Main Analog Output Value (AQ000 ~ AQ003) | R |
40569 ~ 40572 | EXT1 Analog Output Value (AQ100 ~ AQ103) | R |
40573 ~ 40576 | EXT2 Analog Output Value (AQ200 ~ AQ203) | R |
40577 ~ 40580 | EXT3 Analog Output Value (AQ300 ~ AQ303) | R |
40581 ~ 40584 | EXT4 Analog Output Value (AQ400 ~ AQ403) | R |
40585 ~ 40588 | EXT5 Analog Output Value (AQ500 ~ AQ503) | R |
40589 ~ 40592 | EXT6 Analog Output Value (AQ600 ~ AQ603) | R |
40593 ~ 40596 | EXT7 Analog Output Value (AQ700 ~ AQ703) | R |
40597 ~ 41108 | 0 ~ 511 Analog Flag Value ( AM0 ~ AM511) | R |

Supported Modbus Code: 03/04 ( Readable in normal mode )

Address | Description | R/W | Note
42001~42004 | Parameter of Function Block B0 | R |
42005~42008 | Parameter of Function Block B1 | R |
42009~42012 | Parameter of Function Block B2 | R |
…………………………………………………
46093~46096 | Parameter of Function Block B1023 | R |

Block Type | Address 1 | Address 2 | Address 3 | Address 4
AND | Block Output (0xxxx) | X | X | X
AND (Edge) | Block Output (0xxxx) | X | X | X
NAND | Block Output (0xxxx) | X | X | X
NAND (Edge) | Block Output (0xxxx) | X | X | X
OR | Block Output (0xxxx) | X | X | X
NOR | Block Output (0xxxx) | X | X | X
XOR | Block Output (0xxxx) | X | X | X
NOT | Block Output (0xxxx) | X | X | X
On-Delay | Block Output(0xxxx) | X | Timer (4xxxx) | X
Off-Delay | Block Output (0xxxx) | X | Timer (4xxxx) | X
On-/Off-Delay | Block Output (0xxxx) | X | Timer (4xxxx) | X
Retentive on-Delay | Block Output (0xxxx) | X | Timer (4xxxx) | X
Wiping relay (pulse output) | Block Output (0xxxx) | X | Timer (4xxxx) | X
Edge triggered wiping relay | Block Output (0xxxx) | X | Timer (4xxxx) | X
Asynchronous Pulse Generator | Block Output (0xxxx) | X | Timer (4xxxx) | X
Random Generator | Block Output (0xxxx) | X | Timer (4xxxx) | X
Stairway lighting switch | Block Output (0xxxx) | X | Timer (4xxxx) | X
Multiple function switch | Block Output (0xxxx) | X | Timer (4xxxx) | X
Weekly Timer | Block Output (0xxxx) | X | X | X
Yearly Timer | Block Output (0xxxx) | X | X | X
Up/Down counter | Block Output (0xxxx) | X | Count Value (l) (4xxxx) | Count Value (h) (4xxxx)
Hours Counter | Block Output (0xxxx) | X | MN Value (l) (4xxxx) | MN Value (h) (4xxxx)
Threshold trigger | Block Output (0xxxx) | X | Count Value (l) (4xxxx) | Count Value (h) (4xxxx)
Analog Comparator | Block Output (0xxxx) | X | Actual values(Ax-Ay) (l) (4xxxx) | Actual values(Ax-Ay) (h) (4xxxx)
Analog threshold trigger | Block Output (0xxxx) | X | Actual value Ax (l) (4xxxx) | Actual value Ax (h) (4xxxx)
Analog Amplifier | Block Output (4xxxx) | X | Actual value Ax (l) (4xxxx) | Actual value Ax (h) (4xxxx)
Analog watchdog | Block Output (0xxxx) | Actual value Aen (4xxxx) | Actual value Ax (l) (4xxxx) | Actual value Ax (h) (4xxxx)
Analog differential trigger | Block Output (0xxxx) | X | Actual value Ax (l) (4xxxx) | Actual value Ax (h) (4xxxx)
Latching Relay | Block Output (0xxxx) | X | X | X
Pulse Relay | Block Output (0xxxx) | X | X | X
Message texts | Block Output (0xxxx) | X | X | X
Shift register | Block Output (0xxxx) | X | Register Value (4xxxx) | X
Modbus Read | Block Output(0xxxx) | Count (4xxxx) | Data Address (4xxxx) | X
Modbus Write | Block Output(0xxxx) | Count (4xxxx) | Data1(Manual) / Data Address(Auto) (4xxxx) | Data2(Manual) (4xxxx)


Address Mapping _ 5x

5/6 Series Address Mapping

Supported Modbus Code: 01/02/05/15 ( Readable & writable in normal mode )

Address | Description | R/W | Note
00001 ~ 00032 | Main Digital Input Value ( I000 ~ I031) | R | (0/1)
00033 ~ 00064 | Ext1 Digital Input Value ( I100 ~ I131) | R | (0/1)
00065 ~ 00096 | Ext2 Digital Input Value ( I200 ~ I231) | R | (0/1)
00097 ~ 00128 | Ext3 Digital Input Value ( I300 ~ I331) | R | (0/1)
00129 ~ 00160 | Ext4 Digital Input Value ( I400 ~ I431) | R | (0/1)
00161 ~ 00192 | Ext5 Digital Input Value ( I500 ~ I531) | R | (0/1)
00193 ~ 00224 | Ext6 Digital Input Value ( I600 ~ I631) | R | (0/1)
00225 ~ 00256 | Ext7 Digital Input Value ( I700 ~ I731) | R | (0/1)
00257 ~ 00272 | Main Digital Output Value ( Q000 ~ Q016) | R | (0/1)
00273 ~ 00288 | EXT1 Digital Output Value ( Q100 ~ Q116) | R | (0/1)
00289 ~ 00304 | EXT2 Digital Output Value ( Q200 ~ Q216) | R | (0/1)
00305 ~ 00320 | EXT3 Digital Output Value ( Q300 ~ Q316) | R | (0/1)
00321 ~ 00336 | EXT4 Digital Output Value ( Q400 ~ Q416) | R | (0/1)
00337 ~ 00352 | EXT5 Digital Output Value ( Q500 ~ Q516) | R | (0/1)
00353 ~ 00368 | EXT6 Digital Output Value ( Q600 ~ Q616) | R | (0/1)
00369 ~ 00384 | EXT7 Digital Output Value ( Q700 ~ Q716) | R | (0/1)
00385 ~ 00896 | Digital Flag (M0 ~ M511) | R/W | (0/1)
00897 ~ 00960 | Shift register bit (S0.0 ~ S3.15 ) | R | (0/1)
01793 ~ 01808 | Function Key ( F000 ~ F015) | R/W | (0/1)

Supported Modbus Code: 01/02 ( Readable in normal mode )

Address | Description | R/W | Note
02001~02004 | Status of Function Block B0 | R | (0/1)
02005~02008 | Status of Function Block B1 | R | (0/1)
02009~02012 | Status of Function Block B2 | R | (0/1)
…………………………………………………
06093~06096 | Status of Function Block B1023 | R | (0/1)

Supported Modbus Code: 03/04 ( Readable in normal mode )

Address | Description | R/W | Note
40001 | Com0 model | R | 0 : Slave , 1 : Master
40002 | Com0 protocol | R | 0 : RTU , 1 : ASCII
40003 | Com0 device address | R | 1~255
40004 | Com0 baudrate | R | 0x00 :1200 0x01 : 2400 0x02 : 4800 0x03 :9600 0x04 : 14400 0x05 : 19200 0x06 :28800 0x07 : 38400 0x08 : 57600 0x09:115200 0x0a:230400 0x0b:460800
40005 | Com0 parity | R | 0 : None 1 : Odd 2 : Even
40006 | Com0 data bit | R | 0 : 7-bit 1 : 8-bit
40007 | Com0 stop bit | R | 0 : 1-bit 1 : 2-bit
40008 | Com0 timeout | R | 50 ~ 65535 ms
40009 | Com0 delay between polls | R | 0 ~ 65535 ms
40010 | Com0 data register index | R | 0 : High Low 1:Low High
40011 | Com0 status flag | R | status
40012 | Com1 model | R | 0 : Slave 1: Master
40013 | Com1 protocol | R | 0 : RTU 1 : ASCII
40014 | Com1 device address | R | 1~255
40015 | Com1 baudrate | R | 0x00 :1200 0x01 : 2400 0x02 : 4800 0x03 :9600 0x04 : 14400 0x05 : 19200 0x06 :28800 0x07 : 38400 0x08 : 57600 0x09:115200 0x0a:230400 0x0b:460800 0x0c:921600 0x0d:1843200 0x0e:3686400 0x0f: 4500000
40016 | Com1 parity | R | 0 : None 1 : Odd 2 : Even
40017 | Com1 data bit | R | 0 : 7-bit 1 : 8-bit
40018 | Com1 stop bit | R | 0 : 1-bit 1 : 2-bit
40019 | Com1 timeout | R | 50 ~ 65535 ms
40020 | Com1 delay between polls | R | 0 ~ 65535 ms
40021 | Com1 data register index | R | 0 : High Low 1:Low High
40022 | Com1 status flag | R | status
40023 | Com2 model | R | 0 : Slave 1 : Master
40024 | Com2 protocol | R | 0 : RTU 1 : ASCII
40025 | Com2 device address | R | 1~255
40026 | Com2 baudrate | R | 0x00 :1200 0x01 : 2400 0x02 : 4800 0x03 :9600 0x04 : 14400 0x05 : 19200 0x06 :28800 0x07 : 38400 0x08 : 57600 0x09:115200 0x0a:230400 0x0b:460800 0x0c:921600 0x0d:1843200 0x0e:3686400 0x0f: 4500000
40027 | Com2 parity | R | 0 : None 1 : Odd 2 : Even
40028 | Com2 data bit | R | 0 : 7-bit 1 : 8-bit
40029 | Com2 stop bit | R | 0 : 1-bit 1 : 2-bit
40030 | Com2 timeout | R | 50 ~ 65535 ms
40031 | Com2 delay between polls | R | 0 ~ 65535 ms
40032 | Com2 data register index | R | 0 : High Low 1:Low High
40033 | Com2 status flag | R | status

Supported Modbus Code: 03/04 ( Readable in normal mode )

Address | Description | R/W | Note
40211 | Module Name 1 | R | 5188/5189 series Ex:0x5188
40212 | Module Name 2 | R | 0x0000
40213 | Firmware Version 1 | R | C1.00 Ex:0xC100
40214 | Firmware Version 2 | R | 0x0000
40215 | Mac Serial Number 1 | R | Serial Number 1
40216 | Mac Serial Number 2 | R | Serial Number 2
40217 | Mac Serial Number 3 | R | Serial Number 3
40218 | Mac Serial Number 4 | R | Serial Number 4
40219 | Mac Serial Number 5 | R | Serial Number 5
40220 | Mac Serial Number 6 | R | Serial Number 6
40221 | Redundancy condition | R | 0: None 1:Master 2:Slave
40222 | Redundancy operating time (low word) (ms) | R | 0x0000 ~ 0xFFFF
40223 | Redundancy operating time (Hi word) (ms) | R | 0x0000 ~ 0xFFFF
40224 | LCM Control Register | R |
40225 | Machine internal tempature (°C) | R | -32768 ~ 32767
40226 | Controller Fault Status | R |
40227 | System Status 1 | R |
40228 | System Status 2 | R |
40229 | Scan Cycle Time (ms) | R | 1 ~ 65535
40230 | Redundancy status | R | 0 : stop 1:standby 2:active
40231 | Power On Hours (Hr) | R | 0~65535
40232 | COM0 communication success rate 次/分 | R | 0~65535
40233 | COM0 communication error rate 次/分 | R | 0~65535
40234 | COM1 communication success rate 次/分 | R | 0~65535
40235 | COM1 communication error rate 次/分 | R | 0~65535
40236 | COM2 communication success rate 次/分 | R | 0~65535
40237 | COM2 communication error rate 次/分 | R | 0~65535
40248 | Downloading number of times | R | 0~65535
40249 | History Temperature_min (°C) | R | -32768 ~ 32767
40250 | History Temperature_max (°C) | R | -32768 ~ 32767
40251 | High temperature protection point | R | -32768 ~ 32767
40252 | Low temperature protection point | R | -32768 ~ 32767
40253 | Power On Count (low word) | R | 0x0000 ~ 0xFFFF
40254 | Power On Count (high word) | R | 0x0000 ~ 0xFFFF
40255 | DOWNLOAD_STATUS | R | 0 : normal 1 : fail
40256 | Last shutdown time-Week_RTC | R | 0 ~ 6
40257 | Last shutdown time-Year_RTC | R | 2000 ~ 2099
40258 | Last shutdown time-Month_RTC | R | 1 ~ 12
40259 | Last shutdown time-Day_RTC | R | 1 ~ 31
40260 | Last shutdown time-Hour_RTC | R | 0 ~ 23
40261 | Last shutdown time-Min_RTC | R | 0 ~ 59
40262 | Last shutdown time-Sec_RTC | R | 0 ~ 59
40263 | RTC Calibrate sign | R | 0:plus 1:minus
40264 | RTC Calibrate value | R | 0 ~ 30 (sec/week)
40264 | Data Log status | R |

Supported Modbus Code: 03/04 ( Readable in normal mode )

Address | Description | R/W | Note
40301 | Week_RTC | R | 0 ~ 6
40302 | Year_RTC | R | 2000 ~ 2099
40303 | Month_RTC | R | 1 ~ 12
40304 | Day_RTC | R | 1 ~ 31
40305 | Hour_RTC | R | 0 ~ 23
40306 | Min_RTC | R | 0 ~ 59
40307 | Sec_RTC | R | 0 ~ 59

Supported Modbus Code: 03/04 ( Readable in normal mode )

Address | Description | R/W | Note
40341 ~ 40372 | AI Type | R |
40373 ~ 40500 | Extend modoule control | R |
40501 ~ 40508 | Main Analog Input Value ( AI000 ~ AI007 ) | R |
40509 ~ 40516 | EXT1 Analog Input Value ( AI100 ~ AI107 ) | R |
40517 ~ 40524 | EXT2 Analog Input Value ( AI200 ~ AI207 ) | R |
40525 ~ 40532 | EXT3 Analog Input Value ( AI300 ~ AI307 ) | R |
40533 ~ 40540 | EXT4 Analog Input Value ( AI400 ~ AI407 ) | R |
40541 ~ 40548 | EXT5 Analog Input Value ( AI500 ~ AI507 ) | R |
40549 ~ 40556 | EXT6 Analog Input Value ( AI600 ~ AI607 ) | R |
40557 ~ 40564 | EXT7 Analog Input Value ( AI700 ~ AI707 ) | R |
40565 ~ 40568 | Main Analog Output Value (AQ000 ~ AQ003) | R |
40569 ~ 40572 | EXT1 Analog Output Value (AQ100 ~ AQ103) | R |
40573 ~ 40576 | EXT2 Analog Output Value (AQ200 ~ AQ203) | R |
40577 ~ 40580 | EXT3 Analog Output Value (AQ300 ~ AQ303) | R |
40581 ~ 40584 | EXT4 Analog Output Value (AQ400 ~ AQ403) | R |
40585 ~ 40588 | EXT5 Analog Output Value (AQ500 ~ AQ503) | R |
40589 ~ 40592 | EXT6 Analog Output Value (AQ600 ~ AQ603) | R |
40593 ~ 40596 | EXT7 Analog Output Value (AQ700 ~ AQ703) | R |
40597 ~ 41108 | Analog Flag Value ( AM0 ~ AM511) | R/W |
41109 ~ 41124 | AQ type | R | 0: 0~10V or 0~20mA 1: 4~20mA

Supported Modbus Code: 03/04 ( Readable in normal mode )

Address | Description |  | R/W | Note
42001~42004 | Parameter of Function Block B0 |  | R |
42005~42008 | Parameter of Function Block B1 |  | R |
42009~42012 | Parameter of Function Block B2 |  | R |
…………………………………………………
46093~46096 | Parameter of Function Block B1023 | R |  |

Block Type | Address 1 | Address 2 | Address 3 | Address 4
AND | Block Output (0xxxx) | X | X | X
AND (Edge) | Block Output (0xxxx) | X | X | X
NAND | Block Output (0xxxx) | X | X | X
NAND (Edge) | Block Output (0xxxx) | X | X | X
OR | Block Output (0xxxx) | X | X | X
NOR | Block Output (0xxxx) | X | X | X
XOR | Block Output (0xxxx) | X | X | X
NOT | Block Output (0xxxx) | X | X | X
On-Delay | Block Output(0xxxx) | X | Timer (4xxxx) | X
Off-Delay | Block Output (0xxxx) | X | Timer (4xxxx) | X
On-/Off-Delay | Block Output (0xxxx) | X | Timer (4xxxx) | X
Retentive on-Delay | Block Output (0xxxx) | X | Timer (4xxxx) | X
Wiping relay (pulse output) | Block Output (0xxxx) | X | Timer (4xxxx) | X
Edge triggered wiping relay | Block Output (0xxxx) | X | Timer (4xxxx) | X
Asynchronous Pulse Generator | Block Output (0xxxx) | X | Timer (4xxxx) | X
Random Generator | Block Output (0xxxx) | X | Timer (4xxxx) | X
Stairway lighting switch | Block Output (0xxxx) | X | Timer (4xxxx) | X
Multiple function switch | Block Output (0xxxx) | X | Timer (4xxxx) | X
Weekly Timer | Block Output (0xxxx) | X | X | X
Yearly Timer | Block Output (0xxxx) | X | X | X
Astronomical_Clock | Block Output (0xxxx) | X | Sunrise (4xxxx) | Sunset (4xxxx)
Stopwatch | Block Output (4xxxx) | CurT (4xxxx) | OutT (l) (4xxxx) | OutT (h) (4xxxx)
Up/Down counter | Block Output (0xxxx) | X | Count Value (l) (4xxxx) | Count Value (h) (4xxxx)
Hours Counter | Block Output (0xxxx) | X | MN Value (l) (4xxxx) | MN Value (h) (4xxxx)
Threshold trigger | Block Output (0xxxx) | X | Fre (l) (4xxxx) | Fre (h) (4xxxx)
Analog_Math | Block Output (4xxxx) | Status (4xxxx) | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
Analog Comparator | Block Output (0xxxx) | X | Actual value(Ax-Ay) (l) (4xxxx) | Actual values(Ax-Ay) (h) (4xxxx)
Analog threshold trigger | Block Output (0xxxx) | X | Actual value Ax (l) (4xxxx) | Actual value Ax (h) (4xxxx)
Analog Amplifier | Block Output (4xxxx) | X | Actual value Ax (l) (4xxxx) | Actual value Ax (h) (4xxxx)
Analog watchdog | Block Output (0xxxx) | Actual value Aen (4xxxx) | Actual value Ax (l) (4xxxx) | Actual value Ax (h) (4xxxx)
Analog differential trigger | Block Output (0xxxx) | X | Actual value Ax (l) (4xxxx) | Actual value Ax (h) (4xxxx)
Analog_MUX | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
Analog_Ramp | Block Output (4xxxx) | CurL (4xxxx) | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
PI_Controller | Block Output (4xxxx) | PV (4xxxx) | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
PWM | Block Output (0xxxx) | Periodic time (4xxxx) | Range Max.(4xxxx) | Range Min.(4xxxx)
Analog_Filter | Block Output (4xxxx) | Ax (4xxxx) | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
MAX_MIN | Block Output (4xxxx) | Ax (4xxxx) | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
Average_Value | Block Output (4xxxx) | Cycle (4xxxx) | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
Latching Relay | Block Output (0xxxx) | X | X | X
Pulse Relay | Block Output (0xxxx) | X | X | X
Message texts | Block Output (0xxxx) | X | X | X
Shift register | Block Output (0xxxx) | X | Register Value (4xxxx) | X
Math_Detection | Block Output (0xxxx) | Status (4xxxx) | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
Modbus Read | Block Output(0xxxx) | Count (4xxxx) | Data Address (4xxxx) | X
Modbus Write | Block Output(0xxxx) | Count (4xxxx) | Data1(Manual) / Data Address(Auto) (4xxxx) | Data2(Manual) (4xxxx)
Boolean function | Block Output(0xxxx) | Setting (4xxxx) | X | X
TDT | Block Output(0xxxx) | time_MS (4xxxx) | time_DH (4xxxx) | time_YM (4xxxx)
BCD | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
BIN | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
ROL | Block Output (4xxxx) | NbR (4xxxx) | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
ROR | Block Output (4xxxx) | NbR (4xxxx) | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
SHL | Block Output (4xxxx) | NbS (4xxxx) | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
SHR | Block Output (4xxxx) | NbS (4xxxx) | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
AND_MASK_WORD | Block Output (4xxxx) | Mask (4xxxx) | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
OR_MASK_WORD | Block Output (4xxxx) | Mask (4xxxx) | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
NOT_MASK_WORD | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
NAND_MASK_WORD | Block Output (4xxxx) | Mask (4xxxx) | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
NOR_MASK_WORD | Block Output (4xxxx) | Mask (4xxxx) | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
XOR_MASK_WORD | Block Output (4xxxx) | Mask (4xxxx) | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
ARRMX_MI_AV | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
ACMX_MI_AV | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
RNAD | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
ODD | Block Output(0xxxx) | X | X | X
EVEN | Block Output(0xxxx) | X | X | X
MOD | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
REM | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
LOG | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
SQRT | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
ABS | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
GCD | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
LCM | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
POW2 | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
EXP | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
FIX | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
ROUND | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
SIN | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
COS | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
TAN | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
COT | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
SEC | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
CSC | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
MEM | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
Quadratic_equation | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
ENCODER | Block Output (0xxxx) | X | CNT(l) (4xxxx) | CNT(h) (4xxxx)
SMC | Block Output(0xxxx) | X | X | X
SMCE | Block Output(0xxxx) | X | X | X
PTO | Block Output(0xxxx) | X | X | X
PTOE | Block Output(0xxxx) | X | X | X
SEG | Block Output (4xxxx) | X | Actual value AQ(l) (4xxxx) | Actual value AQ (h) (4xxxx)
Word2Bit | Block Output(0xxxx) | Nb (4xxxx) | X | X
UDC | Block Output(0xxxx) | Cycle_Setting (4xxxx) | Cycle (l) (4xxxx) | Cycle (h) (4xxxx)
CRC16 | Block Output (4xxxx) | X | X | X

52 Series only :

● Server mode :

Supported Modbus Code: 01/02 ( Readable in normal mode )

Address | Description | R/W | Note | Device
07001 ~ 07032 | ID0 Input ( 0 ~ 31 ) | R | (0/1) | Server ( Device ID = 0)
07033 ~ 07064 | ID1 Input ( 0 ~ 31 ) | R | (0/1) | Station ( Device ID = 1)
07065 ~ 07096 | ID2 Input ( 0 ~ 31 ) | R | (0/1) | Station ( Device ID = 2)
07097 ~ 07128 | ID3 Input ( 0 ~ 31 ) | R | (0/1) | Station ( Device ID = 3)
07129 ~ 07160 | ID4 Input ( 0 ~ 31 ) | R | (0/1) | Station ( Device ID = 4)
07161 ~ 07192 | ID5 Input ( 0 ~ 31 ) | R | (0/1) | Station ( Device ID = 5)
07193 ~ 07224 | ID6 Input ( 0 ~ 31 ) | R | (0/1) | Station ( Device ID = 6)
07225 ~ 07256 | ID7 Input ( 0 ~ 31 ) | R | (0/1) | Station ( Device ID = 7)

07257 ~ 07272 | ID0 Output ( 0 ~ 15 ) | R | (0/1) | Server ( Device ID = 0)
07273 ~ 07288 | ID1 Output ( 0 ~ 15 ) | R | (0/1) | Station ( Device ID = 1)
07289 ~ 07304 | ID2 Output ( 0 ~ 15 ) | R | (0/1) | Station ( Device ID = 2)
07305 ~ 07320 | ID3 Output ( 0 ~ 15 ) | R | (0/1) | Station ( Device ID = 3)
07321 ~ 07336 | ID4 Output ( 0 ~ 15 ) | R | (0/1) | Station ( Device ID = 4)
07337 ~ 07352 | ID5 Output ( 0 ~ 15 ) | R | (0/1) | Station ( Device ID = 5)
07353 ~ 07368 | ID6 Output ( 0 ~ 15 ) | R | (0/1) | Station ( Device ID = 6)
07369 ~ 07384 | ID7 Output ( 0 ~ 15 ) | R | (0/1) | Station ( Device ID = 7)

07385 ~ 07416 | ID0 VM ( 0~31 ) | R | (0/1) | Server ( Device ID = 0)
07417~ 07448 | ID1 VM ( 0~31) | R | (0/1) | Group ( Device ID = 1)
07449 ~ 07480 | ID2 VM ( 0~31) | R | (0/1) | Group ( Device ID = 2)
07481 ~ 07512 | ID3 VM ( 0~31) | R | (0/1) | Group ( Device ID = 3)
07513 ~ 07544 | ID4 VM ( 0~31) | R | (0/1) | Group ( Device ID = 4)
07545 ~ 07576 | ID5 VM ( 0~31) | R | (0/1) | Group ( Device ID = 5)
07577 ~ 07608 | ID6 VM ( 0~31) | R | (0/1) | Group ( Device ID = 6)
07609~ 07640 | ID7 VM ( 0~31) | R | (0/1) | Group ( Device ID = 7)

09434 | ID1 Wifi status | R | (0/1) | Station / Group ( Device ID = 1)
09435 | ID2 Wifi status | R | (0/1) | Station / Group ( Device ID = 2)
09436 | ID3 Wifi status | R | (0/1) | Station / Group ( Device ID = 3)
09437 | ID4 Wifi status | R | (0/1) | Station / Group ( Device ID = 4)
09438 | ID5 Wifi status | R | (0/1) | Station / Group ( Device ID = 5)
09439 | ID6 Wifi status | R | (0/1) | Station / Group ( Device ID = 6)
09440 | ID7 Wifi status | R | (0/1) | Station / Group ( Device ID = 7)

Supported Modbus Code: 03/04 ( Readable in normal mode )

Address | Description | R/W | Note | Device
47001 ~ 47008 | ID0 Analog Input ( 0 ~ 7 ) | R |  | Server ( Device ID = 0)
47009 ~ 47016 | ID1 Analog Input ( 0 ~ 7 ) | R |  | Station ( Device ID = 1)
47017 ~ 47024 | ID2 Analog Input ( 0 ~ 7 ) | R |  | Station ( Device ID = 2)
47025 ~ 47032 | ID3 Analog Input ( 0 ~ 7 ) | R |  | Station ( Device ID = 3)
47033 ~ 47040 | ID4 Analog Input ( 0 ~ 7 ) | R |  | Station ( Device ID = 4)
47041 ~ 47048 | ID5 Analog Input ( 0 ~ 7 ) | R |  | Station ( Device ID = 5)
47049 ~ 47056 | ID6 Analog Input ( 0 ~ 7 ) | R |  | Station ( Device ID = 6)
47057 ~ 47064 | ID7 Analog Input ( 0 ~ 7 ) | R |  | Station ( Device ID = 7)

47065 ~ 47068 | ID0 Analog Output ( 0 ~ 3 ) | R | Server ( Device ID = 0)
47069 ~ 47072 | ID1 Analog Output ( 0 ~ 3 ) | R | Station ( Device ID = 1)
47073 ~ 47076 | ID2 Analog Output ( 0 ~ 3 ) | R | Station ( Device ID = 2)
47077 ~ 47080 | ID3 Analog Output ( 0 ~ 3 ) | R | Station ( Device ID = 3)
47081 ~ 47084 | ID4 Analog Output ( 0 ~ 3 ) | R | Station ( Device ID = 4)
47085 ~ 47088 | ID5 Analog Output ( 0 ~ 3 ) | R | Station ( Device ID = 5)
47089 ~ 47092 | ID6 Analog Output ( 0 ~ 3 ) | R | Station ( Device ID = 6)
47093 ~ 47096 | ID7 Analog Output ( 0 ~ 3 ) | R | Station ( Device ID = 7)

47097 ~ 47352 | ID0 VAM ( 0~31) | R | Server ( Device ID = 0)
47353 ~ 47608 | ID1 VAM ( 0~31) | R | Group ( Device ID = 1)
47609 ~ 47864 | ID2 VAM ( 0~31) | R | Group ( Device ID = 2)
47865 ~ 48120 | ID3 VAM ( 0~31) | R | Group ( Device ID = 3)
48121 ~ 48376 | ID4 VAM ( 0~31) | R | Group ( Device ID = 4)
48377 ~ 48632 | ID5 VAM ( 0~31) | R | Group ( Device ID = 5)
48633 ~ 48888 | ID6 VAM ( 0~31) | R | Group ( Device ID = 6)
48889 ~ 49144 | ID7 VAM ( 0~31) | R | Group ( Device ID = 7)

● Remote mode :

Supported Modbus Code: 01/02 ( Readable in normal mode )

Address | Description | R/W | Note | Device
07001 ~ 07032 | Input ( 0 ~ 31 ) | R | (0/1) | Remote
07257 ~ 07272 | Output ( 0 ~ 15 ) | R | (0/1) | Remote

Supported Modbus Code: 03/04 ( Readable in normal mode )

Address | Description | R/W | Note | Device
47001 ~ 47008 | Analog Input ( 0 ~ 7 ) | R |  | Remote
47065 ~ 47068 | Analog Output ( 0 ~ 3 ) | R |  | Remote

● Slave mode :

Supported Modbus Code: 01/02 ( Readable in normal mode )

Address | Description | R/W | Note | Device
07001 ~ 07032 | Input ( 0 ~ 31 ) | R | (0/1) | Slave
07257 ~ 07272 | Output ( 0 ~ 15 ) | R | (0/1) | Slave

Supported Modbus Code: 03/04 ( Readable in normal mode )

Address | Description | R/W | Note | Device
47001 ~ 47008 | Analog Input ( 0 ~ 7 ) | R |  | Slave
47065 ~ 47068 | Analog Output ( 0 ~ 3 ) | R |  | Slave